summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-01-07 02:50:56 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-01-07 02:50:56 +0000
commit58dfc9ba077a9e0f6ec9e0f9e00076c55c8e46b7 (patch)
tree24c29a73794829fbb1a4a23ef87ed9eaa7266ea4 /sci-libs/geos/geos-3.2.0.ebuild
parentVersion bump (diff)
downloadgentoo-2-58dfc9ba077a9e0f6ec9e0f9e00076c55c8e46b7.tar.gz
gentoo-2-58dfc9ba077a9e0f6ec9e0f9e00076c55c8e46b7.tar.bz2
gentoo-2-58dfc9ba077a9e0f6ec9e0f9e00076c55c8e46b7.zip
Version bump and removed useless .la files (bug #298887)
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/geos/geos-3.2.0.ebuild')
-rw-r--r--sci-libs/geos/geos-3.2.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-libs/geos/geos-3.2.0.ebuild b/sci-libs/geos/geos-3.2.0.ebuild
new file mode 100644
index 000000000000..2f98e49cff40
--- /dev/null
+++ b/sci-libs/geos/geos-3.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.2.0.ebuild,v 1.1 2010/01/07 02:50:56 bicatali Exp $
+
+EAPI=2
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="http://geos.refractions.net"
+SRC_URI="http://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc python ruby"
+
+RDEPEND="ruby? ( virtual/ruby )
+ python? ( virtual/python )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ ruby? ( dev-lang/swig )
+ python? ( dev-lang/swig )"
+
+src_configure() {
+ econf $(use_enable python) $(use_enable ruby)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ cd "${S}/doc"
+ emake doxygen-html || die "doc generation failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}"usr/lib*/python*/site-packages/geos/_geos.*a || die
+ dodoc AUTHORS NEWS README TODO
+ if use doc; then
+ cd "${S}/doc"
+ dohtml -r doxygen_docs/html/* || die
+ fi
+}