summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-02 08:19:02 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-02 08:19:02 +0000
commit1d38b761e1ec15c246e61b28a0062479751e9ad5 (patch)
tree7606b3e9938146126d0c50c668254f1b07c17b56 /sci-libs/gamer/gamer-1.4.ebuild
parentFixed automagic doxygen usage (diff)
downloadgentoo-2-1d38b761e1ec15c246e61b28a0062479751e9ad5.tar.gz
gentoo-2-1d38b761e1ec15c246e61b28a0062479751e9ad5.tar.bz2
gentoo-2-1d38b761e1ec15c246e61b28a0062479751e9ad5.zip
Fixed automagic doxygen usage
(Portage version: 2.2.0_alpha2/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/gamer/gamer-1.4.ebuild')
-rw-r--r--sci-libs/gamer/gamer-1.4.ebuild23
1 files changed, 17 insertions, 6 deletions
diff --git a/sci-libs/gamer/gamer-1.4.ebuild b/sci-libs/gamer/gamer-1.4.ebuild
index ea3b6f633c5f..3460016530db 100644
--- a/sci-libs/gamer/gamer-1.4.ebuild
+++ b/sci-libs/gamer/gamer-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gamer/gamer-1.4.ebuild,v 1.1 2010/11/01 14:30:16 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gamer/gamer-1.4.ebuild,v 1.2 2010/11/02 08:19:02 jlec Exp $
EAPI="3"
@@ -13,21 +13,30 @@ SRC_URI="http://www.fetk.org/codes/download/${P}.tar.gz"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
LICENSE="GPL-2"
-IUSE=""
+IUSE="doc"
-RDEPEND="dev-libs/maloc"
-DEPEND="${RDEPEND}"
+RDEPEND=">=dev-libs/maloc-1.4"
+DEPEND="
+ ${RDEPEND}
+ doc? (
+ media-gfx/graphviz
+ app-doc/doxygen )"
S="${WORKDIR}"/${PN}
src_prepare() {
- epatch "${FILESDIR}"/${PV}-multilib.patch
+ epatch \
+ "${FILESDIR}"/${PV}-multilib.patch \
+ "${FILESDIR}"/${PV}-doc.patch
eautoreconf
}
src_configure() {
local fetk_include
local fetk_lib
+ local myconf
+
+ use doc || myconf="${myconf} --with-doxygen= --with-dot="
fetk_include="${EPREFIX}"/usr/include
fetk_lib="${EPREFIX}"/usr/$(get_libdir)
@@ -35,8 +44,10 @@ src_configure() {
export FETK_LIBRARY="${fetk_lib}"
econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
--disable-triplet \
- --enable-shared
+ --enable-shared \
+ ${myconf}
}
src_install() {