summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-03-09 16:45:31 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-03-09 16:45:31 +0000
commit5ede04f72ab36753b1893fb8eac088adeeb6d6a2 (patch)
tree6552c06a15d163f544b8c69764aba2b7df2f6752 /sci-libs/csparse
parentAdd live cvs version (diff)
downloadgentoo-2-5ede04f72ab36753b1893fb8eac088adeeb6d6a2.tar.gz
gentoo-2-5ede04f72ab36753b1893fb8eac088adeeb6d6a2.tar.bz2
gentoo-2-5ede04f72ab36753b1893fb8eac088adeeb6d6a2.zip
Version bump. Fixed collision with cxsparse, rse, fixing bug #246589
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/csparse')
-rw-r--r--sci-libs/csparse/ChangeLog12
-rw-r--r--sci-libs/csparse/csparse-2.2.1-r1.ebuild (renamed from sci-libs/csparse/csparse-2.2.1.ebuild)10
-rw-r--r--sci-libs/csparse/csparse-2.2.2.ebuild35
-rw-r--r--sci-libs/csparse/files/csparse-2.2.2-autotools.patch59
4 files changed, 112 insertions, 4 deletions
diff --git a/sci-libs/csparse/ChangeLog b/sci-libs/csparse/ChangeLog
index 90bf19cad48c..f541d92378e1 100644
--- a/sci-libs/csparse/ChangeLog
+++ b/sci-libs/csparse/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/csparse
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/csparse/ChangeLog,v 1.1 2008/02/05 18:44:59 bicatali Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/csparse/ChangeLog,v 1.2 2009/03/09 16:45:31 bicatali Exp $
+
+*csparse-2.2.2 (09 Mar 2009)
+*csparse-2.2.1-r1 (09 Mar 2009)
+
+ 09 Mar 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/csparse-2.2.2-autotools.patch, -csparse-2.2.1.ebuild,
+ +csparse-2.2.1-r1.ebuild, +csparse-2.2.2.ebuild:
+ Version bump. Fixed collision with cxsparse, rse, fixing bug #246589
*csparse-2.2.1 (05 Feb 2008)
diff --git a/sci-libs/csparse/csparse-2.2.1.ebuild b/sci-libs/csparse/csparse-2.2.1-r1.ebuild
index 5e846e9af952..1a148153baaa 100644
--- a/sci-libs/csparse/csparse-2.2.1.ebuild
+++ b/sci-libs/csparse/csparse-2.2.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/csparse/csparse-2.2.1.ebuild,v 1.1 2008/02/05 18:44:59 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/csparse/csparse-2.2.1-r1.ebuild,v 1.1 2009/03/09 16:45:31 bicatali Exp $
inherit autotools eutils
@@ -24,6 +24,12 @@ src_unpack() {
eautoreconf
}
+src_compile() {
+ # avoid collision with cxsparse
+ econf --includedir="/usr/include/csparse"
+ emake || die "emake failed"
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc README.txt Doc/ChangeLog || die "dodoc failed"
diff --git a/sci-libs/csparse/csparse-2.2.2.ebuild b/sci-libs/csparse/csparse-2.2.2.ebuild
new file mode 100644
index 000000000000..6f45cc77748e
--- /dev/null
+++ b/sci-libs/csparse/csparse-2.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/csparse/csparse-2.2.2.ebuild,v 1.1 2009/03/09 16:45:31 bicatali Exp $
+
+EAPI=2
+inherit autotools eutils
+
+MY_PN=CSparse
+DESCRIPTION="Concise sparse matrix package."
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/CSparse"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${MY_PN}/versions/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ eautoreconf
+}
+
+src_configure() {
+ # avoid collision with cxsparse
+ econf --includedir="/usr/include/csparse"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt Doc/ChangeLog || die "dodoc failed"
+}
diff --git a/sci-libs/csparse/files/csparse-2.2.2-autotools.patch b/sci-libs/csparse/files/csparse-2.2.2-autotools.patch
new file mode 100644
index 000000000000..dc2846c66994
--- /dev/null
+++ b/sci-libs/csparse/files/csparse-2.2.2-autotools.patch
@@ -0,0 +1,59 @@
+--- configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ configure.ac 2008-01-30 18:34:40.659910749 +0000
+@@ -0,0 +1,10 @@
++# -*- Autoconf -*-
++AC_PREREQ(2.59)
++AC_INIT(csparse, 2.2.3, davis@cise.ufl.edu)
++AM_INIT_AUTOMAKE([foreign])
++AC_PROG_INSTALL
++AC_PROG_LIBTOOL
++AC_CHECK_LIB(m, sqrt)
++AC_CHECK_HEADERS(UFconfig.h)
++AC_CONFIG_FILES([Makefile Source/Makefile Demo/Makefile])
++AC_OUTPUT
+--- Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Makefile.am 2008-01-30 18:35:32.154594734 +0000
+@@ -0,0 +1,4 @@
++SUBDIRS = Source Demo
++EXTRA_DIST = README.txt
++include_HEADERS = Include/cs.h
++
+--- Source/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Source/Makefile.am 2008-01-30 18:45:50.337822988 +0000
+@@ -0,0 +1,12 @@
++AM_CPPFLAGS = -I$(top_builddir)/Include
++lib_LTLIBRARIES = libcsparse.la
++libcsparse_la_SOURCES = \
++ cs_add.c cs_amd.c cs_chol.c cs_cholsol.c cs_counts.c cs_cumsum.c \
++ cs_droptol.c cs_dropzeros.c cs_dupl.c cs_entry.c \
++ cs_etree.c cs_fkeep.c cs_gaxpy.c cs_happly.c cs_house.c cs_ipvec.c \
++ cs_lsolve.c cs_ltsolve.c cs_lu.c cs_lusol.c cs_util.c cs_multiply.c \
++ cs_permute.c cs_pinv.c cs_post.c cs_pvec.c cs_qr.c cs_qrsol.c \
++ cs_scatter.c cs_schol.c cs_sqr.c cs_symperm.c cs_tdfs.c cs_malloc.c \
++ cs_transpose.c cs_compress.c cs_usolve.c cs_utsolve.c cs_scc.c \
++ cs_maxtrans.c cs_dmperm.c cs_updown.c cs_print.c cs_norm.c cs_load.c \
++ cs_dfs.c cs_reach.c cs_spsolve.c cs_ereach.c cs_leaf.c cs_randperm.c
+--- Demo/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Demo/Makefile.am 2008-01-31 11:11:28.880545257 +0000
+@@ -0,0 +1,21 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++LDADD = $(top_builddir)/Source/libcsparse.la -lm
++
++check_PROGRAMS = cs_demo1 cs_demo2 cs_demo3
++
++check-local: $(check_PROGRAMS)
++ - ./cs_demo1 < ../Matrix/t1
++ - ./cs_demo2 < ../Matrix/t1
++ - ./cs_demo2 < ../Matrix/ash219
++ - ./cs_demo2 < ../Matrix/bcsstk01
++ - ./cs_demo2 < ../Matrix/fs_183_1
++ - ./cs_demo2 < ../Matrix/mbeacxc
++ - ./cs_demo2 < ../Matrix/west0067
++ - ./cs_demo2 < ../Matrix/lp_afiro
++ - ./cs_demo2 < ../Matrix/bcsstk16
++ - ./cs_demo3 < ../Matrix/bcsstk01
++ - ./cs_demo3 < ../Matrix/bcsstk16
++
++cs_demo1_SOURCE = cs_demo1.c
++cs_demo2_SOURCES= cs_demo2.c cs_demo.c cs_demo.h
++cs_demo3_SOURCES = cs_demo3.c cs_demo.c cs_demo.h