summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-09-06 17:08:46 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-09-06 17:08:46 +0000
commit2dd590ef2ca4851c6b2aeaff2f2227ebf0180ffc (patch)
treeaea923754351fd7f1c17e642491a3e7a9bfd9f3c /sci-libs/colpack
parentAdd initscript for rrdcached, thanks to slepnoga (diff)
downloadgentoo-2-2dd590ef2ca4851c6b2aeaff2f2227ebf0180ffc.tar.gz
gentoo-2-2dd590ef2ca4851c6b2aeaff2f2227ebf0180ffc.tar.bz2
gentoo-2-2dd590ef2ca4851c6b2aeaff2f2227ebf0180ffc.zip
Version bump
(Portage version: 2.2.01.20894-prefix/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/colpack')
-rw-r--r--sci-libs/colpack/ChangeLog8
-rw-r--r--sci-libs/colpack/colpack-1.0.8.ebuild43
2 files changed, 49 insertions, 2 deletions
diff --git a/sci-libs/colpack/ChangeLog b/sci-libs/colpack/ChangeLog
index 61abf70cb91d..d01409bd925a 100644
--- a/sci-libs/colpack/ChangeLog
+++ b/sci-libs/colpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/colpack
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/colpack/ChangeLog,v 1.2 2012/06/28 23:39:16 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/colpack/ChangeLog,v 1.3 2012/09/06 17:08:46 bicatali Exp $
+
+*colpack-1.0.8 (06 Sep 2012)
+
+ 06 Sep 2012; Sébastien Fabbro <bicatali@gentoo.org> +colpack-1.0.8.ebuild:
+ Version bump
28 Jun 2012; Sebastien Fabbro <fabbros@gentoo.org> colpack-1.0.6.ebuild:
keyword amd64-linux and x86-linux. cleaned up openmp check
@@ -10,4 +15,3 @@
13 Apr 2012; Sébastien Fabbro <bicatali@gentoo.org> +colpack-1.0.6.ebuild,
+files/colpack-1.0.6-flags.patch, +metadata.xml:
Initial import
-
diff --git a/sci-libs/colpack/colpack-1.0.8.ebuild b/sci-libs/colpack/colpack-1.0.8.ebuild
new file mode 100644
index 000000000000..66133beb1ad0
--- /dev/null
+++ b/sci-libs/colpack/colpack-1.0.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/colpack/colpack-1.0.8.ebuild,v 1.1 2012/09/06 17:08:46 bicatali Exp $
+
+EAPI=4
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils toolchain-funcs autotools-utils
+
+MYPN=ColPack
+
+DESCRIPTION="C++ algorithms for specialized vertex coloring problems"
+LICENSE="GPL-3 LGPL-3"
+HOMEPAGE="http://www.cscapes.org/coloringpage/software.htm"
+SRC_URI="http://www.cscapes.org/download/${MYPN}/${MYPN}-${PV}.tar.gz"
+
+SLOT="0"
+IUSE="openmp static-libs"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYPN}-${PV}"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.0.6-flags.patch )
+
+pkg_setup() {
+ if use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp; then
+ ewarn "You are using gcc without OpenMP"
+ die "Need an OpenMP capable compiler"
+ fi
+}
+
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable openmp)
+ )
+ autotools-utils_src_configure
+}