summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-02-19 16:21:10 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-02-19 16:21:10 +0000
commit40186d0e33b5f20ac827fe65fb2e2514ec94bb70 (patch)
tree99ce3933fe597e3a38d6a0aece9207f234122178 /sci-libs/blas-goto
parentChanged the description in an attempt to keep people from breaking their X co... (diff)
downloadgentoo-2-40186d0e33b5f20ac827fe65fb2e2514ec94bb70.tar.gz
gentoo-2-40186d0e33b5f20ac827fe65fb2e2514ec94bb70.tar.bz2
gentoo-2-40186d0e33b5f20ac827fe65fb2e2514ec94bb70.zip
blas-goto-1.11 version bump.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sci-libs/blas-goto')
-rw-r--r--sci-libs/blas-goto/ChangeLog9
-rw-r--r--sci-libs/blas-goto/blas-goto-1.11.ebuild141
-rw-r--r--sci-libs/blas-goto/files/digest-blas-goto-1.113
-rw-r--r--sci-libs/blas-goto/metadata.xml9
4 files changed, 161 insertions, 1 deletions
diff --git a/sci-libs/blas-goto/ChangeLog b/sci-libs/blas-goto/ChangeLog
index 94581cfb8863..6938aab29263 100644
--- a/sci-libs/blas-goto/ChangeLog
+++ b/sci-libs/blas-goto/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/blas-goto
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/ChangeLog,v 1.3 2007/01/08 02:29:53 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/ChangeLog,v 1.4 2007/02/19 16:21:09 bicatali Exp $
+
+*blas-goto-1.11 (19 Feb 2007)
+
+ 19 Feb 2007; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ +blas-goto-1.11.ebuild:
+ Version bump. Also fixed for LDFLAGS such as as-needed, and tested on
+ amd64. Added a longdescription on metadata.xml.
08 Jan 2007; Danny van Dyk <kugelfang@gentoo.org> -blas-goto-1.08.ebuild:
QA: Removed unused versions.
diff --git a/sci-libs/blas-goto/blas-goto-1.11.ebuild b/sci-libs/blas-goto/blas-goto-1.11.ebuild
new file mode 100644
index 000000000000..97b9f8903066
--- /dev/null
+++ b/sci-libs/blas-goto/blas-goto-1.11.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/blas-goto-1.11.ebuild,v 1.1 2007/02/19 16:21:09 bicatali Exp $
+
+inherit eutils fortran flag-o-matic toolchain-funcs
+
+MY_PN="GotoBLAS"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="The fastest implementations of the Basic Linear Algebra Subroutines"
+HOMEPAGE="http://www.tacc.utexas.edu/resources/software/software.php"
+SRC_URI="http://www.tacc.utexas.edu/resources/software/login/gotoblas/${MY_P}.tar.gz"
+LICENSE="tacc"
+SLOT="0"
+# See http://www.tacc.utexas.edu/resources/software/gotoblasfaq.php
+# for supported architectures
+KEYWORDS="~x86 ~amd64"
+IUSE="threads"
+RESTRICT="mirror"
+RDEPEND="app-admin/eselect-blas"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_PN}"
+FORTRAN="g77 gfortran" # ifc g95 pgf77 pathf90 f90 f77
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Set up C compiler
+ if [[ $(tc-getCC) = *gcc ]]; then
+ C_COMPILER="GNU"
+ elif [[ $(tc-getCC) = icc ]]; then
+ C_COMPILER="INTEL"
+ else
+ die "tc-getCC() returned an invalid C compiler; valid are gcc or icc."
+ fi
+
+ # Set up Fortran compiler
+ if [[ ${FORTRANC} = g77 ]]; then
+ F_COMPILER="G77"
+ elif [[ ${FORTRANC} = gfortran ]]; then
+ F_COMPILER="GFORTRAN"
+ # Otherwise, we get undefined reference to _gfortran_runtime_error
+ FORTRAN_LIB="-lgfortran"
+# elif [[ ${FORTRANC} = ifc ]]; then
+# F_COMPILER="INTEL"
+# elif [[ ${FORTRANC} = g95 ]]; then
+# F_COMPILER="G95"
+# elif [[ ${FORTRANC} = pgf77 ]]; then
+# F_COMPILER="PGI"
+# elif [[ ${FORTRANC} = pathf90 ]]; then
+# F_COMPILER="PATHSCALE"
+# elif [[ ${FORTRANC} = f90 ]] || [[ ${FORTRANC} = f77 ]]; then
+# F_COMPILER="SUN"
+# elif [[ ${FORTRANC} = xlf ]]; then
+# F_COMPILER="IBM"
+ else
+ die "fortran.eclass returned an invalid Fortran compiler \'${FORTRANC}\'; valid are ${FORTRAN}."
+ fi
+
+ # Fix shared lib build
+ sed -i \
+ -e "s:\(&& echo OK\):${FORTRAN_LIB} \1:g" \
+ "${S}"/exports/Makefile
+
+ # Set up compilers
+ sed -i \
+ -e "s:^\(C_COMPILER =\) GNU:\1 ${C_COMPILER}:g" \
+ -e "s:^# \(F_COMPILER =\) G77:\1 ${F_COMPILER}:g" \
+ -e "s:^# \(SMP = 1\):\1:g" \
+ -e "s:\$(COMPILER_PREFIX)ar:$(tc-getAR):" \
+ -e "s:\$(COMPILER_PREFIX)as:$(tc-getAS):" \
+ -e "s:\$(COMPILER_PREFIX)ld:$(tc-getLD):" \
+ -e "s:\$(COMPILER_PREFIX)ranlib:$(tc-getRANLIB):" \
+ "${S}"/Makefile.rule
+
+ # Threaded?
+ if use threads; then
+ sed -i \
+ -e "s:^# \(SMP = 1\):\1:g" \
+ "${S}"/Makefile.rule
+ fi
+
+ # If you need a 64-bit binary
+ # If you need a 64-bit integer interface, also do this for "INTERFACE64 = 1"
+ if use amd64; then
+ sed -i \
+ -e "s:^# \(BINARY64 = 1\):\1:g" \
+ "${S}"/Makefile.rule
+ fi
+
+ # Respect CFLAGS/FFLAGS
+ sed -i \
+ -e "/^COMMON_OPT += -O2$/d" \
+ "${S}"/Makefile.rule
+ sed -i \
+ -e "s:^\(CCOMMON_OPT +=\)$:\1 ${CFLAGS}:g" \
+ -e "s:^\(FCOMMON_OPT +=\)$:\1 ${FFLAGS:- -O2}:g" \
+ "${S}"/Makefile.rule
+}
+
+src_compile() {
+
+ # Make static library
+ emake LDFLAGS=$(raw_ldflags) || die "emake failed"
+
+ # Make shared library
+ cd exports
+ emake so -j1 || die "emake failed"
+}
+
+src_test() {
+ cd test
+ emake || die "emake test failed"
+}
+
+src_install() {
+ local MAIN_DIR="/usr/$(get_libdir)/blas"
+ local DIR="${MAIN_DIR}/goto"
+
+ # dolib.so doesn't support our alternate locations
+ exeinto ${DIR}
+ doexe libgoto_*.so
+ dosym libgoto_*.so ${DIR}/libgoto.so
+ dosym libgoto_*.so ${DIR}/libgoto.so.0
+ dosym libgoto_*.so ${DIR}/libgoto.so.0.0.0
+
+ # dolib.a doesn't support our alternate locations
+ insinto ${DIR}
+ doins libgoto_*.a
+ dosym libgoto_*.a ${DIR}/libgoto.a
+
+ dodoc 01 Readme.txt 03History.txt 04FAQ.txt
+
+ eselect blas add $(get_libdir) "${FILESDIR}"/eselect-goto goto
+}
+
+pkg_postinst() {
+ if [[ -z $(eselect blas show) ]]; then
+ eselect blas set goto
+ fi
+}
diff --git a/sci-libs/blas-goto/files/digest-blas-goto-1.11 b/sci-libs/blas-goto/files/digest-blas-goto-1.11
new file mode 100644
index 000000000000..0ed778d1664c
--- /dev/null
+++ b/sci-libs/blas-goto/files/digest-blas-goto-1.11
@@ -0,0 +1,3 @@
+MD5 0790d4de9f6680ffe429801299bad00d GotoBLAS-1.11.tar.gz 1632357
+RMD160 292f119f53d5b88a4b95998f294fd55cc1f6b3f9 GotoBLAS-1.11.tar.gz 1632357
+SHA256 05697c943f9679fcda4513fe7cd32f475407d1204cc71b6608dfbd522547fafc GotoBLAS-1.11.tar.gz 1632357
diff --git a/sci-libs/blas-goto/metadata.xml b/sci-libs/blas-goto/metadata.xml
index b229aec85b8f..f12d4740a074 100644
--- a/sci-libs/blas-goto/metadata.xml
+++ b/sci-libs/blas-goto/metadata.xml
@@ -2,4 +2,13 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci</herd>
+<longdescription lang="en">
+The GotoBLAS codes are one of the fastest implementations
+of the Basic Linear Algebra Subroutines(BLAS).
+To achieve performance it starts by observing that for current
+generation architectures, much of the overhead comes from Translation
+Look-aside Buffer (TLB) table misses. While the importance of caches
+is also taken into consideration, it is the minimization of such TLB
+misses that drives the approach.
+</longdescription>
</pkgmetadata>