summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-03-24 20:54:40 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-03-24 20:54:40 +0000
commitabf0e3d0527efdf48843ad82a93669b43f4ce4db (patch)
treedbd5aaad5e28e30c0b58df8d79047e5af79662ed /sci-geosciences
parentDelete older ebuild. (diff)
downloadgentoo-2-abf0e3d0527efdf48843ad82a93669b43f4ce4db.tar.gz
gentoo-2-abf0e3d0527efdf48843ad82a93669b43f4ce4db.tar.bz2
gentoo-2-abf0e3d0527efdf48843ad82a93669b43f4ce4db.zip
eselect wxwidgets affects build behaviour, not runtime, and only outside of
portage so it has no use here. Use 'unicode' wx libs since 'base' means non-X only. Don't use \ inside of quotes. (Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/grass/ChangeLog7
-rw-r--r--sci-geosciences/grass/grass-6.4.0.ebuild21
2 files changed, 9 insertions, 19 deletions
diff --git a/sci-geosciences/grass/ChangeLog b/sci-geosciences/grass/ChangeLog
index e28559bc3913..713ab159df74 100644
--- a/sci-geosciences/grass/ChangeLog
+++ b/sci-geosciences/grass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/grass
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.95 2011/03/10 19:14:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.96 2011/03/24 20:54:40 dirtyepic Exp $
+
+ 24 Mar 2011; Ryan Hill <dirtyepic@gentoo.org> grass-6.4.0.ebuild:
+ eselect wxwidgets affects build behaviour, not runtime, and only outside of
+ portage so it has no use here. Use 'unicode' wx libs since 'base' means non-X
+ only. Don't use \ inside of quotes.
10 Mar 2011; Justin Lecher <jlec@gentoo.org> grass-6.3.0.ebuild,
grass-6.4.0.ebuild, metadata.xml:
diff --git a/sci-geosciences/grass/grass-6.4.0.ebuild b/sci-geosciences/grass/grass-6.4.0.ebuild
index b89437444a33..b7d3b834e660 100644
--- a/sci-geosciences/grass/grass-6.4.0.ebuild
+++ b/sci-geosciences/grass/grass-6.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.4.0.ebuild,v 1.6 2011/03/10 19:14:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.4.0.ebuild,v 1.7 2011/03/24 20:54:40 dirtyepic Exp $
EAPI="3"
@@ -124,18 +124,6 @@ pkg_setup() {
# only py2 is supported
python_set_active_version 2
fi
-
- if use wxwidgets; then
- # only 2.8 is supported or the wx-gui barfs at runtime...
- local success=0
- ewarn "Attempting to select a compatible wxwidgets"
- eselect wxwidgets set gtk2-unicode-release-2.8
- success=1
- fi
- if [ $success != 1 ]; then
- eerror "Unable to select a compatible wxwidgets!"
- die "Please set wxwidgets to at least 2.8 (see \`eselect wxwidgets --help\`)."
- fi
}
src_prepare() {
@@ -161,7 +149,7 @@ src_configure() {
if use python && use wxwidgets; then
WX_BUILD=yes
WX_GTK_VER=2.8
- need-wxwidgets base
+ need-wxwidgets unicode
myconf+="
--without-tcltk
--with-wxwidgets=${WX_CONFIG}
@@ -201,10 +189,7 @@ src_configure() {
$(use_with cxx) \
$(use_with fftw) \
$(use_with ffmpeg) \
- --with-ffmpeg-includes="/usr/include/libavcodec \
- /usr/include/libavdevice /usr/include/libavfilter \
- /usr/include/libavformat /usr/include/libavutil \
- /usr/include/libpostproc /usr/include/libswscale" \
+ --with-ffmpeg-includes="/usr/include/libavcodec /usr/include/libavdevice /usr/include/libavfilter /usr/include/libavformat /usr/include/libavutil /usr/include/libpostproc /usr/include/libswscale" \
$(use_with gmath blas) \
$(use_with gmath lapack) \
$(use_with jpeg) \