summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGérald Fenoy <djay@gentoo.org>2006-11-24 21:43:08 +0000
committerGérald Fenoy <djay@gentoo.org>2006-11-24 21:43:08 +0000
commit6c74a438b6743ce4713d53fd13448800e70cb987 (patch)
tree183120b977e5bb698b04c244e004ec951ab6efc6 /sci-geosciences
parentStable on ppc64; bug #154857 (diff)
downloadgentoo-2-6c74a438b6743ce4713d53fd13448800e70cb987.tar.gz
gentoo-2-6c74a438b6743ce4713d53fd13448800e70cb987.tar.bz2
gentoo-2-6c74a438b6743ce4713d53fd13448800e70cb987.zip
Version bump.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsbabel/ChangeLog9
-rw-r--r--sci-geosciences/gpsbabel/files/digest-gpsbabel-1.3.23
-rw-r--r--sci-geosciences/gpsbabel/files/gpsbabel-1.3.2.patch28
-rw-r--r--sci-geosciences/gpsbabel/gpsbabel-1.3.2.ebuild69
4 files changed, 108 insertions, 1 deletions
diff --git a/sci-geosciences/gpsbabel/ChangeLog b/sci-geosciences/gpsbabel/ChangeLog
index d52cd7075d3e..eda7fc875043 100644
--- a/sci-geosciences/gpsbabel/ChangeLog
+++ b/sci-geosciences/gpsbabel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-geosciences/gpsbabel
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsbabel/ChangeLog,v 1.4 2006/09/30 21:32:20 djay Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsbabel/ChangeLog,v 1.5 2006/11/24 21:43:08 djay Exp $
+
+*gpsbabel-1.3.2 (24 Nov 2006)
+
+ 24 Nov 2006; <djay@gentoo.org> +files/gpsbabel-1.3.2.patch,
+ +gpsbabel-1.3.2.ebuild:
+ Version bump, thanks to Alistair Boyle <sail.not.swim@gmail.com> for his
+ reminder (bug #155185)
*gpsbabel-1.3.1 (30 Sep 2006)
diff --git a/sci-geosciences/gpsbabel/files/digest-gpsbabel-1.3.2 b/sci-geosciences/gpsbabel/files/digest-gpsbabel-1.3.2
new file mode 100644
index 000000000000..aca5bd3bdd8e
--- /dev/null
+++ b/sci-geosciences/gpsbabel/files/digest-gpsbabel-1.3.2
@@ -0,0 +1,3 @@
+MD5 5a9c442bc681035b1dfdbb32b1d3fa8b gpsbabel-1.3.2.tar.gz 2983808
+RMD160 0f0c05e67eaa77f8325b22ac8ed874ac5cee28e7 gpsbabel-1.3.2.tar.gz 2983808
+SHA256 31c4991810eb12744c2c908b2b7efa6f311a0bfe5e36f8cc2b1c545bede9c045 gpsbabel-1.3.2.tar.gz 2983808
diff --git a/sci-geosciences/gpsbabel/files/gpsbabel-1.3.2.patch b/sci-geosciences/gpsbabel/files/gpsbabel-1.3.2.patch
new file mode 100644
index 000000000000..d15ab8da8032
--- /dev/null
+++ b/sci-geosciences/gpsbabel/files/gpsbabel-1.3.2.patch
@@ -0,0 +1,28 @@
+diff -ru ./Makefile.in ./Makefile.in
+--- ./Makefile.in 2006-11-06 00:54:07.000000000 +0100
++++ ./Makefile.in 2006-11-24 22:01:04.000000000 +0100
+@@ -36,7 +36,8 @@
+ GBCFLAGS=$(EXTRA_CFLAGS) $(DEBUGGING) -I. -I@srcdir@/coldsync \
+ $(OPTIMIZATION) @CFLAGS@
+ LDFLAGS=$(EXTRA_LDFLAGS) @LDFLAGS@
+-DESTDIR=/usr/local/
++PREFIX=@prefix@
++INSTALL_DIR=$(DESTDIR)/$(PREFIX)
+
+ # OTHER_ROOT=/opt/local # For DarwinPorts on OSX
+ # OTHER_ROOT=/sw # Uncomment For Fink on OS X.
+@@ -136,10 +137,12 @@
+ # This will only work on UNIX-like substances.
+ #
+ install: @INSTALL_DEBUG@
+- install gpsbabel $(DESTDIR)/bin
++ @mkdir -p $(INSTALL_DIR)/bin
++ install gpsbabel $(INSTALL_DIR)/bin/
+
+ install-debug:
+- install gpsbabel-debug $(DESTDIR)/bin
++ @mkdir -p $(INSTALL_DIR)/bin
++ install gpsbabel-debug $(INSTALL_DIR)/bin/
+
+ # Nerdy release stuff that needs to work only on Linux.
+
diff --git a/sci-geosciences/gpsbabel/gpsbabel-1.3.2.ebuild b/sci-geosciences/gpsbabel/gpsbabel-1.3.2.ebuild
new file mode 100644
index 000000000000..349f4b8bccf2
--- /dev/null
+++ b/sci-geosciences/gpsbabel/gpsbabel-1.3.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsbabel/gpsbabel-1.3.2.ebuild,v 1.1 2006/11/24 21:43:08 djay Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="GPSBabel is a waypoints, tracks and routes converter in variety of form"
+
+HOMEPAGE="http://www.gpsbabel.org/"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE="doc usb debug"
+
+RDEPEND="dev-libs/expat
+ usb? ( dev-libs/libusb )
+ debug? ( dev-util/efence )"
+
+DEPEND="doc? ( virtual/tetex dev-libs/libxslt dev-libs/libxml2 dev-lang/perl )
+ ${RDEPEND}"
+
+src_unpack(){
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/gpsbabel-${PV}.patch || die "Unable to apply gpsbabel.patch"
+}
+
+src_compile() {
+ local myconf="";
+ if ! use usb;then
+ myconf="${myconf} --with-libusb=no"
+ fi
+ if use doc; then
+ myconf="${myconf} --with-doc=${S}/doc/manual"
+ fi
+ eautoconf
+ econf ${myconf} $(use_enable debug efence)
+ emake || die "emake failed"
+ if use doc; then
+ emake doc || die "Documentation generation failed"
+ cd "${S}/doc"
+ make || die "Documentation generation failed"
+ fi
+}
+
+src_install() {
+ cd "${S}"
+ make DESTDIR="${D}" install || die "Install failed"
+ dodoc README* || die "Unable to install gpsbabel doc"
+ if use doc; then
+ cd "${S}"/doc/
+ dohtml ./manual/htmldoc-${PV}/* || die "Unable to install htmldoc"
+ docinto manual
+ dodoc doc.dvi babelfront2.eps || \
+ die "Unable to install gpsbabel documentation"
+ fi
+}
+
+pkg_postinst(){
+ if use debug; then
+ einfo "If you need gpsbabel in debuging mode, use : gpsbabel-debug"
+ fi
+}