summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGérald Fenoy <djay@gentoo.org>2006-11-25 03:39:43 +0000
committerGérald Fenoy <djay@gentoo.org>2006-11-25 03:39:43 +0000
commitfe6707446b7184a0a07092babbf0f7c638ee336c (patch)
tree46295d3800f0ec22e89fa5af43b4fea57d3f9b78 /sci-geosciences/mapserver/files
parent2.1.2_rc2-r2 revbump. This fixes bugs #150585 and #156014. (diff)
downloadgentoo-2-fe6707446b7184a0a07092babbf0f7c638ee336c.tar.gz
gentoo-2-fe6707446b7184a0a07092babbf0f7c638ee336c.tar.bz2
gentoo-2-fe6707446b7184a0a07092babbf0f7c638ee336c.zip
Initial import of mapserver.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'sci-geosciences/mapserver/files')
-rw-r--r--sci-geosciences/mapserver/files/digest-mapserver-4.10.03
-rw-r--r--sci-geosciences/mapserver/files/mapserver-4.10.0_php.patch307
-rw-r--r--sci-geosciences/mapserver/files/mapserver_tcl.patch22
3 files changed, 332 insertions, 0 deletions
diff --git a/sci-geosciences/mapserver/files/digest-mapserver-4.10.0 b/sci-geosciences/mapserver/files/digest-mapserver-4.10.0
new file mode 100644
index 000000000000..508bf57ddccd
--- /dev/null
+++ b/sci-geosciences/mapserver/files/digest-mapserver-4.10.0
@@ -0,0 +1,3 @@
+MD5 4668bbd017c20c251e962a5cd09c8f31 mapserver-4.10.0.tar.gz 1782838
+RMD160 425b1e856e98165cb7d4facf6a1ef393bf9c7f36 mapserver-4.10.0.tar.gz 1782838
+SHA256 c59b0b6b75443fbbced153c4b01f752e748cf73ce7c29125cfe8e223893b9d99 mapserver-4.10.0.tar.gz 1782838
diff --git a/sci-geosciences/mapserver/files/mapserver-4.10.0_php.patch b/sci-geosciences/mapserver/files/mapserver-4.10.0_php.patch
new file mode 100644
index 000000000000..fdc851fade4d
--- /dev/null
+++ b/sci-geosciences/mapserver/files/mapserver-4.10.0_php.patch
@@ -0,0 +1,307 @@
+diff -ru ./mapserver-4.10.0/Makefile.in ../mapserver-4.10.0/Makefile.in
+--- ./mapserver-4.10.0/Makefile.in 2006-08-27 18:33:56.000000000 +0200
++++ ../mapserver-4.10.0/Makefile.in 2006-10-07 14:29:07.000000000 +0200
+@@ -169,6 +169,8 @@
+ #
+ PHP_REGEX_OBJ=@PHP_REGEX_OBJ@
+ PHP_REGEX_INC=@PHP_REGEX_INC@
++PHP5_REGEX_OBJ=@PHP5_REGEX_OBJ@
++PHP5_REGEX_INC=@PHP5_REGEX_INC@
+
+ #
+ # Multithreading support.
+@@ -247,11 +249,14 @@
+ .cpp.o:
+ $(CXX) -c $(CXXFLAGS) $< -o $@
+
+-all: $(MAKE_GD) libmap.a $(EXTRA_DEFAULT) $(EXE_LIST) @MAKE_PHPMS@
++all: $(MAKE_GD) libmap.a $(EXTRA_DEFAULT) $(EXE_LIST) @MAKE_PHPMS@ @MAKE_PHP5MS@
+
+ php3_mapscript:: $(LIBMAP_STATIC)
+ cd mapscript/php3; $(MAKE); cd ../..
+
++php5_mapscript:: $(LIBMAP_STATIC)
++ cd mapscript/php5; $(MAKE); cd ../..
++
+ maplexer.o: maplexer.c map.h mapfile.h
+
+ maplexer.c: maplexer.l
+@@ -334,6 +339,9 @@
+ php3_mapscript_clean::
+ cd mapscript/php3; $(MAKE) clean; cd ../..
+
++php5_mapscript_clean::
++ cd mapscript/php3; $(MAKE) clean; cd ../..
++
+ install:
+ @echo ""
+ @echo "***** MapServer Installation *****"
+@@ -354,7 +362,7 @@
+ (cd $(INST_BIN) && rm $(EXE_LIST) )
+ (cd $(INST_LIB) && rm $(LIBMAP_SH_VER) $(LIBMAP_SHARED) )
+
+-clean: @MAKE_PHPMS_CLEAN@
++clean: @MAKE_PHPMS_CLEAN@ @MAKE_PHP5MS_CLEAN@
+ rm -f $(LIBMAP_STATIC) $(LIBMAP_SHARED) $(LIBMAP_SH_VER) *.o $(EXE_LIST)
+
+ exe-clean:
+Only in ../mapserver-4.10.0/: Makefile.in.orig
+diff -ru ./mapserver-4.10.0/configure.in ../mapserver-4.10.0/configure.in
+--- ./mapserver-4.10.0/configure.in 2006-08-28 16:09:23.000000000 +0200
++++ ../mapserver-4.10.0/configure.in 2006-10-07 14:34:44.000000000 +0200
+@@ -1866,21 +1866,10 @@
+ dnl PHP/MapScript module options
+ dnl ---------------------------------------------------------------------
+
+-AC_CHECKING(for PHP/MapScript module options)
+-AC_ARG_WITH(php,
+-[ --with-php=DIR Specify directory where PHP4's include files are
+- installed (or a pointer to the full source tree)
+- Required in order to compile the PHP/MapScript
+- module.],,)
+-
+-AC_ARG_ENABLE(internal-ld-detect,
+-[ --enable-perlv-ld-detect (applies to --with-php only)
+- Use perl -V output to figure the command to use to
+- link php_mapscript.so. Try this only if the default
+- internal macro didn't work.],,)
+-
+-if test -n "$with_php" -a -d "$with_php" ; then
+- AC_EXPAND_PATH($with_php, PHP_SRC_DIR)
++dnl --------------------------------------------------------------------------
++dnl No php version specific
++dnl --------------------------------------------------------------------------
++if test -n "$with_php4" -o -n "$with_php5" ; then
+ dnl
+ dnl Checks for shared library linking.
+ dnl
+@@ -1889,7 +1878,6 @@
+ dnl (The perl-V macro was the default in 3.6 and before but this was
+ dnl changed in 3.7 to use the internal AC_LD_SHARED macro by default)
+ dnl
+-
+ if test "$enable_perlv_ld_detect" = "yes" ; then
+ AC_MSG_RESULT(Using perl -V macro to figure ld command to link php_mapscript.so)
+
+@@ -1912,6 +1900,17 @@
+ PHP_CC="$CC $C_PIC"
+ PHP_LD="$PHP_LD_SHARED"
+ fi
++fi
++
++AC_CHECKING(for PHP4/MapScript module options)
++AC_ARG_WITH(php4,
++[ --with-php4=DIR Specify directory where PHP4's include files are
++ installed (or a pointer to the full source tree)
++ Required in order to compile the PHP/MapScript
++ module.],,)
++
++if test -n "$with_php4" -a -d "$with_php4" ; then
++ AC_EXPAND_PATH($with_php4,PHP_SRC_DIR)
+
+ dnl
+ dnl Look for PHP3's config.h or PHP4's php_config.h.
+@@ -2001,6 +2000,109 @@
+ AC_SUBST(MAKE_PHPMS, $MAKE_PHPMS)
+ AC_SUBST(MAKE_PHPMS_CLEAN, $MAKE_PHPMS_CLEAN)
+
++AC_CHECKING(for PHP5/MapScript module options)
++AC_ARG_WITH(php5,
++[ --with-php5=DIR Specify directory where PHP5's include files are
++ installed (or a pointer to the full source tree)
++ Required in order to compile the PHP/MapScript
++ module.],,)
++
++if test -n "$with_php5" -a -d "$with_php5" ; then
++ AC_EXPAND_PATH($with_php5, PHP5_SRC_DIR)
++
++ dnl
++ dnl Look for PHP3's config.h or PHP4's php_config.h.
++ dnl We'll need the config file to find info about the PHP configuration
++ dnl
++ AC_MSG_CHECKING([for location of config.h or php_config.h])
++ dnl In PHP3, it was called config.h
++ test -f "$PHP5_SRC_DIR/config.h" && PHP5_CONFIG_H="$PHP5_SRC_DIR/config.h"
++
++ dnl In PHP 4.0.1 to 4.0.3, it was php-4.0.x/php_config.h
++ test -f "$PHP5_SRC_DIR/php_config.h" && PHP5_CONFIG_H="$PHP5_SRC_DIR/php_config.h"
++
++ dnl Starting with PHP 4.0.4, it's php-4.0.x/main/php_config.h
++ test -f "$PHP5_SRC_DIR/main/php_config.h" && PHP5_CONFIG_H="$PHP5_SRC_DIR/main/php_config.h"
++
++ dnl If php was installed, then the headers are under $prefix/include/php/*
++ test -f "$PHP5_SRC_DIR/include/php/main/php_config.h" && PHP5_SRC_DIR="$PHP5_SRC_DIR/include/php/" && PHP5_CONFIG_H="$PHP5_SRC_DIR/main/php_config.h"
++
++ if test -n "$PHP5_CONFIG_H" ; then
++ AC_MSG_RESULT([$PHP5_CONFIG_H])
++ else
++ AC_MSG_ERROR([
++!!! Could not find config.h or php_config.h in $PHP5_SRC_DIR. !!!
++!!! Has PHP5 been configured yet? !!!])
++ fi
++
++ dnl
++ dnl Check which PHP5 version we're using.
++ dnl
++ AC_MSG_CHECKING([whether we have PHP5])
++ if test -n "`grep 'ZEND_API' $PHP5_CONFIG_H`" ; then
++ PHP5_VERSION_FLAG="-DPHP4"
++ else
++ AC_MSG_ERROR([
++!!! PHP MapScript now requires PHP 5.0.0 or more recent. !!!
++!!! Support for PHP3 has been dropped after MapServer version 3.5. !!!])
++ fi
++ AC_MSG_RESULT([$PHP5_VERSION_FLAG])
++
++ dnl
++ dnl Check if PHP was compiled with the bundled regex, and if so then
++ dnl use the same version to compile MapServer.
++ dnl
++ AC_MSG_CHECKING([whether we should use PHP5's regex])
++ if test -n "`grep 'define REGEX 1' $PHP5_CONFIG_H`" ; then
++ AC_MSG_RESULT(yes)
++
++ dnl We'll check for regex_extra.h - that might let use build
++ dnl without the source using libphp_common.so
++ test -f "$PHP5_SRC_DIR/regex/regex_extra.h" && PHP5_NO_SOURCE="1"
++ if test -n "$PHP5_NO_SOURCE" ; then
++ dnl Found regex_extra.h
++ USE_PHP5_REGEX="-DUSE_PHP_REGEX"
++ PHP5_REGEX_OBJ=php_regex.o
++ AC_MSG_RESULT([ found regex_extra.h - building PHP MapScript with PHP5's bundled regex ])
++ else
++ AC_MSG_ERROR([
++!!! PHP5 uses its bundled regex library but regex/regex_extra.h cannot be !!!
++!!! found. !!!])
++ fi
++
++ else
++ AC_MSG_RESULT(no)
++ fi
++
++ PHP5MS_MAKEFILE=mapscript/php5/Makefile
++ MAKE_PHP5MS=php5_mapscript
++ MAKE_PHP5MS_CLEAN=php_mapscript_clean
++
++ AC_SUBST(PHP5_VERSION_FLAG, $PHP5_VERSION_FLAG)
++ AC_SUBST(PHP5_SRC_DIR, $PHP5_SRC_DIR)
++ AC_SUBST(PHP5_REGEX_INC, $PHP5_REGEX_INC)
++ AC_SUBST(PHP5_REGEX_OBJ, $PHP5_REGEX_OBJ)
++ AC_SUBST(USE_PHP5_REGEX, $USE_PHP5_REGEX)
++
++ AC_MSG_RESULT([ PHP5/MapScript module configured.])
++ AC_MSG_RESULT([ $PHP5_VERSION_FLAG, $PHP5_SRC_DIR])
++elif test -n "$with_php5" -a "$with_php5" != "no" ; then
++ AC_MSG_ERROR([Missing or invalid PHP5 source directory in --with-php5=DIR.])
++else
++ AC_MSG_RESULT([ PHP5/MapScript module not configured.])
++fi
++
++AC_SUBST(MAKE_PHP5MS, $MAKE_PHP5MS)
++AC_SUBST(MAKE_PHP5MS_CLEAN, $MAKE_PHP5MS_CLEAN)
++AC_ARG_ENABLE(internal-ld-detect,
++
++[ --enable-perlv-ld-detect (applies to --with-php only)
++ Use perl -V output to figure the command to use to
++ link php_mapscript.so. Try this only if the default
++ internal macro didn't work.],,)
++
++
++
+ dnl ---------------------------------------------------------------------
+ dnl Shared library building.
+ dnl
+@@ -2039,6 +2141,7 @@
+ !!! See: http://mapserver.gis.umn.edu/cgi-bin/wiki.pl?PHPMapScriptCGI !!!])
+
+
++
+ AC_MSG_CHECKING([for location of Apache headers using apxs])
+ if test -z "$MAKE_PHPMS" ; then
+ AC_MSG_ERROR([--with-apxs applies only if --with-php is used.])
+@@ -2159,5 +2262,5 @@
+ AC_SUBST(ALL_STATIC_LIB, $ALL_STATIC_LIB)
+ AC_SUBST(RPATHS, [$RPATHS])
+
+-AC_OUTPUT(Makefile $PHPMS_MAKEFILE mapscript/java/Makefile mapscript/csharp/Makefile)
++AC_OUTPUT(Makefile $PHPMS_MAKEFILE $PHP5MS_MAKEFILE mapscript/java/Makefile mapscript/csharp/Makefile)
+
+Only in ../mapserver-4.10.0/: configure.in.orig
+diff -ru ./mapserver-4.10.0/mapscript/php3/Makefile.in ../mapserver-4.10.0/mapscript/php3/Makefile.in
+--- ./mapserver-4.10.0/mapscript/php3/Makefile.in 2006-08-26 18:29:54.000000000 +0200
++++ ../mapserver-4.10.0/mapscript/php3/Makefile.in 2006-10-07 14:35:06.000000000 +0200
+@@ -77,7 +77,7 @@
+
+ CFLAGS112 = $(CFLAGS) $(MS_DEFINE) $(MS_INC) $(PHP_INC) $(PHP_REGEX_INC)
+
+-all: php_mapscript.so
++all: php_mapscript.so php_proj.so
+
+ PHPMS_OBJS = php_mapscript_util.o php_mapscript.o mapscript_i.o $(PHP_REGEX_OBJ)
+
+diff -ru ./mapserver-4.10.0/mapscript/php5/Makefile.in ../mapserver-4.10.0/mapscript/php5/Makefile.in
+--- ./mapserver-4.10.0/mapscript/php5/Makefile.in 2006-10-07 14:57:56.000000000 +0200
++++ ../mapserver-4.10.0/mapscript/php5/Makefile.in 2006-10-07 14:35:20.000000000 +0200
+@@ -35,26 +35,26 @@
+
+ CC = @PHP_CC@
+ LD = @PHP_LD@
+-CFLAGS = @CFLAGS@ @USE_PHP_REGEX@ -DCOMPILE_DL=1 @PHP_VERSION_FLAG@
++CFLAGS = @CFLAGS@ @USE_PHP5_REGEX@ -DCOMPILE_DL=1 @PHP5_VERSION_FLAG@
+ RUNPATHS= @RPATHS@
+
+ #
+ # Set PHP_SRC_DIR to point to the root of the PHP source tree
+ #
+-PHP_SRC_DIR = @PHP_SRC_DIR@
++PHP_SRC_DIR = @PHP5_SRC_DIR@
+
+ PHP_INC = -I$(PHP_SRC_DIR) -I$(PHP_SRC_DIR)/dl -I$(PHP_SRC_DIR)/main \
+ -I$(PHP_SRC_DIR)/Zend -I$(PHP_SRC_DIR)/include \
+ -I$(PHP_SRC_DIR)/TSRM @APACHE_INC@
+
+ #
+-# IMPORTANT NOTE ABOUT REGEX FOR PHP_MAPSCRIPT USERS:
++# IMPORTANT NOTE ABOUT REGEX FOR PHP5_MAPSCRIPT USERS:
+ #
+-# In order to compile the PHP_MAPSCRIPT module, we have to make MapServer
+-# uses the same version of the REGEX library that PHP was compiled with:
++# In order to compile the PHP5_MAPSCRIPT module, we have to make MapServer
++# uses the same version of the REGEX library that PHP5 was compiled with:
+ #
+-PHP_REGEX_OBJ=@PHP_REGEX_OBJ@
+-PHP_REGEX_INC=@PHP_REGEX_INC@
++PHP5_REGEX_OBJ=@PHP5_REGEX_OBJ@
++PHP5_REGEX_INC=@PHP5_REGEX_INC@
+
+
+ #
+@@ -75,20 +75,20 @@
+ # The rest of the file should not have to be edited...
+ #
+
+-CFLAGS112 = $(CFLAGS) $(MS_DEFINE) $(MS_INC) $(PHP_INC) $(PHP_REGEX_INC)
++CFLAGS112 = $(CFLAGS) $(MS_DEFINE) $(MS_INC) $(PHP_INC) $(PHP5_REGEX_INC)
+
+-all: php_mapscript.so
++all: php_mapscript.so php_proj.so
+
+-PHPMS_OBJS = php_mapscript_util.o php_mapscript.o mapscript_i.o $(PHP_REGEX_OBJ)
++PHP5MS_OBJS = php_mapscript_util.o php_mapscript.o mapscript_i.o $(PHP5_REGEX_OBJ)
+
+-PHPPROJ_OBJS = php_mapscript_util.o php_proj.o $(PHP_REGEX_OBJ)
++PHP5PROJ_OBJS = php_mapscript_util.o php_proj.o $(PHP5_REGEX_OBJ)
+
+
+-php_mapscript.so: $(PHPMS_OBJS) ../../libmap.a
+- $(LD) -o $@ $(PHPMS_OBJS) $(MS_LIBS)
++php_mapscript.so: $(PHP5MS_OBJS) ../../libmap.a
++ $(LD) -o $@ $(PHP5MS_OBJS) $(MS_LIBS)
+
+-php_proj.so: $(PHPPROJ_OBJS)
+- $(LD) -o $@ $(PHPPROJ_OBJS) $(MS_LIBS)
++php_proj.so: $(PHP5PROJ_OBJS)
++ $(LD) -o $@ $(PHP5PROJ_OBJS) $(MS_LIBS)
+
+ %.o: %.c php_mapscript_util.h php_mapscript.h
+ $(CC) $(CFLAGS112) -c -o $@ $<
diff --git a/sci-geosciences/mapserver/files/mapserver_tcl.patch b/sci-geosciences/mapserver/files/mapserver_tcl.patch
new file mode 100644
index 000000000000..dab7db05ea3d
--- /dev/null
+++ b/sci-geosciences/mapserver/files/mapserver_tcl.patch
@@ -0,0 +1,22 @@
+--- mapscript/tcl/Makefile.in 2001-10-26 00:56:39.000000000 +0200
++++ mapscript/tcl/Makefile.in 2006-03-11 13:21:12.000000000 +0100
+@@ -25,7 +25,7 @@
+ TCL_LIBS = @TCL_LIBS@
+ LIBS = @TCL_LIBS@
+ TCL_DBGX = @TCL_DBGX@
+-LIB_RUNTIME_DIR = @TCL_EXEC_PREFIX@/lib:@TCL_EXEC_PREFIX@/lib/$(PACKAGEDIR):@TCL_PREFIX@/lib:@MAPSERVERHOME@
++LIB_RUNTIME_DIR = @TCL_EXEC_PREFIX@/lib:@TCL_EXEC_PREFIX@/lib/$(PACKAGEDIR):@TCL_PREFIX@/lib
+
+ MAPSERVERHOME = @MAPSERVERHOME@
+ MAPSERVERDEFS = @MAPSERVERDEFS@
+--- mapscript/mapscript.i 2005-11-22 22:44:48.000000000 +0100
++++ mapscript/mapscript.i 2006-04-12 23:47:23.000000000 +0200
+@@ -206,7 +206,7 @@
+
+ /* Tcl */
+ #ifdef SWIGTCL8
+-%include "tclmodule.i"
++/* %include "tclmodule.i" */
+ #endif /* SWIGTCL8 */
+
+ /*