summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2010-09-20 18:20:44 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2010-09-20 18:20:44 +0000
commitf08b5cd73b79b1b0690f338f42ffb85b99e07c50 (patch)
treeaf03ff401418813a5811e876857ed966afe5351b /sci-electronics
parentia64/m68k/s390/sh/sparc stable wrt #322531 (diff)
downloadgentoo-2-f08b5cd73b79b1b0690f338f42ffb85b99e07c50.tar.gz
gentoo-2-f08b5cd73b79b1b0690f338f42ffb85b99e07c50.tar.bz2
gentoo-2-f08b5cd73b79b1b0690f338f42ffb85b99e07c50.zip
Version bump, sorting file locations and LDFLAGS. Fixes bugs 299476 and 337425.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/magic/ChangeLog12
-rw-r--r--sci-electronics/magic/files/magic-ldflags.patch40
-rw-r--r--sci-electronics/magic/magic-7.5.202.ebuild62
3 files changed, 112 insertions, 2 deletions
diff --git a/sci-electronics/magic/ChangeLog b/sci-electronics/magic/ChangeLog
index 8ad83b67b5ef..507442105863 100644
--- a/sci-electronics/magic/ChangeLog
+++ b/sci-electronics/magic/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-electronics/magic
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/magic/ChangeLog,v 1.56 2009/09/27 14:53:44 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/magic/ChangeLog,v 1.57 2010/09/20 18:20:44 dilfridge Exp $
+
+*magic-7.5.202 (20 Sep 2010)
+
+ 20 Sep 2010; Andreas K. Huettel <dilfridge@gentoo.org>
+ +magic-7.5.202.ebuild:
+ Version bump, moving aux files back to LIBDIR and docs manually to the doc
+ dir. Beat it into accepting LDFLAGS, improve tutorial file location. Fixes
+ bug 299476 and bug 337425.
27 Sep 2009; nixnut <nixnut@gentoo.org> magic-7.4.46-r1.ebuild:
ppc stable #281411
diff --git a/sci-electronics/magic/files/magic-ldflags.patch b/sci-electronics/magic/files/magic-ldflags.patch
new file mode 100644
index 000000000000..60d5891beee0
--- /dev/null
+++ b/sci-electronics/magic/files/magic-ldflags.patch
@@ -0,0 +1,40 @@
+diff -r -u magic-7.5.202.orig/scripts/configure.in magic-7.5.202/scripts/configure.in
+--- magic-7.5.202.orig/scripts/configure.in 2010-03-08 14:33:07.000000000 +0100
++++ magic-7.5.202/scripts/configure.in 2010-07-02 22:15:50.814199319 +0200
+@@ -1350,7 +1350,6 @@
+ if test "x${loader_run_path}" != "x" ; then
+ LD_RUN_PATH="${LD_RUN_PATH} -Wl,-rpath,${loader_run_path}"
+ fi
+- LDFLAGS=""
+ EXTRA_LIB_SPECS="-ldl"
+ ;;
+
+diff -r -u magic-7.5.202.orig/scripts/defs.mak.in magic-7.5.202/scripts/defs.mak.in
+--- magic-7.5.202.orig/scripts/defs.mak.in 2010-03-08 14:33:07.000000000 +0100
++++ magic-7.5.202/scripts/defs.mak.in 2010-07-02 22:15:50.814199319 +0200
+@@ -53,7 +53,7 @@
+ M4 = @M4@
+ RANLIB = @RANLIB@
+ SHDLIB_EXT = @SHDLIB_EXT@
+-LDDL_FLAGS = @LDDL_FLAGS@
++LDDL_FLAGS = ${LDFLAGS} @LDDL_FLAGS@
+ LD_RUN_PATH = @LD_RUN_PATH@
+ LIB_SPECS = @LIB_SPECS@
+ WISH_EXE = @WISH_EXE@
+diff -r -u magic-7.5.202.orig/tcltk/Makefile magic-7.5.202/tcltk/Makefile
+--- magic-7.5.202.orig/tcltk/Makefile 2009-05-29 15:54:55.000000000 +0200
++++ magic-7.5.202/tcltk/Makefile 2010-07-02 22:16:30.916202298 +0200
+@@ -41,11 +41,11 @@
+ (cd $(DESTDIR)${TCLDIR}; chmod 0755 tkcon.tcl tkshell.tcl)
+
+ magicexec: magicexec.c
+- ${CC} ${CFLAGS} -pg ${CPPFLAGS} ${DFLAGS} magicexec.c -o magicexec \
++ ${CC} ${CFLAGS} -pg ${CPPFLAGS} ${DFLAGS} ${LDFLAGS} magicexec.c -o magicexec \
+ ${LD_RUN_PATH} ${LIBS} ${LIB_SPECS}
+
+ magicdnull: magicdnull.c
+- ${CC} ${CFLAGS} ${CPPFLAGS} ${DFLAGS} magicdnull.c -o magicdnull \
++ ${CC} ${CFLAGS} ${CPPFLAGS} ${DFLAGS} ${LDFLAGS} magicdnull.c -o magicdnull \
+ ${LD_RUN_PATH} ${LIBS} ${LIB_SPECS}
+
+ magic.tcl: magic.tcl.in ${MAGICDIR}/defs.mak
diff --git a/sci-electronics/magic/magic-7.5.202.ebuild b/sci-electronics/magic/magic-7.5.202.ebuild
new file mode 100644
index 000000000000..a96268b43452
--- /dev/null
+++ b/sci-electronics/magic/magic-7.5.202.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/magic/magic-7.5.202.ebuild,v 1.1 2010/09/20 18:20:44 dilfridge Exp $
+
+EAPI=2
+
+inherit multilib eutils autotools
+
+DESCRIPTION="The VLSI design CAD tool."
+HOMEPAGE="http://www.opencircuitdesign.com/magic/index.html"
+SRC_URI="http://www.opencircuitdesign.com/magic/archive/${P}.tgz \
+ ftp://ftp.mosis.edu/pub/sondeen/magic/new/beta/2002a.tar.gz"
+
+LICENSE="as-is GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses
+ sys-libs/readline
+ dev-lang/tcl
+ dev-lang/tk
+ dev-tcltk/blt"
+DEPEND="${RDEPEND}
+ app-shells/tcsh"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-ldflags.patch"
+ cd scripts
+ eautoreconf
+ cd ..
+ sed -i -e "s: -pg : :" tcltk/Makefile || die "tcltk patch failed"
+}
+
+src_configure() {
+ # Short-circuit top-level configure script to retain CFLAGS
+ cd scripts
+ CPP="cpp" econf
+}
+
+src_compile() {
+ emake -j1 || die "Compilation failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die
+
+ dodoc README README.Tcl TODO || die
+
+ # Move docs from libdir to docdir and add symlink.
+ mv "${D}/usr/$(get_libdir)/magic/doc"/* "${D}/usr/share/doc/${PF}/" || die
+ rmdir "${D}/usr/$(get_libdir)/magic/doc" || die
+ dosym "/usr/share/doc/${PF}" "/usr/$(get_libdir)/magic/doc" || die
+
+ # Move tutorial from libdir to datadir and add symlink.
+ dodir /usr/share/${PN} || die
+ mv "${D}/usr/$(get_libdir)/magic/tutorial" "${D}/usr/share/${PN}/" || die
+ dosym "/usr/share/${PN}/tutorial" "/usr/$(get_libdir)/magic/tutorial" || die
+
+ # Install latest MOSIS tech files
+ cp -pPR "${WORKDIR}"/2002a "${D}"/usr/$(get_libdir)/magic/sys/current || die
+}