summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-18 14:02:11 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-18 14:02:11 +0000
commit65a851ef271527574f41744e1d85b29d4a53454d (patch)
tree0f572d5800d21856b26d393d0c2e7cf86068babd /sci-electronics
parentMask portpeek >= 2.1.6 for testing (diff)
downloadgentoo-2-65a851ef271527574f41744e1d85b29d4a53454d.tar.gz
gentoo-2-65a851ef271527574f41744e1d85b29d4a53454d.tar.bz2
gentoo-2-65a851ef271527574f41744e1d85b29d4a53454d.zip
sci-electronics/gnucap: Drop old; repect CC and CXX, #452838
(Portage version: 2.2.0_alpha154/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gnucap/ChangeLog8
-rw-r--r--sci-electronics/gnucap/gnucap-0.35.20091207.ebuild10
-rw-r--r--sci-electronics/gnucap/gnucap-0.35.ebuild45
3 files changed, 12 insertions, 51 deletions
diff --git a/sci-electronics/gnucap/ChangeLog b/sci-electronics/gnucap/ChangeLog
index 4c249d27b9a4..edb03df57650 100644
--- a/sci-electronics/gnucap/ChangeLog
+++ b/sci-electronics/gnucap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/gnucap
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/ChangeLog,v 1.53 2011/06/28 20:12:22 ranger Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/ChangeLog,v 1.54 2013/01/18 14:02:10 jlec Exp $
+
+ 18 Jan 2013; Justin Lecher <jlec@gentoo.org> -gnucap-0.35.ebuild,
+ gnucap-0.35.20091207.ebuild:
+ Drop old; repect CC and CXX, #452838
28 Jun 2011; Brent Baude <ranger@gentoo.org> gnucap-0.35.20091207.ebuild:
Marking gnucap-0.35.20091207 ppc for bug 365415
diff --git a/sci-electronics/gnucap/gnucap-0.35.20091207.ebuild b/sci-electronics/gnucap/gnucap-0.35.20091207.ebuild
index 8655f0324d51..efbc586c8b98 100644
--- a/sci-electronics/gnucap/gnucap-0.35.20091207.ebuild
+++ b/sci-electronics/gnucap/gnucap-0.35.20091207.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/gnucap-0.35.20091207.ebuild,v 1.5 2011/06/28 20:12:22 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/gnucap-0.35.20091207.ebuild,v 1.6 2013/01/18 14:02:10 jlec Exp $
EAPI="2"
-inherit multilib
+inherit multilib toolchain-funcs
SNAPSHOTDATE="${P##*.}"
MY_PV="${PN}-${SNAPSHOTDATE:0:4}-${SNAPSHOTDATE:4:2}-${SNAPSHOTDATE:6:2}"
@@ -50,13 +50,15 @@ src_prepare() {
sed -i -e "s:strchr(str2, '|'):const_cast<char*>(strchr(str2, '|')):" \
{src,modelgen}/ap_match.cc || die "sed failed"
+
+ tc-export CC CXX
}
src_compile () {
emake || die "Compilation failed"
for PLUGIN_DIR in models-* ; do
cd "${S}/${PLUGIN_DIR}"
- emake || die "Compilation failed in ${PLUGIN_DIR}"
+ emake CC=$(tc-getCC) CCC=$(tc-getCXX) || die "Compilation failed in ${PLUGIN_DIR}"
done
}
diff --git a/sci-electronics/gnucap/gnucap-0.35.ebuild b/sci-electronics/gnucap/gnucap-0.35.ebuild
deleted file mode 100644
index bffe05cb95d4..000000000000
--- a/sci-electronics/gnucap/gnucap-0.35.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/gnucap-0.35.ebuild,v 1.9 2011/05/21 16:26:31 armin76 Exp $
-
-inherit eutils
-
-DESCRIPTION="GNUCap is the GNU Circuit Analysis Package"
-SRC_URI="http://www.gnucap.org/dist/${P}.tar.gz"
-HOMEPAGE="http://www.gnucap.org/"
-
-IUSE="doc examples"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc x86"
-
-DEPEND="doc? ( virtual/latex-base )"
-
-src_unpack() {
- unpack ${A} || die "Failed to unpack!"
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-gcc43.patch
-
- # No need to install COPYING and INSTALL
- sed -i \
- -e 's: COPYING INSTALL::' \
- -e 's:COPYING history INSTALL:history:' \
- doc/Makefile.in || die "sed failed"
-
- if ! use doc ; then
- sed -i \
- -e 's:SUBDIRS = doc examples man:SUBDIRS = doc examples:' \
- Makefile.in || die "sed failed"
- fi
-
- if ! use examples ; then
- sed -i \
- -e 's:SUBDIRS = doc examples:SUBDIRS = doc:' \
- Makefile.in || die "sed failed"
- fi
-}
-
-src_install () {
- make DESTDIR="${D}" install || die "Installation failed"
-}