summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2013-11-03 08:19:51 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2013-11-03 08:19:51 +0000
commit450eaaa0bb810051ce75b72bf51611e99b9f9f33 (patch)
treef6b3d38ebca830ceea686b02386f54f8542588ba /sci-electronics
parentVersion bump. New upstream merged gtk-engines-qtcurve and qtcurve-qt4 into on... (diff)
downloadgentoo-2-450eaaa0bb810051ce75b72bf51611e99b9f9f33.tar.gz
gentoo-2-450eaaa0bb810051ce75b72bf51611e99b9f9f33.tar.bz2
gentoo-2-450eaaa0bb810051ce75b72bf51611e99b9f9f33.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/linsmith/ChangeLog7
-rw-r--r--sci-electronics/linsmith/linsmith-0.99.26.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/sci-electronics/linsmith/ChangeLog b/sci-electronics/linsmith/ChangeLog
index dfb36849e5c0..be83e9ace15b 100644
--- a/sci-electronics/linsmith/ChangeLog
+++ b/sci-electronics/linsmith/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/linsmith
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/linsmith/ChangeLog,v 1.19 2013/08/28 11:16:18 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/linsmith/ChangeLog,v 1.20 2013/11/03 08:19:51 tomjbe Exp $
+
+*linsmith-0.99.26 (03 Nov 2013)
+
+ 03 Nov 2013; Thomas Beierlein <tomjbe@gentoo.org> +linsmith-0.99.26.ebuild:
+ Version bump
28 Aug 2013; Agostino Sarubbo <ago@gentoo.org> linsmith-0.99.25.ebuild:
Stable for x86, wrt bug #482132
diff --git a/sci-electronics/linsmith/linsmith-0.99.26.ebuild b/sci-electronics/linsmith/linsmith-0.99.26.ebuild
new file mode 100644
index 000000000000..faac0c71d1e8
--- /dev/null
+++ b/sci-electronics/linsmith/linsmith-0.99.26.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/linsmith/linsmith-0.99.26.ebuild,v 1.1 2013/11/03 08:19:51 tomjbe Exp $
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Smith charting program, mainly designed for educational use."
+HOMEPAGE="http://www.jcoppens.com/soft/linsmith/index.en.php"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ dev-libs/libxml2:2
+ dev-libs/glib:2
+ dev-libs/atk
+ gnome-base/libgnome
+ gnome-base/libgnomecanvas
+ gnome-base/libgnomeui"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # This patch is to prevent make install copying
+ # the examples in /usr/share/linsmith
+ # Now they are cp to the correct location.
+ epatch \
+ "${FILESDIR}"/${PN}-datafiles.patch
+
+ # fix QA warnings about wrong categories in .desktop file
+ sed -i -e "s/Application;Engineering;/Education;Science;Electronics;/" \
+ -e "s/Encoding=/#Encoding=/" \
+ ${PN}.desktop || die
+
+ # fix QA warnings about 'maintainer mode'
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto "/usr/share/${PN}"
+ doins datafiles/conv0809
+
+ dodoc AUTHORS ChangeLog NEWS NOTES README THANKS TODO
+ doman doc/${PN}.1
+
+ domenu ${PN}.desktop
+ doicon ${PN}_icon.xpm
+
+ if use doc; then
+ insinto "/usr/share/doc/${PF}"
+ doins doc/manual.pdf
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins datafiles/*.circ datafiles/*.load || die
+ fi
+}