summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2014-08-10 17:07:58 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2014-08-10 17:07:58 +0000
commit3a1731bb6c9e19ed262311d4870b21a491b8a203 (patch)
tree052730d6566a428a874bf8c8e6733dfe3bc4adb3 /sci-electronics
parentAdd use flag to control building of vmhgfs module. (diff)
downloadgentoo-2-3a1731bb6c9e19ed262311d4870b21a491b8a203.tar.gz
gentoo-2-3a1731bb6c9e19ed262311d4870b21a491b8a203.tar.bz2
gentoo-2-3a1731bb6c9e19ed262311d4870b21a491b8a203.zip
Version bump (bug #508568). Thanks Jeremiah
(Portage version: 2.2.11-r1/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/systemc/ChangeLog9
-rw-r--r--sci-electronics/systemc/systemc-2.3.1.ebuild59
2 files changed, 66 insertions, 2 deletions
diff --git a/sci-electronics/systemc/ChangeLog b/sci-electronics/systemc/ChangeLog
index 98286afcd600..e2a42da5ac49 100644
--- a/sci-electronics/systemc/ChangeLog
+++ b/sci-electronics/systemc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/systemc
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/systemc/ChangeLog,v 1.16 2013/09/15 14:40:07 tomjbe Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/systemc/ChangeLog,v 1.17 2014/08/10 17:07:58 tomjbe Exp $
+
+*systemc-2.3.1 (10 Aug 2014)
+
+ 10 Aug 2014; Thomas Beierlein <tomjbe@gentoo.org> +systemc-2.3.1.ebuild:
+ Version bump (bug #508568). Thanks Jeremiah
*systemc-2.3.0 (15 Sep 2013)
diff --git a/sci-electronics/systemc/systemc-2.3.1.ebuild b/sci-electronics/systemc/systemc-2.3.1.ebuild
new file mode 100644
index 000000000000..1225e7485452
--- /dev/null
+++ b/sci-electronics/systemc/systemc-2.3.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/systemc/systemc-2.3.1.ebuild,v 1.1 2014/08/10 17:07:58 tomjbe Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs autotools-utils
+
+DESCRIPTION="A C++ based modeling platform for VLSI and system-level co-design"
+HOMEPAGE="http://www.systemc.org/"
+SRC_URI="${P}.tgz"
+
+SLOT="0"
+LICENSE="SOPLA-3.0"
+IUSE="doc static-libs"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="fetch test"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+pkg_nofetch() {
+ elog "${PN} developers require end-users to accept their license agreement"
+ elog "by registering on their Web site (${HOMEPAGE})."
+ elog "Please download ${A} manually and place it in ${DISTDIR}."
+}
+
+src_prepare() {
+ for sfile in src/sysc/qt/md/*.s ; do
+ sed -i -e '$a \
+#if defined(__linux__) && defined(__ELF__) \
+.section .note.GNU-stack,"",%progbits \
+#endif' "${sfile}" || die "Patching ${sfile} failed"
+ done
+}
+
+src_configure() {
+ econf $(use_enable static-libs static) CXX=$(tc-getCXX)\
+ --with-unix-layout
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog INSTALL NEWS README RELEASENOTES
+ rm docs/SystemC_Open_Source_License.pdf || die
+ rm docs/Makefile* || die
+ use doc && dodoc -r docs/*
+ cd src
+ autotools-utils_src_install
+}
+
+pkg_postinst() {
+ elog "If you want to run the examples, you need to :"
+ elog " tar xvfz ${PORTAGE_ACTUAL_DISTDIR}/${A}"
+ elog " cd ${P}"
+ elog " find examples -name 'Makefile.*' -exec sed -i -e 's/-lm/-lm -lpthread/' '{}' \;"
+ elog " ./configure"
+ elog " cd examples"
+ elog " make check"
+}