summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2012-05-23 18:43:02 +0000
committerDenis Dupeyron <calchan@gentoo.org>2012-05-23 18:43:02 +0000
commit09b4e7c4405c02e34b236a88a295e1229a7a0e01 (patch)
tree6c3537c5cc422f4f39902c762144dc5825adee63 /sci-electronics
parentAdd jamvm to jre provider. #416819 (diff)
downloadgentoo-2-09b4e7c4405c02e34b236a88a295e1229a7a0e01.tar.gz
gentoo-2-09b4e7c4405c02e34b236a88a295e1229a7a0e01.tar.bz2
gentoo-2-09b4e7c4405c02e34b236a88a295e1229a7a0e01.zip
Version bump.
(Portage version: 2.1.10.62/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/ngspice/ChangeLog9
-rw-r--r--sci-electronics/ngspice/ngspice-24.ebuild98
2 files changed, 105 insertions, 2 deletions
diff --git a/sci-electronics/ngspice/ChangeLog b/sci-electronics/ngspice/ChangeLog
index a346fc13a868..e2be906e52cb 100644
--- a/sci-electronics/ngspice/ChangeLog
+++ b/sci-electronics/ngspice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/ngspice
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ngspice/ChangeLog,v 1.1 2011/07/15 22:45:58 calchan Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ngspice/ChangeLog,v 1.2 2012/05/23 18:43:02 calchan Exp $
+
+*ngspice-24 (23 May 2012)
+
+ 23 May 2012; Denis Dupeyron <calchan@gentoo.org> +ngspice-24.ebuild:
+ Version Bump.
*ngspice-23 (15 Jul 2011)
diff --git a/sci-electronics/ngspice/ngspice-24.ebuild b/sci-electronics/ngspice/ngspice-24.ebuild
new file mode 100644
index 000000000000..4409a03b6ae3
--- /dev/null
+++ b/sci-electronics/ngspice/ngspice-24.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ngspice/ngspice-24.ebuild,v 1.1 2012/05/23 18:43:02 calchan Exp $
+
+EAPI="3"
+
+inherit autotools eutils
+
+DESCRIPTION="The Next Generation Spice (Electronic Circuit Simulator)."
+SRC_URI="mirror://sourceforge/ngspice/${P}.tar.gz
+ mirror://sourceforge/ngspice/${PN}${PV}-manual.pdf.gz"
+HOMEPAGE="http://ngspice.sourceforge.net"
+LICENSE="BSD GPL-2"
+
+SLOT="0"
+IUSE="X debug readline"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="readline? ( >=sys-libs/readline-5.0 )
+ X? ( x11-libs/libXaw
+ x11-libs/libXt
+ x11-libs/libX11
+ sci-visualization/xgraph )"
+
+RDEPEND="$DEPEND"
+
+src_prepare() {
+ sed -e 's/_CFLAGS -O2/_CFLAGS/' -i configure.ac || die "sed failed"
+ sed -e 's/LDFLAGS =/LDFLAGS +=/' -i src/xspice/icm/makedefs.in || die "sed failed"
+ eautoreconf
+}
+
+src_configure() {
+ local MYCONF
+ if use debug ; then
+ MYCONF="--enable-debug \
+ --enable-ftedebug \
+ --enable-cpdebug \
+ --enable-asdebug \
+ --enable-stepdebug \
+ --enable-pzdebug"
+ else
+ MYCONF="--disable-debug \
+ --disable-ftedebug \
+ --disable-cpdebug \
+ --disable-asdebug \
+ --disable-stepdebug \
+ --disable-pzdebug"
+ fi
+ # Those don't compile
+ MYCONF="${MYCONF} \
+ --disable-sensdebug \
+ --disable-blktmsdebug \
+ --disable-smltmsdebug"
+
+ econf \
+ ${MYCONF} \
+ --enable-xspice \
+ --enable-cider \
+ --enable-ndev \
+ --disable-xgraph \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ $(use_with X x) \
+ $(use_with readline)
+}
+
+# These will need to be looked at some day:
+# --enable-adms
+# --enable-nodelimiting
+# --enable-predictor
+# --enable-newtrunc
+# --enable-openmp
+
+src_install () {
+ local infoFile
+ for infoFile in doc/ngspice.info*; do
+ echo 'INFO-DIR-SECTION EDA' >> ${infoFile}
+ echo 'START-INFO-DIR-ENTRY' >> ${infoFile}
+ echo '* NGSPICE: (ngspice). Electronic Circuit Simulator.' >> ${infoFile}
+ echo 'END-INFO-DIR-ENTRY' >> ${infoFile}
+ done
+
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ANALYSES AUTHORS BUGS ChangeLog DEVICES NEWS \
+ README Stuarts_Poly_Notes || die "failed to install documentation"
+
+ insinto /usr/share/doc/${PF}
+ doins ../${PN}${PV}-manual.pdf || die "failed to install manual"
+
+ # We don't need ngmakeidx to be installed
+ rm "${D}"/usr/bin/ngmakeidx
+}
+
+src_test () {
+ # Bug 108405
+ true
+}