summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-06-21 11:03:18 +0000
committerMichael Weber <xmw@gentoo.org>2012-06-21 11:03:18 +0000
commit33795d22e153fc20ddd397ec106421a4e6c45639 (patch)
tree9e7e695c0c6358bf60614d9a993f6104b567c577 /sci-electronics/xnec2c
parentFixed building with automake-1.12 (bug #422779) (diff)
downloadgentoo-2-33795d22e153fc20ddd397ec106421a4e6c45639.tar.gz
gentoo-2-33795d22e153fc20ddd397ec106421a4e6c45639.tar.bz2
gentoo-2-33795d22e153fc20ddd397ec106421a4e6c45639.zip
Version bumps (bug 420985)
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/xnec2c')
-rw-r--r--sci-electronics/xnec2c/ChangeLog11
-rw-r--r--sci-electronics/xnec2c/xnec2c-1.6.ebuild42
-rw-r--r--sci-electronics/xnec2c/xnec2c-2.0_beta.ebuild42
3 files changed, 93 insertions, 2 deletions
diff --git a/sci-electronics/xnec2c/ChangeLog b/sci-electronics/xnec2c/ChangeLog
index b772c196ca1a..1ea3847304d0 100644
--- a/sci-electronics/xnec2c/ChangeLog
+++ b/sci-electronics/xnec2c/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-electronics/xnec2c
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xnec2c/ChangeLog,v 1.6 2011/07/11 13:50:28 tomjbe Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xnec2c/ChangeLog,v 1.7 2012/06/21 11:03:18 xmw Exp $
+
+*xnec2c-2.0_beta (21 Jun 2012)
+*xnec2c-1.6 (21 Jun 2012)
+
+ 21 Jun 2012; Michael Weber <xmw@gentoo.org> +xnec2c-1.6.ebuild,
+ +xnec2c-2.0_beta.ebuild:
+ Version bumps (bug 420985)
*xnec2c-1.5 (11 Jul 2011)
diff --git a/sci-electronics/xnec2c/xnec2c-1.6.ebuild b/sci-electronics/xnec2c/xnec2c-1.6.ebuild
new file mode 100644
index 000000000000..63796facf57b
--- /dev/null
+++ b/sci-electronics/xnec2c/xnec2c-1.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xnec2c/xnec2c-1.6.ebuild,v 1.1 2012/06/21 11:03:18 xmw Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="A GTK+ graphical interactive version of nec2c."
+HOMEPAGE="http://www.qsl.net/5b4az/pages/nec2.html"
+SRC_URI="http://www.qsl.net/5b4az/pkg/nec2/xnec2c/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+S="${WORKDIR}/${PN}"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.4-fortify.patch
+
+ glib-gettextize --force --copy || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS README doc/*.txt || die
+ dohtml -r doc/* || die
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ fi
+}
diff --git a/sci-electronics/xnec2c/xnec2c-2.0_beta.ebuild b/sci-electronics/xnec2c/xnec2c-2.0_beta.ebuild
new file mode 100644
index 000000000000..83a59efc4f30
--- /dev/null
+++ b/sci-electronics/xnec2c/xnec2c-2.0_beta.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xnec2c/xnec2c-2.0_beta.ebuild,v 1.1 2012/06/21 11:03:18 xmw Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="A GTK+ graphical interactive version of nec2c."
+HOMEPAGE="http://www.qsl.net/5b4az/pages/nec2.html"
+SRC_URI="http://www.qsl.net/5b4az/pkg/nec2/xnec2c/${P/_beta/-beta}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+S="${WORKDIR}/${PN}"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.4-fortify.patch
+
+ glib-gettextize --force --copy || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS README doc/*.txt || die
+ dohtml -r doc/* || die
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ fi
+}