summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2012-05-12 06:19:44 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2012-05-12 06:19:44 +0000
commita3bc5ca4bc2c97d2b26f5ef9d871ce2f31cc7a23 (patch)
treea39c2eb49d229c923cf84b89e07c32a653179584 /sci-electronics/xcircuit
parentRemove old. (diff)
downloadgentoo-2-a3bc5ca4bc2c97d2b26f5ef9d871ce2f31cc7a23.tar.gz
gentoo-2-a3bc5ca4bc2c97d2b26f5ef9d871ce2f31cc7a23.tar.bz2
gentoo-2-a3bc5ca4bc2c97d2b26f5ef9d871ce2f31cc7a23.zip
Version bump
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/xcircuit')
-rw-r--r--sci-electronics/xcircuit/ChangeLog9
-rw-r--r--sci-electronics/xcircuit/xcircuit-3.7.39.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/sci-electronics/xcircuit/ChangeLog b/sci-electronics/xcircuit/ChangeLog
index 5183888d8995..325792cf3032 100644
--- a/sci-electronics/xcircuit/ChangeLog
+++ b/sci-electronics/xcircuit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/xcircuit
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/ChangeLog,v 1.49 2010/07/18 13:36:50 nixnut Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/ChangeLog,v 1.50 2012/05/12 06:19:44 tomjbe Exp $
+
+*xcircuit-3.7.39 (12 May 2012)
+
+ 12 May 2012; Thomas Beierlein <tomjbe@gentoo.org> +xcircuit-3.7.39.ebuild:
+ Version bump
18 Jul 2010; <nixnut@gentoo.org> xcircuit-3.6.165.ebuild:
ppc stable #324117
diff --git a/sci-electronics/xcircuit/xcircuit-3.7.39.ebuild b/sci-electronics/xcircuit/xcircuit-3.7.39.ebuild
new file mode 100644
index 000000000000..e7afde3e4c27
--- /dev/null
+++ b/sci-electronics/xcircuit/xcircuit-3.7.39.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/xcircuit-3.7.39.ebuild,v 1.1 2012/05/12 06:19:44 tomjbe Exp $
+
+EAPI=2
+inherit autotools eutils multilib
+
+DESCRIPTION="Circuit drawing and schematic capture program."
+SRC_URI="http://opencircuitdesign.com/xcircuit/archive/${P}.tgz"
+HOMEPAGE="http://opencircuitdesign.com/xcircuit"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXpm
+ x11-libs/libSM
+ x11-libs/libICE
+ sys-libs/zlib
+ app-text/ghostscript-gpl
+ dev-lang/tcl
+ dev-lang/tk"
+RDEPEND=${DEPEND}
+
+RESTRICT="test" #131024
+
+src_prepare() {
+ eautoreconf # avoid QA-warning wrt automaintainer mode
+}
+
+src_configure() {
+ export loader_run_path="/usr/$(get_libdir)"
+ econf \
+ --disable-dependency-tracking \
+ --with-tcl \
+ --with-ngspice
+}
+
+src_compile() {
+ emake appdefaultsdir="/usr/share/X11/app-defaults" || die
+}
+
+src_install () {
+ emake DESTDIR="${D}" appdefaultsdir="/usr/share/X11/app-defaults" \
+ appmandir="/usr/share/man/man1" install || die
+ dodoc CHANGES README* TODO
+}