summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-05-13 22:14:08 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-05-13 22:14:08 +0000
commite8d2013376ca57aaa1ab1a976722afcc278d60c9 (patch)
treecb57c90e14f4c01e2c05cd6add3b69c038cdd7c5 /sci-chemistry
parentBump. Many of the changes are internal, to help adding new translators etc. A... (diff)
downloadgentoo-2-e8d2013376ca57aaa1ab1a976722afcc278d60c9.tar.gz
gentoo-2-e8d2013376ca57aaa1ab1a976722afcc278d60c9.tar.bz2
gentoo-2-e8d2013376ca57aaa1ab1a976722afcc278d60c9.zip
Fix parallel build. Remove the really ugly LDFLAGS hack, it's no longer needed. Cleaner installation of executable and wrapper.
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/mopac7/ChangeLog11
-rw-r--r--sci-chemistry/mopac7/files/digest-mopac7-1.102
-rw-r--r--sci-chemistry/mopac7/files/digest-mopac7-1.10-r13
-rw-r--r--sci-chemistry/mopac7/mopac7-1.10-r1.ebuild50
4 files changed, 64 insertions, 2 deletions
diff --git a/sci-chemistry/mopac7/ChangeLog b/sci-chemistry/mopac7/ChangeLog
index f2439178623e..9fabea0e95f8 100644
--- a/sci-chemistry/mopac7/ChangeLog
+++ b/sci-chemistry/mopac7/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/mopac7
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/ChangeLog,v 1.6 2005/12/06 09:09:25 spyderous Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/ChangeLog,v 1.7 2006/05/13 22:14:08 spyderous Exp $
+
+*mopac7-1.10-r1 (13 May 2006)
+
+ 13 May 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ +mopac7-1.10-r1.ebuild:
+ Fix parallel build. Remove the really ugly LDFLAGS hack, it's no longer
+ needed. Cleaner installation of executable and wrapper.
*mopac7-1.10 (06 Dec 2005)
diff --git a/sci-chemistry/mopac7/files/digest-mopac7-1.10 b/sci-chemistry/mopac7/files/digest-mopac7-1.10
index e7bcdc3bc869..da9189352166 100644
--- a/sci-chemistry/mopac7/files/digest-mopac7-1.10
+++ b/sci-chemistry/mopac7/files/digest-mopac7-1.10
@@ -1 +1,3 @@
MD5 d5352a3cf349b9ac4df943bb7992cfa9 mopac7-1.10.tgz 1596446
+RMD160 19c6c97c91d3762269e8add5b2c43c9473efcf90 mopac7-1.10.tgz 1596446
+SHA256 993ace860c77345d1c8629f416bfc765610b9f264e9885b3777f44b745817ab5 mopac7-1.10.tgz 1596446
diff --git a/sci-chemistry/mopac7/files/digest-mopac7-1.10-r1 b/sci-chemistry/mopac7/files/digest-mopac7-1.10-r1
new file mode 100644
index 000000000000..da9189352166
--- /dev/null
+++ b/sci-chemistry/mopac7/files/digest-mopac7-1.10-r1
@@ -0,0 +1,3 @@
+MD5 d5352a3cf349b9ac4df943bb7992cfa9 mopac7-1.10.tgz 1596446
+RMD160 19c6c97c91d3762269e8add5b2c43c9473efcf90 mopac7-1.10.tgz 1596446
+SHA256 993ace860c77345d1c8629f416bfc765610b9f264e9885b3777f44b745817ab5 mopac7-1.10.tgz 1596446
diff --git a/sci-chemistry/mopac7/mopac7-1.10-r1.ebuild b/sci-chemistry/mopac7/mopac7-1.10-r1.ebuild
new file mode 100644
index 000000000000..3ac2ba4315ee
--- /dev/null
+++ b/sci-chemistry/mopac7/mopac7-1.10-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/mopac7-1.10-r1.ebuild,v 1.1 2006/05/13 22:14:08 spyderous Exp $
+
+inherit autotools
+
+DESCRIPTION="Autotooled, updated version of a powerful, fast semi-empirical package"
+HOMEPAGE="http://sourceforge.net/projects/mopac7/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+LICENSE="mopac7"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+RDEPEND="dev-libs/libf2c"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Install the executable
+ sed -i \
+ -e "s:noinst_PROGRAMS = mopac7:bin_PROGRAMS = mopac7:g" \
+ src/Makefile.am \
+ || die "sed failed: install mopac7"
+ # Install the script to run the executable
+ sed -i \
+ -e "s:EXTRA_DIST = run_mopac7:if HAVE_F2C\nbin_SCRIPTS = run_mopac7\nendif:g" \
+ Makefile.am \
+ || die "sed failed: install run_mopac7"
+
+ # Fix parallel build by adding internal dependency on libmopac7.la from
+ # executable
+ sed -i \
+ -e "s:mopac7_LDFLAGS = -lmopac7 -lf2c -lm:mopac7_LDFLAGS = -lf2c -lm:g" \
+ -e "s:\(mopac7_LDFLAGS.*\):\1\nmopac7_LDADD = libmopac7.la:g" \
+ src/Makefile.am \
+ || die "sed failed: fix dependencies"
+
+ eautoreconf
+}
+
+src_install() {
+ # A correct fix would have a run_mopac7.in with @bindir@ that gets
+ # replaced by configure, and run_mopac7 added to AC_OUTPUT in configure.ac
+ sed -i "s:./src/mopac7:mopac7:g" run_mopac7
+
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS README ChangeLog
+}