summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-07-02 08:56:56 +0000
committerJustin Lecher <jlec@gentoo.org>2011-07-02 08:56:56 +0000
commitd62ef6a65c30e0584e0d2cdd456cbdb19da0d69b (patch)
tree7b231679c6a7c5b88091715269e501d417774b59 /sci-chemistry
parentUse pkg-config to detect mmdb and lapack libs (diff)
downloadgentoo-2-d62ef6a65c30e0584e0d2cdd456cbdb19da0d69b.tar.gz
gentoo-2-d62ef6a65c30e0584e0d2cdd456cbdb19da0d69b.tar.bz2
gentoo-2-d62ef6a65c30e0584e0d2cdd456cbdb19da0d69b.zip
Use pkg-config to detect mmdb and lapack libs
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/apbs/ChangeLog6
-rw-r--r--sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild6
-rw-r--r--sci-chemistry/apbs/apbs-1.3-r1.ebuild6
-rw-r--r--sci-chemistry/apbs/apbs-1.3.ebuild6
-rw-r--r--sci-chemistry/apbs/metadata.xml18
5 files changed, 23 insertions, 19 deletions
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
index b81d48ff05fc..eba59b3182cd 100644
--- a/sci-chemistry/apbs/ChangeLog
+++ b/sci-chemistry/apbs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/apbs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.48 2011/06/21 16:07:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.49 2011/07/02 08:56:56 jlec Exp $
+
+ 02 Jul 2011; Justin Lecher <jlec@gentoo.org> apbs-1.2.1b-r4.ebuild,
+ apbs-1.3.ebuild, apbs-1.3-r1.ebuild, metadata.xml:
+ Use pkg-config to detect mmdb and lapack libs
21 Jun 2011; Justin Lecher <jlec@gentoo.org> apbs-1.2.1b-r4.ebuild,
apbs-1.3.ebuild, apbs-1.3-r1.ebuild:
diff --git a/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild b/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
index 57f1b2f70d94..00f87514ed85 100644
--- a/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
+++ b/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild,v 1.11 2011/06/21 16:07:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild,v 1.12 2011/07/02 08:56:56 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit autotools eutils fortran-2 flag-o-matic python toolchain-funcs versionator
+inherit autotools eutils flag-o-matic fortran-2 python toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-3)
MY_P="${PN}-${MY_PV}"
@@ -80,7 +80,7 @@ src_configure() {
econf \
--disable-maloc-rebuild \
--enable-shared \
- --with-blas=-lblas \
+ --with-blas="$(pkg-config --libs blas)" \
$(use_enable openmp) \
$(use_enable python) \
$(use_enable tools) \
diff --git a/sci-chemistry/apbs/apbs-1.3-r1.ebuild b/sci-chemistry/apbs/apbs-1.3-r1.ebuild
index b686e745cd1a..894cf101e429 100644
--- a/sci-chemistry/apbs/apbs-1.3-r1.ebuild
+++ b/sci-chemistry/apbs/apbs-1.3-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3-r1.ebuild,v 1.5 2011/06/21 16:07:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3-r1.ebuild,v 1.6 2011/07/02 08:56:56 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit autotools eutils fortran-2 flag-o-matic python toolchain-funcs versionator
+inherit autotools eutils flag-o-matic fortran-2 python toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-3)
MY_P="${PN}-${MY_PV}"
@@ -108,7 +108,7 @@ src_configure() {
econf \
--disable-maloc-rebuild \
--enable-shared \
- --with-blas=-lblas \
+ --with-blas="$(pkg-config --libs blas)" \
$(use_enable openmp) \
$(use_enable python) \
$(use_enable tools) \
diff --git a/sci-chemistry/apbs/apbs-1.3.ebuild b/sci-chemistry/apbs/apbs-1.3.ebuild
index a35ae022f15d..5939b16a69f2 100644
--- a/sci-chemistry/apbs/apbs-1.3.ebuild
+++ b/sci-chemistry/apbs/apbs-1.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3.ebuild,v 1.7 2011/06/21 16:07:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3.ebuild,v 1.8 2011/07/02 08:56:56 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit autotools eutils fortran-2 flag-o-matic python toolchain-funcs versionator
+inherit autotools eutils flag-o-matic fortran-2 python toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-3)
MY_P="${PN}-${MY_PV}"
@@ -105,7 +105,7 @@ src_configure() {
econf \
--disable-maloc-rebuild \
--enable-shared \
- --with-blas=-lblas \
+ --with-blas="$(pkg-config --libs blas)" \
$(use_enable openmp) \
$(use_enable python) \
$(use_enable tools) \
diff --git a/sci-chemistry/apbs/metadata.xml b/sci-chemistry/apbs/metadata.xml
index 8a1c32e03b3d..568638098427 100644
--- a/sci-chemistry/apbs/metadata.xml
+++ b/sci-chemistry/apbs/metadata.xml
@@ -2,21 +2,21 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci-chemistry</herd>
- <maintainer>
- <email>markusle@gentoo.org</email>
- <name>Markus Dittrich</name>
- </maintainer>
+ <maintainer>
+ <email>markusle@gentoo.org</email>
+ <name>Markus Dittrich</name>
+ </maintainer>
<maintainer>
<email>jlec@gentoo.org</email>
<name>Justin Lecher</name>
<description>Ebuild Crasher</description>
- </maintainer>
+ </maintainer>
<use>
- <flag name='arpack'>Include support for arpack libs</flag>
- <flag name='fetk'>Include support for FeTK</flag>
- <flag name='tools'>Install optional tools</flag>
+ <flag name="arpack">Include support for arpack libs</flag>
+ <flag name="fetk">Include support for FeTK</flag>
+ <flag name="tools">Install optional tools</flag>
</use>
-<longdescription>
+ <longdescription>
APBS is a software package for modeling biomolecular solvation through solution
of the Poisson-Boltzmann equation (PBE), one of the most popular continuum
models for describing electrostatic interactions between molecular solutes in