summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-18 08:57:09 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-18 08:57:09 +0000
commitc14d4fda5374dee29bdd9309d19a2d07099972d1 (patch)
tree385883af9f453f49cd386e068d227b913cfa748e /sci-chemistry
parentqa: formatting (diff)
downloadgentoo-2-c14d4fda5374dee29bdd9309d19a2d07099972d1.tar.gz
gentoo-2-c14d4fda5374dee29bdd9309d19a2d07099972d1.tar.bz2
gentoo-2-c14d4fda5374dee29bdd9309d19a2d07099972d1.zip
New Addition
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/prekin/ChangeLog11
-rw-r--r--sci-chemistry/prekin/files/6.51.081122-Makefile.patch41
-rw-r--r--sci-chemistry/prekin/metadata.xml8
-rw-r--r--sci-chemistry/prekin/prekin-6.51.081122.ebuild52
4 files changed, 112 insertions, 0 deletions
diff --git a/sci-chemistry/prekin/ChangeLog b/sci-chemistry/prekin/ChangeLog
new file mode 100644
index 000000000000..47e68d5f385a
--- /dev/null
+++ b/sci-chemistry/prekin/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-chemistry/prekin
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/prekin/ChangeLog,v 1.1 2010/07/18 08:57:09 jlec Exp $
+
+*prekin-6.51.081122 (18 Jul 2010)
+
+ 18 Jul 2010; Justin Lecher <jlec@gentoo.org>
+ +files/6.51.081122-Makefile.patch, +prekin-6.51.081122.ebuild,
+ +metadata.xml:
+ New Addition
+
diff --git a/sci-chemistry/prekin/files/6.51.081122-Makefile.patch b/sci-chemistry/prekin/files/6.51.081122-Makefile.patch
new file mode 100644
index 000000000000..5fd9d00d9b06
--- /dev/null
+++ b/sci-chemistry/prekin/files/6.51.081122-Makefile.patch
@@ -0,0 +1,41 @@
+diff --git a/Makefile.linux b/Makefile.linux
+index 65a021a..3daacd8 100755
+--- a/Makefile.linux
++++ b/Makefile.linux
+@@ -1,15 +1,15 @@
+ #
+-CFLAGS = -I/usr/X11R6/include
++CFLAGS += -I/usr/X11R6/include
+
+ ifeq ($(MAKECMDGOALS),debug)
+ CFLAGS = -g -I/usr/X11R6/include
+ endif
+
+-LIBS = -L/usr/lib -L/usr/X11R6/lib -lXmu -lXm -lXt -lSM -lICE -lXext -lX11
++LIBS = -L/usr/GENTOOLIBDIR -L/usr/X11R6/lib -lXmu -lXm -lXt -lSM -lICE -lXext -lX11
+
+ ifeq ($(MAKECMDGOALS),nogui)
+-CFLAGS = -D NOGUI -I/usr/X11R6/include
+-LIBS = -L/usr/lib -L/usr/X11R6/lib -lXmu -lXt -lSM -lICE -lXext -lX11
++CFLAGS += -D NOGUI -I/usr/X11R6/include
++LIBS = -L/usr/GENTOOLIBDIR -L/usr/X11R6/lib -lXmu -lXt -lSM -lICE -lXext -lX11
+ endif
+
+ FIN = -lm -pthread #for RH9.0, ok for RH7.3 & RH8.0
+@@ -26,13 +26,13 @@ OBJS = PKINANGL.o PKINCRTL.o PKINCSBS.o PKINCSUB.o PKINCOUT.o PKINMENU.o PKINROT
+ # Commands specific to clients created by this Makefile
+
+ prekin: $(OBJS)
+- cc -o prekin $(CFLAGS) $(OBJS) -L/usr/X11R6/lib $(LIBS) -ldl $(FIN)
++ cc -o prekin $(CFLAGS) $(LDFLAGS) $(OBJS) -L/usr/X11R6/lib $(LIBS) -ldl $(FIN)
+
+ debug: $(OBJS)
+- cc -o prekin $(CFLAGS) $(OBJS) -L/usr/X11R6/lib $(LIBS) -ldl $(FIN)
++ cc -o prekin $(CFLAGS) $(LDFLAGS) $(OBJS) -L/usr/X11R6/lib $(LIBS) -ldl $(FIN)
+
+ nogui: $(OBJS)
+- cc -o prekin $(CFLAGS) $(OBJS) -L/usr/X11R6/lib $(LIBS) -ldl $(FIN)
++ cc -o prekin $(CFLAGS) $(LDFLAGS) $(OBJS) -L/usr/X11R6/lib $(LIBS) -ldl $(FIN)
+
+ clean:
+ rm *.o
diff --git a/sci-chemistry/prekin/metadata.xml b/sci-chemistry/prekin/metadata.xml
new file mode 100644
index 000000000000..9a1f70b1fd6f
--- /dev/null
+++ b/sci-chemistry/prekin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+<use>
+ <flag name='gui'>build gui support</flag>
+</use>
+</pkgmetadata>
diff --git a/sci-chemistry/prekin/prekin-6.51.081122.ebuild b/sci-chemistry/prekin/prekin-6.51.081122.ebuild
new file mode 100644
index 000000000000..efe0dabb7ea2
--- /dev/null
+++ b/sci-chemistry/prekin/prekin-6.51.081122.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/prekin/prekin-6.51.081122.ebuild,v 1.1 2010/07/18 08:57:09 jlec Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs eutils multilib
+
+MY_P="${PN}.${PV}"
+
+DESCRIPTION="Prepares molecular kinemages (input files for Mage & KiNG) from PDB-format coordinate files"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/prekin.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/prekin/${MY_P}.src.tgz"
+
+LICENSE="richardson"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="X"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXt
+ X? ( x11-libs/openmotif )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-Makefile.patch
+ sed \
+ -e 's:cc:$(CC):g' \
+ -e "s:GENTOOLIBDIR:$(get_libdir):g" \
+ "${S}"/Makefile.linux > Makefile
+}
+
+src_compile() {
+ local mytarget
+
+ if use X; then
+ mytarget="${PN}"
+ else
+ mytarget="nogui"
+ fi
+
+ emake \
+ CC="$(tc-getCC)" \
+ ${mytarget} || die "make failed"
+}
+
+src_install() {
+ dobin "${S}"/prekin || die "dobin failed"
+}