summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-27 14:57:36 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-27 14:57:36 +0000
commit756dd6dcbaafe0c4abf6a49cc5c650275d150086 (patch)
tree4d1ae69a9c2ed0e6ab4a8308856d09d2825ccfe8 /sci-chemistry
parentStable for x86, wrt bug #450678 (diff)
downloadgentoo-2-756dd6dcbaafe0c4abf6a49cc5c650275d150086.tar.gz
gentoo-2-756dd6dcbaafe0c4abf6a49cc5c650275d150086.tar.bz2
gentoo-2-756dd6dcbaafe0c4abf6a49cc5c650275d150086.zip
sci-chemistry/ball: Use python-single-r1 eclass
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/ball/ChangeLog5
-rw-r--r--sci-chemistry/ball/ball-1.4.1-r1.ebuild9
2 files changed, 9 insertions, 5 deletions
diff --git a/sci-chemistry/ball/ChangeLog b/sci-chemistry/ball/ChangeLog
index c91f8be9068f..0ef90f505e51 100644
--- a/sci-chemistry/ball/ChangeLog
+++ b/sci-chemistry/ball/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-chemistry/ball
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ball/ChangeLog,v 1.4 2013/01/27 14:30:47 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ball/ChangeLog,v 1.5 2013/01/27 14:57:36 jlec Exp $
+
+ 27 Jan 2013; Justin Lecher <jlec@gentoo.org> ball-1.4.1-r1.ebuild:
+ Use python-single-r1 eclass
*ball-1.4.1-r1 (27 Jan 2013)
diff --git a/sci-chemistry/ball/ball-1.4.1-r1.ebuild b/sci-chemistry/ball/ball-1.4.1-r1.ebuild
index 6d923d89e238..53975f2b28a2 100644
--- a/sci-chemistry/ball/ball-1.4.1-r1.ebuild
+++ b/sci-chemistry/ball/ball-1.4.1-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ball/ball-1.4.1-r1.ebuild,v 1.1 2013/01/27 14:30:47 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ball/ball-1.4.1-r1.ebuild,v 1.2 2013/01/27 14:57:36 jlec Exp $
-EAPI=4
+EAPI=5
-PYTHON_DEPEND="python? 2"
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
-inherit cmake-utils python
+inherit cmake-utils python-single-r1
DESCRIPTION="Biochemical Algorithms Library"
HOMEPAGE="http://www.ball-project.org/"
@@ -34,6 +34,7 @@ RDEPEND="
x11-libs/qt-webkit:4
cuda? ( dev-util/nvidia-cuda-toolkit )
mpi? ( virtual/mpi )
+ python? ( ${PYTHON_DEPS} )
sql? ( x11-libs/qt-sql:4 )
webkit? ( x11-libs/qt-webkit:4 )"
DEPEND="${RDEPEND}