summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-05-23 13:29:17 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-05-23 13:29:17 +0000
commit52ee4514ea5a0c4de4db6ff78cfaa4068dd8a41a (patch)
treeba41cc8b5442a428bd8283cbf7a48de86cf14b32 /sci-chemistry
parentFix qt4 build and only install libpoppler-cairo.la with USE=cairo (diff)
downloadgentoo-2-52ee4514ea5a0c4de4db6ff78cfaa4068dd8a41a.tar.gz
gentoo-2-52ee4514ea5a0c4de4db6ff78cfaa4068dd8a41a.tar.bz2
gentoo-2-52ee4514ea5a0c4de4db6ff78cfaa4068dd8a41a.zip
Removed ifc use flag and replaced it with fortran.eclass logic
(Portage version: 2.1_rc2)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gamess/ChangeLog6
-rw-r--r--sci-chemistry/gamess/gamess-20060222.2.ebuild43
2 files changed, 23 insertions, 26 deletions
diff --git a/sci-chemistry/gamess/ChangeLog b/sci-chemistry/gamess/ChangeLog
index c49ff9a7d0b8..8e9053bc5c29 100644
--- a/sci-chemistry/gamess/ChangeLog
+++ b/sci-chemistry/gamess/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/gamess
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/ChangeLog,v 1.12 2006/05/14 07:30:02 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/ChangeLog,v 1.13 2006/05/23 13:29:17 markusle Exp $
+
+ 23 May 2006; Markus Dittrich <markusle@gentoo.org>
+ gamess-20060222.2.ebuild:
+ Removed ifc use flag and replaced it with fortran.eclass logic.
14 May 2006; Donnie Berkholz <spyderous@gentoo.org>;
gamess-05272005.5.ebuild, gamess-20060222.2.ebuild:
diff --git a/sci-chemistry/gamess/gamess-20060222.2.ebuild b/sci-chemistry/gamess/gamess-20060222.2.ebuild
index 48351c1b902f..40e9eb2f7832 100644
--- a/sci-chemistry/gamess/gamess-20060222.2.ebuild
+++ b/sci-chemistry/gamess/gamess-20060222.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/gamess-20060222.2.ebuild,v 1.4 2006/05/14 07:30:02 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/gamess-20060222.2.ebuild,v 1.5 2006/05/23 13:29:17 markusle Exp $
inherit eutils toolchain-funcs fortran flag-o-matic
@@ -11,24 +11,22 @@ SRC_URI="${P}.tar.gz"
SLOT="0"
KEYWORDS="~ppc ~x86"
-IUSE="ifc hardened blas"
+IUSE="hardened blas"
RESTRICT="fetch"
DEPEND="app-shells/tcsh
- ifc? ( >=dev-lang/ifc-8.1 )
hardened? ( sys-apps/paxctl )
blas? ( virtual/blas )"
RDEPEND="app-shells/tcsh
- net-misc/openssh
- ifc? ( >=dev-lang/ifc-8.1 )"
+ net-misc/openssh"
S="${WORKDIR}/${PN}"
GAMESS_DOWNLOAD="http://www.msg.ameslab.gov/GAMESS/License_Agreement.html"
GAMESS_VERSION="22 FEB 2006 (R2)"
-
+FORTRAN="ifc g77 gfortran"
pkg_nofetch() {
echo
@@ -41,17 +39,11 @@ pkg_nofetch() {
}
pkg_setup() {
- # make sure we have the proper fortan compiler;
- # use ifc for USE="ifc" and g77 otherwise
- if use ifc; then
- need_fortran ifc
- else
- need_fortran gfortran g77
- fi
+ fortran_pkg_setup
# blas and ifc don't go together
- if use blas && use ifc; then
- die "${PN} can not be compiled with USE=blas and USE=ifc"
+ if use blas && [[ "${FORTRANC}" = "ifc" ]]; then
+ die "${PN} can not be compiled with USE=blas and ifc"
fi
}
@@ -67,14 +59,14 @@ src_unpack() {
# for hardened-gcc let't turn off ssp, since it breakes
# a few routines
cd "${S}"
- if use hardened && ([[ ${FORTRANC} = g77 ]]); then
+ if use hardened && [[ "${FORTRANC}" = "g77" ]]; then
FFLAGS="${FFLAGS} -fno-stack-protector-all"
fi
# some fixes for gfortan;
# also append -w otherwise we get flooded with Hollerith
# constant warnings
- if [[ ${FORTRANC} == gfortran ]]; then
+ if [[ "${FORTRANC}" == "gfortran" ]]; then
FFLAGS="${FFLAGS} -w"
sed -e "s|-fno-move-all-movables|-w|g" \
@@ -102,11 +94,11 @@ src_unpack() {
# insert proper FFLAGS into GAMESS' comp makefile
# in case we're using ifc let's strip all the gcc
# specific stuff
- if use ifc; then
+ if [[ "${FORTRANC}" == "ifc" ]]; then
sed -e "s/-malign-double -fautomatic /-cm -w \$MODULE.f/" \
-e "s/-Wno-globals -fno-globals \$MODULE.f//" \
-e "s/gentoo-OPT = '-O2'/OPT = '${FFLAGS} -quiet'/" \
- -e "s/gentoo-g77/${FORTANC}/" \
+ -e "s/gentoo-g77/${FORTRANC}/" \
-i comp || die "Failed setting up comp script"
elif ! use x86; then
sed -e "s/-malign-double //" \
@@ -126,7 +118,7 @@ src_unpack() {
fi
# fix up GAMESS' linker script;
- if use ifc; then
+ if [[ "${FORTRANC}" == "ifc" ]]; then
sed -e "s/gentoo-LDR='g77'/LDR='${FORTRANC}'/" \
-e "s/gentoo-LDOPTS=' '/LDOPTS='${LDFLAGS}'/" \
-i lked || die "Failed setting up lked script"
@@ -142,7 +134,8 @@ src_unpack() {
# for ifc/gcc-4.x we have to fix the number of underscores of
# fortran symbols, otherwise the linker will barf
- if use ifc || [[ $(gcc-major-version) -ge 4 ]]; then
+ if [[ "${FORTRANC}" == "ifc" ]] || \
+ [[ $(gcc-major-version) -ge 4 ]]; then
sed -e "s/gentoo-F77_OPTS = '-DINT_SIZE=int -D_UNDERSCORES=2/F77_OPTS = '-DINT_SIZE=int -D_UNDERSCORES=1/" \
-i ddi/compddi || die "Failed fixing underscores in compddi"
else
@@ -154,12 +147,12 @@ src_unpack() {
src_compile() {
# build actvte
cd "${S}"/tools
- ${FORTRANC} -o actvte.x actvte.f || \
+ "${FORTRANC}" -o actvte.x actvte.f || \
die "Failed to compile actvte.x"
# for hardened (PAX) users and ifc we need to turn
# MPROTECT off
- if use ifc && use hardened; then
+ if [[ "${FORTRANC}" == "ifc" ]] && use hardened; then
/sbin/paxctl -PemRxS actvte.x 2> /dev/null || \
die "paxctl failed on actvte.x"
fi
@@ -178,7 +171,7 @@ src_compile() {
# for hardened (PAX) users and ifc we need to turn
# MPROTECT off
- if use ifc && use hardened; then
+ if [[ "${FORTRANC}" == "ifc" ]] && use hardened; then
/sbin/paxctl -PemRxS ${PN}.00.x 2> /dev/null || \
die "paxctl failed on actvte.x"
fi
@@ -234,7 +227,7 @@ pkg_postinst() {
ewarn "have been addressed."
fi
- if use ifc; then
+ if [[ "${FORTRANC}" == "ifc" ]]; then
echo
ewarn "IMPORTANT NOTE: We STRONGLY recommend to stay away"
ewarn "from ifc-9.0 for now and use the ifc-8.1 series of"