summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-06 21:59:58 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-06 21:59:58 +0000
commit4e2febb484a970669a6cfc316b7a000f213b569b (patch)
treeb9f2073ce7c1dc29d26ba3b34fe12917405d1ed5 /sci-chemistry
parentAdd ~x86-fbsd keyword. (diff)
downloadgentoo-2-4e2febb484a970669a6cfc316b7a000f213b569b.tar.gz
gentoo-2-4e2febb484a970669a6cfc316b7a000f213b569b.tar.bz2
gentoo-2-4e2febb484a970669a6cfc316b7a000f213b569b.zip
Bump.
(Portage version: 2.1.1_rc1)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/coot/ChangeLog7
-rw-r--r--sci-chemistry/coot/coot-0.1.2.ebuild91
-rw-r--r--sci-chemistry/coot/files/digest-coot-0.1.23
3 files changed, 100 insertions, 1 deletions
diff --git a/sci-chemistry/coot/ChangeLog b/sci-chemistry/coot/ChangeLog
index 0ecb174ee127..44d340cbff3d 100644
--- a/sci-chemistry/coot/ChangeLog
+++ b/sci-chemistry/coot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/coot
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/ChangeLog,v 1.4 2006/08/05 05:08:18 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/ChangeLog,v 1.5 2006/09/06 21:59:58 dberkholz Exp $
+
+*coot-0.1.2 (06 Sep 2006)
+
+ 06 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>; +coot-0.1.2.ebuild:
+ Bump.
05 Aug 2006; Donnie Berkholz <dberkholz@gentoo.org>; metadata.xml:
Remove myself as maintainer, anyone feel free to work on this, although I'll
diff --git a/sci-chemistry/coot/coot-0.1.2.ebuild b/sci-chemistry/coot/coot-0.1.2.ebuild
new file mode 100644
index 000000000000..f263dcf187b5
--- /dev/null
+++ b/sci-chemistry/coot/coot-0.1.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.1.2.ebuild,v 1.1 2006/09/06 21:59:58 dberkholz Exp $
+
+inherit autotools
+
+MY_PV=${PV/_pre/-pre-}
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Crystallographic Object-Oriented Toolkit for model building, completion and validation"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~emsley/coot/"
+RESTRICT="mirror"
+if [[ ${MY_PV} = *pre* ]]; then
+ SRC_URI="http://www.ysbl.york.ac.uk/~emsley/software/pre-release/${MY_P}.tar.gz"
+else
+ SRC_URI="http://www.ysbl.york.ac.uk/~emsley/software/${MY_P}.tar.gz"
+fi
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+RDEPEND=">=sci-libs/gsl-1.3
+ =dev-libs/glib-1.2*
+ =x11-libs/gtkglarea-1.2*
+ x11-libs/gtkglext
+ virtual/glut
+ virtual/opengl
+ sci-chemistry/ccp4
+ dev-lang/python
+ x11-libs/gtk-canvas
+ dev-lang/python
+ x11-libs/guile-gtk
+ dev-scheme/guile-gui
+ dev-scheme/net-http
+ dev-scheme/goosh
+ dev-scheme/guile-www
+ sci-libs/coot-data
+ sci-chemistry/reduce
+ sci-chemistry/probe"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ # Link against single-precision fftw
+ sed -i \
+ -e "s:lfttw:lsfttw:g" \
+ -e "s:lrfttw:lsrfttw:g" \
+ "${S}"/macros/clipper.m4
+
+ # Don't install setup scripts, they're only needed for nonstandard prefixes
+ sed -i \
+ -e "s:^\(setup.*\):#\1:g" \
+ -e "s:.*\(bin_.*\):\1:g" \
+ "${S}"/setup/Makefile.am
+
+ # Fix where it looks for some binaries
+ sed -i \
+ -e "s:/y/people/emsley/coot/Linux/bin/probe.2.11.050121.linux.RH9:${ROOT}usr/bin/probe:g" \
+ -e "s:/y/people/emsley/coot/Linux/bin/reduce.2.21.030604:${ROOT}usr/bin/reduce:g" \
+ "${S}"/scheme/group-settings.scm
+
+ cd "${S}"
+ AT_M4DIR="macros" eautoreconf
+}
+
+src_compile() {
+ # All the --with's are used to activate various parts.
+ # Yes, this is broken behavior.
+ econf \
+ --includedir='${prefix}/include/coot' \
+ --with-gtkcanvas-prefix=/usr \
+ --with-clipper-prefix=/usr \
+ --with-mmdb-prefix=/usr \
+ --with-ssmlib-prefix=/usr \
+ --with-guile=/usr \
+ --with-python=/usr \
+ || die "econf failed"
+
+ # Parallel build's broken
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+
+ # Install misses this
+ insinto /usr/share/coot/python
+ doins "${S}"/src/coot.py
+}
diff --git a/sci-chemistry/coot/files/digest-coot-0.1.2 b/sci-chemistry/coot/files/digest-coot-0.1.2
new file mode 100644
index 000000000000..7831423bca7a
--- /dev/null
+++ b/sci-chemistry/coot/files/digest-coot-0.1.2
@@ -0,0 +1,3 @@
+MD5 10289f909d6824ef4923a97cfb0e63a4 coot-0.1.2.tar.gz 2704638
+RMD160 bb0ff46297fc7135b1bf31159bf41b18462b916c coot-0.1.2.tar.gz 2704638
+SHA256 fcd2e5862ef57baffc19aa30b1bb48b5271baf0667cc72bf5ecd8a02911fe22a coot-0.1.2.tar.gz 2704638