summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-19 10:20:51 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-19 10:20:51 +0000
commit4858b091044f2c22ab524af7190b1e15d11e7fd5 (patch)
tree5e682b99756a18470c605c29f198569cc495ced4 /sci-chemistry
parenthttp://my.opera.com/desktopteam/blog/2012/07/19/12-50-marlin-html5-dnd-hwa-im... (diff)
downloadgentoo-2-4858b091044f2c22ab524af7190b1e15d11e7fd5.tar.gz
gentoo-2-4858b091044f2c22ab524af7190b1e15d11e7fd5.tar.bz2
gentoo-2-4858b091044f2c22ab524af7190b1e15d11e7fd5.zip
sci-chemistry/apbs: Fix patching problem which lead to an empty pkg-config file, #425294
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/apbs/ChangeLog8
-rw-r--r--sci-chemistry/apbs/apbs-1.3-r3.ebuild160
-rw-r--r--sci-chemistry/apbs/files/apbs-1.3/0016-apbs-1.3-apbs.pc-in-AC_CONFIG_FILES.patch28
3 files changed, 195 insertions, 1 deletions
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
index 92425668ee09..cd2e6fb83fe6 100644
--- a/sci-chemistry/apbs/ChangeLog
+++ b/sci-chemistry/apbs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/apbs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.57 2012/06/16 15:37:21 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.58 2012/07/19 10:20:51 jlec Exp $
+
+*apbs-1.3-r3 (19 Jul 2012)
+
+ 19 Jul 2012; Justin Lecher <jlec@gentoo.org> +apbs-1.3-r3.ebuild,
+ +files/apbs-1.3/0016-apbs-1.3-apbs.pc-in-AC_CONFIG_FILES.patch:
+ Fix patching problem which lead to an empty pkg-config file, #425294
25 Apr 2012; Justin Lecher <jlec@gentoo.org> apbs-1.3-r2.ebuild:
Don't run libtoolize twice
diff --git a/sci-chemistry/apbs/apbs-1.3-r3.ebuild b/sci-chemistry/apbs/apbs-1.3-r3.ebuild
new file mode 100644
index 000000000000..653031fe466e
--- /dev/null
+++ b/sci-chemistry/apbs/apbs-1.3-r3.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3-r3.ebuild,v 1.1 2012/07/19 10:20:51 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2"
+
+inherit autotools-utils eutils fortran-2 python toolchain-funcs versionator
+
+MY_PV=$(get_version_component_range 1-3)
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="For evaluation of electrostatic properties of nanoscale biomolecular systems"
+HOMEPAGE="http://apbs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-source.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="arpack doc examples fetk mpi openmp python static-libs tools"
+REQUIRED_USE="mpi? ( !python )"
+
+DEPEND="
+ dev-libs/maloc[mpi=]
+ virtual/blas
+ sys-libs/readline
+ virtual/fortran
+ arpack? ( sci-libs/arpack )
+ fetk? (
+ sci-libs/fetk
+ sci-libs/amd
+ sci-libs/umfpack
+ sci-libs/superlu )
+ mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/"${MY_P}-source"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+MAKEOPTS+=" -j1"
+
+pkg_setup() {
+ fortran-2_pkg_setup
+ use python && python_set_active_version 2 && python_pkg_setup
+ if [[ -z ${MAXMEM} ]]; then
+ einfo "You can specify the max amount of RAM used"
+ einfo "by setting MAXMEM=\"your size in MB\""
+ else
+ einfo "Settings max memory usage to ${MAXMEM} MB"
+ fi
+}
+
+# git clone ssh://woodpecker/home/jlec/apbs.git
+PATCHES=( "${FILESDIR}"/${P}/00{01..16}* )
+
+src_prepare() {
+ rm -rf contrib/{blas,maloc,opal,zlib} || die
+ find -name "._*" -delete || die
+
+ EPATCH_OPTS="-p1" \
+ autotools-utils_src_prepare
+
+ sed \
+ -e "s:GENTOO_PKG_NAME:${PN}:g" \
+ -i Makefile.am || die "Cannot correct package name"
+ sed \
+ -e 's:libmaloc.a:libmaloc.so:g' \
+ -e 's:-lblas::g' \
+ -i configure.ac || die
+ sed -e 's:opal::g' -i contrib/Makefile.am || die
+ sed \
+ -e 's:noinst_PROGRAMS:bin_PROGRAMS:g' \
+ -i tools/*/Makefile.am || die
+ AT_NOELIBTOOLIZE=yes eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=( --docdir="${EPREFIX}/usr/share/doc/${PF}" )
+ use arpack && myeconfargs+=( --with-arpack="${EPREFIX}/usr/$(get_libdir)" )
+
+ # check which mpi version is installed and tell configure
+ if use mpi; then
+ export CC="${EPREFIX}/usr/bin/mpicc"
+ export F77="${EPREFIX}/usr/bin/mpif77"
+
+ if has_version sys-cluster/mpich; then
+ myeconfargs+=( --with-mpich="${EPREFIX}/usr" )
+ elif has_version sys-cluster/mpich2; then
+ myeconfargs+=( --with-mpich2="${EPREFIX}/usr" )
+ elif has_version sys-cluster/openmpi; then
+ myeconfargs+=( --with-openmpi="${EPREFIX}/usr" )
+ fi
+ fi || die "Failed to select proper mpi implementation"
+
+ if use fetk; then
+ myeconfargs+=( --with-fetk-include="${EPREFIX}/usr/include" --with-fetk-library="${EPREFIX}/usr/$(get_libdir)" )
+ else
+ myeconfargs+=( --disable-fetk )
+ fi
+
+ [[ -n ${MAXMEM} ]] && myeconfargs+=( --with-maxmem=${MAXMEM} )
+
+ if use python; then
+ myeconfargs+=( --enable-tools )
+ else
+ myeconfargs+=( $(use_enable tools) )
+ fi
+
+ myeconfargs+=(
+ --disable-maloc-rebuild
+ --enable-shared
+ $(use_enable openmp)
+ $(use_enable python)
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ export LC_NUMERIC=C
+ cd examples && make test \
+ || die "Tests failed"
+ grep -q 'FAILED' "${S}"/examples/TESTRESULTS.log && die "Tests failed"
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ use doc && dohtml -r doc/*
+ use examples && insinto /usr/share/${PN} && doins -r examples
+ use tools && emake DESTDIR="${D}" install-tools
+
+ if use python && ! use mpi; then
+ insinto $(python_get_sitedir)/${PN}
+ doins tools/manip/*.py
+ doins tools/python/{*.py,*.pqr}
+ doins tools/python/*/{*.py,*.so}
+ python_clean_installation_image
+ fi
+
+ if use python || use tools; then
+ mv "${ED}"/usr/bin/analysis{,_apbs} || die
+ mv "${ED}"/usr/bin/smooth{,_apbs} || die
+ fi
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize ${PN}
+ if use python || use tools; then
+ echo
+ elog "Following apps have been renamed"
+ elog "${EPREFIX}/usr/bin/analysis -> ${EPREFIX}/usr/bin/analysis_apbs"
+ elog "${EPREFIX}/usr/bin/smooth -> ${EPREFIX}/usr/bin/smooth_apbs"
+ echo
+ fi
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup ${PN}
+}
diff --git a/sci-chemistry/apbs/files/apbs-1.3/0016-apbs-1.3-apbs.pc-in-AC_CONFIG_FILES.patch b/sci-chemistry/apbs/files/apbs-1.3/0016-apbs-1.3-apbs.pc-in-AC_CONFIG_FILES.patch
new file mode 100644
index 000000000000..8a5e59d0a838
--- /dev/null
+++ b/sci-chemistry/apbs/files/apbs-1.3/0016-apbs-1.3-apbs.pc-in-AC_CONFIG_FILES.patch
@@ -0,0 +1,28 @@
+From ba195e1ea7e023ab442c4699c9c329bacc646c6a Mon Sep 17 00:00:00 2001
+Message-Id: <ba195e1ea7e023ab442c4699c9c329bacc646c6a.1342692605.git.jlec@gentoo.org>
+In-Reply-To: <89d53654acb88cd8dbd4bc9eb388ca6e76d0d6ea.1342692605.git.jlec@gentoo.org>
+References: <89d53654acb88cd8dbd4bc9eb388ca6e76d0d6ea.1342692605.git.jlec@gentoo.org>
+From: Justin Lecher <jlec@gentoo.org>
+Date: Thu, 19 Jul 2012 12:07:59 +0200
+Subject: [PATCH 16/16] apbs 1.3 apbs.pc in AC_CONFIG_FILES
+
+---
+ configure.ac | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index d39a0a5..6855929 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1269,7 +1269,7 @@ AC_CONFIG_FILES([
+
+ bin/Makefile
+
+- apbs.pc:apbs.pc.in
++ apbs.pc
+
+ ])
+ AC_OUTPUT
+--
+1.7.8.6
+