summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2007-01-05 17:10:53 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2007-01-05 17:10:53 +0000
commit45abd093c05f00af9e0cc889783e170ff6ac0cf7 (patch)
tree9a84929c230841a600fe0fea719e3573f90ab7c4 /sci-chemistry
parenteinfo converted to elog (diff)
downloadgentoo-2-45abd093c05f00af9e0cc889783e170ff6ac0cf7.tar.gz
gentoo-2-45abd093c05f00af9e0cc889783e170ff6ac0cf7.tar.bz2
gentoo-2-45abd093c05f00af9e0cc889783e170ff6ac0cf7.zip
QA: Fix sed delimiters when using paths.
(Portage version: 2.1.2_pre2-r1)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gperiodic/files/digest-gperiodic-2.0.72
-rw-r--r--sci-chemistry/gperiodic/gperiodic-2.0.7.ebuild13
2 files changed, 8 insertions, 7 deletions
diff --git a/sci-chemistry/gperiodic/files/digest-gperiodic-2.0.7 b/sci-chemistry/gperiodic/files/digest-gperiodic-2.0.7
index 9a04e716559a..b767956f4d3b 100644
--- a/sci-chemistry/gperiodic/files/digest-gperiodic-2.0.7
+++ b/sci-chemistry/gperiodic/files/digest-gperiodic-2.0.7
@@ -1 +1,3 @@
MD5 b9e74139d4b468f290297fcfb61a7084 gperiodic-2.0.7.tar.gz 124798
+RMD160 0e2f0dff05005c7c018bd996b1957b841de80fff gperiodic-2.0.7.tar.gz 124798
+SHA256 e7cdb11effa7e3adbf5ac60a16b5092359093ffa93282f25a6855094a0fa250f gperiodic-2.0.7.tar.gz 124798
diff --git a/sci-chemistry/gperiodic/gperiodic-2.0.7.ebuild b/sci-chemistry/gperiodic/gperiodic-2.0.7.ebuild
index ce31a7dc6400..b14177d55c91 100644
--- a/sci-chemistry/gperiodic/gperiodic-2.0.7.ebuild
+++ b/sci-chemistry/gperiodic/gperiodic-2.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gperiodic/gperiodic-2.0.7.ebuild,v 1.3 2005/08/19 11:53:38 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gperiodic/gperiodic-2.0.7.ebuild,v 1.4 2007/01/05 17:10:53 kugelfang Exp $
inherit toolchain-funcs
@@ -20,13 +20,12 @@ DEPEND=">=sys-libs/ncurses-5.2
src_compile() {
# The author has removed "unnecessary automake/autoconf setup"
-# econf `use_enable nls` || die
- # This flag stopped it compiling for me
- sed -i -e "s/-DGTK_DISABLE_DEPRECATED/${CFLAGS}/" Makefile
- sed -i -e "/make clean/d" Makefile
- sed -i -e "s/CC=gcc/CC=$(tc-getCC)/" Makefile
+
+ sed -i -e "s|-DGTK_DISABLE_DEPRECATED|${CFLAGS}|" Makefile
+ sed -i -e "|make clean|d" Makefile
+ sed -i -e "s|CC=gcc|CC=$(tc-getCC)|" Makefile
if ! use nls; then
- sed -i -e "/make -C po/d" Makefile
+ sed -i -e "|make -C po|d" Makefile
fi
emake || die "emake failed!"
}