summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-28 19:28:37 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-28 19:28:37 +0000
commit2535369fd9cfe0b50d68c37f7c355623aa573356 (patch)
tree61182f73167aeb5abefecaf9eeb01cc66c31f1a2 /sci-chemistry
parentadd ~x86, bug 360365 (diff)
downloadgentoo-2-2535369fd9cfe0b50d68c37f7c355623aa573356.tar.gz
gentoo-2-2535369fd9cfe0b50d68c37f7c355623aa573356.tar.bz2
gentoo-2-2535369fd9cfe0b50d68c37f7c355623aa573356.zip
Sane check for swig version, https://sourceforge.net/tracker/?func=detail&aid=3253693&group_id=40728&atid=428740
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/openbabel-perl/ChangeLog8
-rw-r--r--sci-chemistry/openbabel-perl/files/openbabel-perl-2.3.0-swig.patch25
-rw-r--r--sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild8
3 files changed, 37 insertions, 4 deletions
diff --git a/sci-chemistry/openbabel-perl/ChangeLog b/sci-chemistry/openbabel-perl/ChangeLog
index 08d09c143f48..0cb84d0039f7 100644
--- a/sci-chemistry/openbabel-perl/ChangeLog
+++ b/sci-chemistry/openbabel-perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/openbabel-perl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-perl/ChangeLog,v 1.1 2011/03/26 15:52:07 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-perl/ChangeLog,v 1.2 2011/03/28 19:28:37 jlec Exp $
+
+ 28 Mar 2011; Justin Lecher <jlec@gentoo.org> openbabel-perl-2.3.0.ebuild,
+ +files/openbabel-perl-2.3.0-swig.patch:
+ Sane check for swig version,
+ https://sourceforge.net/tracker/?func=detail&aid=3253693&group_id=40728&atid=
+ 428740
*openbabel-perl-2.3.0 (26 Mar 2011)
diff --git a/sci-chemistry/openbabel-perl/files/openbabel-perl-2.3.0-swig.patch b/sci-chemistry/openbabel-perl/files/openbabel-perl-2.3.0-swig.patch
new file mode 100644
index 000000000000..6beacf74880c
--- /dev/null
+++ b/sci-chemistry/openbabel-perl/files/openbabel-perl-2.3.0-swig.patch
@@ -0,0 +1,25 @@
+ scripts/CMakeLists.txt | 6 +-----
+ 1 files changed, 1 insertions(+), 5 deletions(-)
+
+diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
+index bf2527b..16feeb4 100644
+--- a/scripts/CMakeLists.txt
++++ b/scripts/CMakeLists.txt
+@@ -8,16 +8,12 @@ if (RUN_SWIG)
+ # SWIG_EXECUTABLE - the path to the swig executable
+ # SWIG_VERSION - the version number of the swig executable
+
+- find_package(SWIG)
++ find_package(SWIG 2.0.0)
+ if (NOT SWIG_FOUND)
+ message(STATUS "SWIG NOT found")
+ return()
+ endif (NOT SWIG_FOUND)
+ message(STATUS "SWIG version is ${SWIG_VERSION}")
+- if (NOT ${SWIG_VERSION} STREQUAL "2.0.0" AND NOT ${SWIG_VERSION} STREQUAL "2.0.1")
+- message(STATUS "SWIG version 2.0.0 exactly is required")
+- return()
+- endif (NOT ${SWIG_VERSION} STREQUAL "2.0.0" AND NOT ${SWIG_VERSION} STREQUAL "2.0.1")
+ endif (RUN_SWIG)
+
+ ###################
diff --git a/sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild b/sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild
index 41f94e0ea36c..6409379f43bf 100644
--- a/sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild
+++ b/sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild,v 1.1 2011/03/26 15:52:07 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-perl/openbabel-perl-2.3.0.ebuild,v 1.2 2011/03/28 19:28:37 jlec Exp $
EAPI="3"
@@ -19,13 +19,15 @@ RDEPEND="
dev-lang/perl
~sci-chemistry/openbabel-${PV}"
DEPEND="${RDEPEND}
- =dev-lang/swig-2.0.1
+ dev-lang/swig
dev-util/cmake"
S="${WORKDIR}/openbabel-${PV}"
src_prepare() {
- epatch "${FILESDIR}/${P}-makefile.patch"
+ epatch \
+ "${FILESDIR}/${P}-makefile.patch" \
+ "${FILESDIR}"/${P}-swig.patch
}
src_configure() {