summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-08-11 07:27:00 +0000
committerJustin Lecher <jlec@gentoo.org>2014-08-11 07:27:00 +0000
commit185aea7f090c0f62c23bead6d64eba0e28d5bfd9 (patch)
tree5f35c4443f949fd42b10d66cee0d340a0ba90008 /sci-chemistry/pymol
parentsci-chemistry/pymol: Version Bump (diff)
downloadgentoo-2-185aea7f090c0f62c23bead6d64eba0e28d5bfd9.tar.gz
gentoo-2-185aea7f090c0f62c23bead6d64eba0e28d5bfd9.tar.bz2
gentoo-2-185aea7f090c0f62c23bead6d64eba0e28d5bfd9.zip
sci-chemistry/pymol: Version Bump
(Portage version: 2.2.10/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry/pymol')
-rw-r--r--sci-chemistry/pymol/ChangeLog7
-rw-r--r--sci-chemistry/pymol/pymol-1.7.2.0.ebuild100
2 files changed, 106 insertions, 1 deletions
diff --git a/sci-chemistry/pymol/ChangeLog b/sci-chemistry/pymol/ChangeLog
index 392082eeb790..64b435236dad 100644
--- a/sci-chemistry/pymol/ChangeLog
+++ b/sci-chemistry/pymol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/pymol
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.114 2014/07/10 09:29:47 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.115 2014/08/11 07:27:00 jlec Exp $
+
+*pymol-1.7.2.0 (11 Aug 2014)
+
+ 11 Aug 2014; Justin Lecher <jlec@gentoo.org> +pymol-1.7.2.0.ebuild:
+ Version Bump
10 Jul 2014; Chema Alonso <nimiux@gentoo.org> pymol-1.7.0.1.ebuild:
Stable for amd64 wrt bug #507142
diff --git a/sci-chemistry/pymol/pymol-1.7.2.0.ebuild b/sci-chemistry/pymol/pymol-1.7.2.0.ebuild
new file mode 100644
index 000000000000..8ef573dcd0b5
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-1.7.2.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-1.7.2.0.ebuild,v 1.1 2014/08/11 07:27:00 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1 fdo-mime versionator
+
+DESCRIPTION="A Python-extensible molecular graphics system"
+HOMEPAGE="http://www.pymol.org/"
+SRC_URI="
+ http://dev.gentoo.org/~jlec/distfiles/${PN}-1.7.0.0.png.xz
+ http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz
+"
+# mirror://sourceforge/project/${PN}/${PN}/$(get_version_component_range 1-2)/${PN}-v${PV}.tar.bz2
+# git archive -v --prefix=${P}/ master -o ${P}.tar.xz
+
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="apbs web"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pmw[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ media-libs/freetype:2
+ media-libs/glew
+ media-libs/libpng
+ media-video/mpeg-tools
+ sys-libs/zlib
+ media-libs/freeglut
+ apbs? (
+ sci-chemistry/apbs
+ sci-chemistry/pdb2pqr
+ sci-chemistry/pymol-apbs-plugin[${PYTHON_USEDEP}]
+ )
+ web? ( !dev-python/webpy[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${P}/${PN}
+
+python_prepare_all() {
+ sed \
+ -e "s:\"/usr:\"${EPREFIX}/usr:g" \
+ -e "/ext_comp_args/s:=\[.*\]$:= \[\]:g" \
+ -e "/import/s:argparse:argparseX:g" \
+ -i setup.py || die
+
+ rm ./modules/pmg_tk/startup/apbs_tools.py || die
+
+ sed \
+ -e "s:/opt/local:${EPREFIX}/usr:g" \
+ -e '/ext_comp_args/s:\[.*\]:[]:g' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install --pymol-path="${EPREFIX}/usr/share/pymol"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ python_export python2_7 EPYTHON
+
+ # These environment variables should not go in the wrapper script, or else
+ # it will be impossible to use the PyMOL libraries from Python.
+ cat >> "${T}"/20pymol <<- EOF
+ PYMOL_PATH="$(python_get_sitedir)/${PN}"
+ PYMOL_DATA="${EPREFIX}/usr/share/pymol/data"
+ PYMOL_SCRIPTS="${EPREFIX}/usr/share/pymol/scripts"
+ EOF
+
+ doenvd "${T}"/20pymol
+
+ newicon "${WORKDIR}"/${PN}-1.7.0.0.png ${PN}.png
+ make_desktop_entry pymol PyMol ${PN} "Graphics;Education;Science;Chemistry" "MimeType=chemical/x-pdb;"
+
+ if ! use web; then
+ rm -rf "${D}/$(python_get_sitedir)/web" || die
+ fi
+
+ rm -f "${ED}"/usr/share/${PN}/LICENSE || die
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}