summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-22 21:09:25 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-22 21:09:25 +0000
commit03444036bfed0307b486385da806610a24c2f487 (patch)
tree91005ac96cae90ed564b4d8284015b9757e42c56 /sci-chemistry/pymol-plugins-msms
parentRemove old-style virtual/jabber-server and virtual/tftp, bugs 358833 and 359125. (diff)
downloadgentoo-2-03444036bfed0307b486385da806610a24c2f487.tar.gz
gentoo-2-03444036bfed0307b486385da806610a24c2f487.tar.bz2
gentoo-2-03444036bfed0307b486385da806610a24c2f487.zip
Byte-Compile script
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/pymol-plugins-msms')
-rw-r--r--sci-chemistry/pymol-plugins-msms/ChangeLog6
-rw-r--r--sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild11
2 files changed, 15 insertions, 2 deletions
diff --git a/sci-chemistry/pymol-plugins-msms/ChangeLog b/sci-chemistry/pymol-plugins-msms/ChangeLog
index bf553a656b7a..1f8c1a94af08 100644
--- a/sci-chemistry/pymol-plugins-msms/ChangeLog
+++ b/sci-chemistry/pymol-plugins-msms/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/pymol-plugins-msms
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-msms/ChangeLog,v 1.1 2011/03/22 08:33:08 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-msms/ChangeLog,v 1.2 2011/03/22 21:09:25 jlec Exp $
+
+ 22 Mar 2011; Justin Lecher <jlec@gentoo.org>
+ pymol-plugins-msms-100415.ebuild:
+ Byte-Compile script
*pymol-plugins-msms-100415 (22 Mar 2011)
diff --git a/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild b/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild
index cc5c5a579b71..cda68386e9e1 100644
--- a/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild
+++ b/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild,v 1.1 2011/03/22 08:33:08 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415.ebuild,v 1.2 2011/03/22 21:09:25 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit eutils python
@@ -44,3 +45,11 @@ src_install() {
}
python_execute_function -s installation
}
+
+pkg_postinst() {
+ python_mod_optimize pmg_tk/startup/${P}.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup pmg_tk/startup/${P}.py
+}