summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-10 14:50:39 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-10 14:50:39 +0000
commite00668cd19a1553e0b6252224fc85243298711c2 (patch)
tree4629a65e2998cc787c4e9fad5c5ef7bf4bb661e0 /sci-chemistry/pointless
parentRemove old-style virtual/bootloader, bug 359971. (diff)
downloadgentoo-2-e00668cd19a1553e0b6252224fc85243298711c2.tar.gz
gentoo-2-e00668cd19a1553e0b6252224fc85243298711c2.tar.bz2
gentoo-2-e00668cd19a1553e0b6252224fc85243298711c2.zip
Version BUmp
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/pointless')
-rw-r--r--sci-chemistry/pointless/ChangeLog7
-rw-r--r--sci-chemistry/pointless/pointless-1.5.19.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/sci-chemistry/pointless/ChangeLog b/sci-chemistry/pointless/ChangeLog
index 8c15dded4a65..905c30a1e11b 100644
--- a/sci-chemistry/pointless/ChangeLog
+++ b/sci-chemistry/pointless/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/pointless
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pointless/ChangeLog,v 1.15 2011/01/16 12:22:09 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pointless/ChangeLog,v 1.16 2011/04/10 14:50:39 jlec Exp $
+
+*pointless-1.5.19 (10 Apr 2011)
+
+ 10 Apr 2011; Justin Lecher <jlec@gentoo.org> +pointless-1.5.19.ebuild:
+ Version BUmp
16 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org>
pointless-1.5.12.ebuild:
diff --git a/sci-chemistry/pointless/pointless-1.5.19.ebuild b/sci-chemistry/pointless/pointless-1.5.19.ebuild
new file mode 100644
index 000000000000..7e10af1a23a0
--- /dev/null
+++ b/sci-chemistry/pointless/pointless-1.5.19.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pointless/pointless-1.5.19.ebuild,v 1.1 2011/04/10 14:50:39 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit eutils multilib python toolchain-funcs
+
+DESCRIPTION="Scores crystallographic Laue and space groups"
+HOMEPAGE="ftp://ftp.mrc-lmb.cam.ac.uk/pub/pre/pointless.html"
+SRC_URI="ftp://ftp.mrc-lmb.cam.ac.uk/pub/pre/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="ccp4"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ sci-chemistry/ccp4-apps
+ >=sci-libs/ccp4-libs-6.1.3
+ sci-libs/clipper
+ sci-libs/fftw:2.1
+ sci-libs/mmdb
+ >=sci-libs/cctbx-2010.03.29.2334-r3"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.5.1-gcc4.4.patch
+}
+
+src_compile() {
+ emake \
+ -f Makefile.make \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LFLAGS="${LDFLAGS}" \
+ CLIB="${EPREFIX}/usr/$(get_libdir)" \
+ CCTBX_VERSION=2010 \
+ ICCP4=-I"${EPREFIX}/usr/include/ccp4" \
+ ITBX="-I${EPREFIX}/usr/include" \
+ ICLPR="-I${EPREFIX}/$(python_get_sitedir)/" \
+ LTBX="-L${EPREFIX}/usr/$(get_libdir)/cctbx/cctbx_build/lib -lcctbx" \
+ SLIB="-L${EPREFIX}/usr/$(get_libdir) -lgfortran" \
+ || die
+}
+
+src_install() {
+ dobin pointless othercell || die
+}