summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-07 10:07:16 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-07 10:07:16 +0000
commitf38a436c7a14e9ca63aec569402d648ed8e7ab16 (patch)
tree6ef92c139968370faa61edc49feb663cc111c6ef /sci-chemistry/cyana
parentKeyword ~x86 by lazy_bum. (diff)
downloadgentoo-2-f38a436c7a14e9ca63aec569402d648ed8e7ab16.tar.gz
gentoo-2-f38a436c7a14e9ca63aec569402d648ed8e7ab16.tar.bz2
gentoo-2-f38a436c7a14e9ca63aec569402d648ed8e7ab16.zip
New addition for NMR assignment and structure calculation software
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/cyana')
-rw-r--r--sci-chemistry/cyana/ChangeLog15
-rw-r--r--sci-chemistry/cyana/cyana-2.1.ebuild78
-rw-r--r--sci-chemistry/cyana/files/2.1-exec.patch77
-rw-r--r--sci-chemistry/cyana/files/2.1-typo.patch13
-rw-r--r--sci-chemistry/cyana/metadata.xml8
5 files changed, 191 insertions, 0 deletions
diff --git a/sci-chemistry/cyana/ChangeLog b/sci-chemistry/cyana/ChangeLog
new file mode 100644
index 000000000000..ef815124905b
--- /dev/null
+++ b/sci-chemistry/cyana/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for sci-chemistry/cyana
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cyana/ChangeLog,v 1.1 2010/03/07 10:07:09 jlec Exp $
+
+*cyana-2.1 (07 Mar 2010)
+
+ 07 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org> +files/2.1-exec.patch,
+ +files/2.1-typo.patch, +cyana-2.1.ebuild, +metadata.xml:
+ CYANA ((c) by Peter Gu"ntert) is a program for automated structure
+ calculation of biological macromolecules on the basis of conformational
+ constraints from NMR. The combination of automated NOESY cross peak
+ assignment, structure calculation with a fast torsion angle dynamics
+ algorithm, and the ease-of-use of CYANA provide for unprecedented
+ efficiency in NMR protein structure determination.
+
diff --git a/sci-chemistry/cyana/cyana-2.1.ebuild b/sci-chemistry/cyana/cyana-2.1.ebuild
new file mode 100644
index 000000000000..2628b038ba06
--- /dev/null
+++ b/sci-chemistry/cyana/cyana-2.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cyana/cyana-2.1.ebuild,v 1.1 2010/03/07 10:07:09 jlec Exp $
+
+EAPI="3"
+
+inherit eutils fortran toolchain-funcs
+
+# we need libg2c for gfortran # 136988
+FORTRAN="ifc"
+
+DESCRIPTION="Combined assignment and dynamics algorithm for NMR applications"
+HOMEPAGE="http://www.las.jp/english/products/s08_cyana/index.html"
+SRC_URI="${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="as-is"
+IUSE="examples"
+
+RESTRICT="fetch"
+
+pkg_nofetch() {
+ elog "Please visit"
+ elog "http://www.las.jp/english/products/s08_cyana/licenses.html"
+ elog "and get a copy of ${A}."
+ elog "Place it in ${DISTDIR}."
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-typo.patch
+ epatch "${FILESDIR}"/${PV}-exec.patch
+
+ cat >> etc/config <<- EOF
+ VERSION=${PV}
+ SHELL=${EPREFIX}/bin/sh
+ FC=${FORTRANC}
+ FFLAGS=${FFLAGS}
+ FFLAGS2=${FFLAGS}
+ CC=$(tc-getCC)
+ FORK=g77fork.o
+ LDFLAGS=${LDFLAGS}
+ LIBS=-pthread -lpthread -liomp5
+ EOF
+
+ if [[ ${FORTRANC} == gfortran ]]; then
+ cat >> etc/config <<- EOF
+ DEFS=-Dgfortran
+ SYSTEM=gfortran
+ EOF
+ else
+ cat >> etc/config <<- EOF
+ DEFS=-Dintel
+ SYSTEM=intel
+ EOF
+ fi
+}
+
+src_compile() {
+ cd src
+ emake \
+ || die
+}
+
+src_install() {
+ source etc/config
+ dobin cyana{job,table,filter,clean} || die
+ newbin src/${PN}/${PN}exe.${SYSTEM} ${PN} || die
+ insinto /usr/share/${PN}
+ doins -r lib macro help || die
+ use examples && doins -r demo
+
+ cat >> "${T}"/20cyana <<- EOF
+ CYANALIB="${EPREFIX}/usr/share/${PN}"
+ EOF
+
+ doenvd "${T}"/20cyana || die
+}
diff --git a/sci-chemistry/cyana/files/2.1-exec.patch b/sci-chemistry/cyana/files/2.1-exec.patch
new file mode 100644
index 000000000000..28cd88d3eee6
--- /dev/null
+++ b/sci-chemistry/cyana/files/2.1-exec.patch
@@ -0,0 +1,77 @@
+diff --git a/cyana b/cyana
+index 4f746cf..a7ff060 100755
+--- a/cyana
++++ b/cyana
+@@ -45,16 +45,13 @@ shift `expr $optind - 1`
+
+ if [ "$h" ]; then usage=1; fi
+ if [ "$usage" ]; then
+- echo "Usage: $prog -hctx parameters ..."
++ echo "Usage: $prog -hS parameters ..."
+ echo
+ echo " -h help"
+ echo " -c command command to start program (must contain \$exefile)"
+ echo " -S run in safe mode, i.e. within one directory"
+- echo " -t system explicit system type"
+- echo " -x display name of executable without executing it"
+ exit 2
+ fi
+-if [ "$c" ]; then cmd="$c"; fi
+ sys=$t
+ mode=$x
+ safe=$S
+@@ -65,23 +62,6 @@ safe=$S
+ eval ${PROG}ARG='$*'
+ export ${PROG}ARG
+
+-
+-# ------ Set library name ------
+-
+-f=$0
+-if [ `echo $f | sed 's,^/.*,+,'` != "+" ]; then f=`which $0`; fi
+-odir=`pwd`
+-while [ "`ls -l $f | awk '{ print substr($1,1,1) }'`" = "l" ]; do
+- l=`ls -l $f | awk '{ i = NF; print $i }'`
+- cd `dirname $f`; cd `dirname $l`; l=`pwd`/`basename $l`
+- f=$l
+-done
+-cd `dirname $f`
+-libdir=`pwd | sed 's,/src/'${prog}'$,,'`
+-cd $odir
+-eval ${PROG}LIB=$libdir
+-export ${PROG}LIB
+-
+ if [ "$safe" ]; then
+ CYANAINIT=initsafe; export CYANAINIT
+ fi
+@@ -89,29 +69,4 @@ fi
+
+ # ------ Start the program ------
+
+-if [ -d $libdir/src/$prog ]; then
+- exe=$libdir/src/$prog/$exe
+-else
+- exe=$libdir/$exe
+-fi
+-if [ "$sys" = "" ]; then
+- sys=`$libdir/etc/identify`
+- files="$exe.$sys* $exe.gnu $exe.*"
+-else
+- files=$exe.$sys
+-fi
+-for exefile in $files; do
+- if [ -x $exefile ]; then
+- if [ "$mode" ]; then
+- echo $exefile; exit 0
+- else
+- if [ "`echo $cmd | grep -c '\$exefile'`" -gt 0 ]; then
+- eval exec $cmd
+- else
+- eval exec $cmd $exefile
+- fi
+- fi
+- fi
+-done
+-echo "No executable found in \"`dirname $exe`\"."
+-exit 1
++exec cyana
diff --git a/sci-chemistry/cyana/files/2.1-typo.patch b/sci-chemistry/cyana/files/2.1-typo.patch
new file mode 100644
index 000000000000..3f011a9b2c28
--- /dev/null
+++ b/sci-chemistry/cyana/files/2.1-typo.patch
@@ -0,0 +1,13 @@
+diff --git a/src/cyana/putpro.f b/src/cyana/putpro.f
+index d4080f9..4490225 100644
+--- a/src/cyana/putpro.f
++++ b/src/cyana/putpro.f
+@@ -66,7 +66,7 @@ c ------------------------------------------------------ BMRB header
+ * ' _Mol_residue_sequence',
+ * ';'
+ do i=1,nr,20
+- write (iunit,'(20A1))') (rcode(rnam(j)),j=i,min(nr,i+19))
++ write (iunit,'(20A1)') (rcode(rnam(j)),j=i,min(nr,i+19))
+ end do
+
+ write (iunit,'(A)')
diff --git a/sci-chemistry/cyana/metadata.xml b/sci-chemistry/cyana/metadata.xml
new file mode 100644
index 000000000000..c6856dc7f2cf
--- /dev/null
+++ b/sci-chemistry/cyana/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>