summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2009-06-20 01:04:12 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2009-06-20 01:04:12 +0000
commit55371dd0d9c3d78ad9538a91ed17b2f0f0bf35c1 (patch)
treeafb681529ab2e944b33fd8bda8c63037a4f196c3 /sci-chemistry/chemtool
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-55371dd0d9c3d78ad9538a91ed17b2f0f0bf35c1.tar.gz
gentoo-2-55371dd0d9c3d78ad9538a91ed17b2f0f0bf35c1.tar.bz2
gentoo-2-55371dd0d9c3d78ad9538a91ed17b2f0f0bf35c1.zip
Latest version, thanks to lumbrius in bug #274199 and Reinis Danne for the science overlay ebuild.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/chemtool')
-rw-r--r--sci-chemistry/chemtool/ChangeLog10
-rw-r--r--sci-chemistry/chemtool/chemtool-1.6.12.ebuild68
2 files changed, 76 insertions, 2 deletions
diff --git a/sci-chemistry/chemtool/ChangeLog b/sci-chemistry/chemtool/ChangeLog
index 3d8add5d21e5..eea7e37bd702 100644
--- a/sci-chemistry/chemtool/ChangeLog
+++ b/sci-chemistry/chemtool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/chemtool
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/ChangeLog,v 1.24 2008/04/26 13:03:47 markusle Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/ChangeLog,v 1.25 2009/06/20 01:04:12 je_fro Exp $
+
+*chemtool-1.6.12 (20 Jun 2009)
+
+ 20 Jun 2009; Jeff Gardner <je_fro@gentoo.org> +chemtool-1.6.12.ebuild:
+ Latest version, thanks to lumbrius in bug #274199 and Reinis Danne for the
+ science overlay ebuild.
*chemtool-1.6.11 (26 Apr 2008)
diff --git a/sci-chemistry/chemtool/chemtool-1.6.12.ebuild b/sci-chemistry/chemtool/chemtool-1.6.12.ebuild
new file mode 100644
index 000000000000..f52edf3746b5
--- /dev/null
+++ b/sci-chemistry/chemtool/chemtool-1.6.12.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/chemtool-1.6.12.ebuild,v 1.1 2009/06/20 01:04:12 je_fro Exp $
+
+inherit eutils kde-functions
+
+DESCRIPTION="A GTK program for drawing organic molecules"
+HOMEPAGE="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/"
+SRC_URI="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="gnome kde nls"
+
+RDEPEND="media-gfx/transfig
+ =x11-libs/gtk+-2*
+ kde? ( =kde-base/kdelibs-3.5* )
+ x86? ( media-libs/libemf )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+}
+
+src_compile() {
+ local config_opts
+ local mycppflags
+ if ! use kde; then
+ unset KDEDIR
+ config_opts="${config_opts} --without-kdedir"
+ else
+ set-kdedir
+ config_opts="${config_opts} --with-kdedir=${KDEDIR}"
+ fi
+ if [ ${ARCH} = "x86" ]; then
+ config_opts="${config_opts} --enable-emf"
+ mycppflags="${mycppflags} -I /usr/include/libEMF"
+ fi
+
+ sed -e "s:\(^CPPFLAGS.*\):\1 ${mycppflags}:" -i Makefile.in || \
+ die "could not append cppflags"
+
+ if use gnome ; then
+ config_opts="${config_opts} --with-gnomedir=/usr" ;
+ else
+ config_opts="${config_opts} --without-gnomedir" ;
+ fi
+
+ econf ${config_opts} --enable-menu \
+ || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog INSTALL README TODO
+ insinto /usr/share/${PN}/examples
+ doins "${S}"/examples/*
+ if ! use nls; then rm -rf "${D}"/usr/share/locale; fi
+
+ insinto /usr/share/pixmaps
+ doins chemtool.xpm
+ make_desktop_entry ${PN} Chemtool ${PN} "Education;Science;Chemistry"
+}