summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-29 16:18:27 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-29 16:18:27 +0000
commitef09030eea6cd06a6ec6a40302c984a21dbba3b8 (patch)
tree974b381417d1ad81f543714b7d22941cdbaf5512 /sci-chemistry/ccpn
parentsci-chemistry/ball: Fix usage of new python r1 eclasses (missing PYTHON_REQUI... (diff)
downloadgentoo-2-ef09030eea6cd06a6ec6a40302c984a21dbba3b8.tar.gz
gentoo-2-ef09030eea6cd06a6ec6a40302c984a21dbba3b8.tar.bz2
gentoo-2-ef09030eea6cd06a6ec6a40302c984a21dbba3b8.zip
sci-chemistry/ccpn: Fix usage of new python r1 eclasses (missing PYTHON_REQUIRED_USE)
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-chemistry/ccpn')
-rw-r--r--sci-chemistry/ccpn/ChangeLog6
-rw-r--r--sci-chemistry/ccpn/ccpn-2.2.2_p130318-r1.ebuild7
-rw-r--r--sci-chemistry/ccpn/ccpn-2.2.2_p130318.ebuild9
3 files changed, 16 insertions, 6 deletions
diff --git a/sci-chemistry/ccpn/ChangeLog b/sci-chemistry/ccpn/ChangeLog
index c72be6ffee5d..9fced7ce09f7 100644
--- a/sci-chemistry/ccpn/ChangeLog
+++ b/sci-chemistry/ccpn/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/ccpn
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ChangeLog,v 1.105 2013/03/22 10:38:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ChangeLog,v 1.106 2013/05/29 16:18:27 jlec Exp $
+
+ 29 May 2013; Justin Lecher <jlec@gentoo.org> ccpn-2.2.2_p130318.ebuild,
+ ccpn-2.2.2_p130318-r1.ebuild:
+ Fix usage of new python r1 eclasses (missing PYTHON_REQUIRED_USE)
22 Mar 2013; Justin Lecher <jlec@gentoo.org> ccpn-2.2.2_p130318-r1.ebuild:
Cut prefix not suffix
diff --git a/sci-chemistry/ccpn/ccpn-2.2.2_p130318-r1.ebuild b/sci-chemistry/ccpn/ccpn-2.2.2_p130318-r1.ebuild
index 2cf85c858024..23a068d5cb54 100644
--- a/sci-chemistry/ccpn/ccpn-2.2.2_p130318-r1.ebuild
+++ b/sci-chemistry/ccpn/ccpn-2.2.2_p130318-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.2.2_p130318-r1.ebuild,v 1.2 2013/03/22 10:38:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.2.2_p130318-r1.ebuild,v 1.3 2013/05/29 16:18:27 jlec Exp $
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
-PYTHON_REQ_USE="ssl tk"
+PYTHON_REQ_USE="ssl,tk"
inherit eutils multilib portability python-single-r1 toolchain-funcs versionator
@@ -25,7 +25,10 @@ LICENSE="|| ( CCPN LGPL-2.1 )"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="+opengl"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
RDEPEND="
+ ${PYTHON_DEPS}
dev-lang/tk[threads]
dev-python/numpy[${PYTHON_USEDEP}]
dev-tcltk/tix
diff --git a/sci-chemistry/ccpn/ccpn-2.2.2_p130318.ebuild b/sci-chemistry/ccpn/ccpn-2.2.2_p130318.ebuild
index 9d5ba37dfa11..a57c297efe6c 100644
--- a/sci-chemistry/ccpn/ccpn-2.2.2_p130318.ebuild
+++ b/sci-chemistry/ccpn/ccpn-2.2.2_p130318.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.2.2_p130318.ebuild,v 1.1 2013/03/18 12:36:30 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.2.2_p130318.ebuild,v 1.2 2013/05/29 16:18:27 jlec Exp $
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
-PYTHON_REQ_USE="ssl tk"
+PYTHON_REQ_USE="ssl,tk"
inherit eutils multilib portability python-single-r1 toolchain-funcs versionator
@@ -25,11 +25,14 @@ LICENSE="|| ( CCPN LGPL-2.1 )"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="+opengl"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
RDEPEND="
+ ${PYTHON_DEPS}
dev-lang/tk[threads]
dev-python/numpy[${PYTHON_USEDEP}]
dev-tcltk/tix
- =sci-libs/ccpn-data-"${MY_MAJOR}"*
+ =sci-libs/ccpn-data-"${MY_MAJOR}"*[${PYTHON_USEDEP}]
sci-biology/psipred
x11-libs/libXext
x11-libs/libX11