summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-06 00:24:33 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-06 00:24:33 +0000
commiteea9986c85fbc8d3664e845174f2408c1bba4649 (patch)
treeff1d6b1159c229bf086d0a47ead7679ac640925a /sci-chemistry/ccp4i
parentsci-chemistry/removed from package.mask, because all QA issues are fixed (diff)
downloadgentoo-2-eea9986c85fbc8d3664e845174f2408c1bba4649.tar.gz
gentoo-2-eea9986c85fbc8d3664e845174f2408c1bba4649.tar.bz2
gentoo-2-eea9986c85fbc8d3664e845174f2408c1bba4649.zip
Splitted interface from ccp4
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/ccp4i')
-rw-r--r--sci-chemistry/ccp4i/ChangeLog12
-rw-r--r--sci-chemistry/ccp4i/ccp4i-6.1.3.ebuild80
-rw-r--r--sci-chemistry/ccp4i/files/6.1.3-fix-baubles.patch22
-rw-r--r--sci-chemistry/ccp4i/files/6.1.3-rename-rapper.patch12
-rw-r--r--sci-chemistry/ccp4i/files/6.1.3-rename-superpose.patch12
-rw-r--r--sci-chemistry/ccp4i/files/6.1.3-rename-truncate.patch22
-rw-r--r--sci-chemistry/ccp4i/metadata.xml5
7 files changed, 165 insertions, 0 deletions
diff --git a/sci-chemistry/ccp4i/ChangeLog b/sci-chemistry/ccp4i/ChangeLog
new file mode 100644
index 000000000000..698351279345
--- /dev/null
+++ b/sci-chemistry/ccp4i/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for sci-chemistry/ccp4i
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4i/ChangeLog,v 1.1 2010/02/06 00:24:33 jlec Exp $
+
+*ccp4i-6.1.3 (06 Feb 2010)
+
+ 06 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +files/6.1.3-fix-baubles.patch, +files/6.1.3-rename-rapper.patch,
+ +files/6.1.3-rename-superpose.patch, +files/6.1.3-rename-truncate.patch,
+ +ccp4i-6.1.3.ebuild, +metadata.xml:
+ Interface splitted from ccp4
+
diff --git a/sci-chemistry/ccp4i/ccp4i-6.1.3.ebuild b/sci-chemistry/ccp4i/ccp4i-6.1.3.ebuild
new file mode 100644
index 000000000000..f01df13f6e02
--- /dev/null
+++ b/sci-chemistry/ccp4i/ccp4i-6.1.3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4i/ccp4i-6.1.3.ebuild,v 1.1 2010/02/06 00:24:33 jlec Exp $
+
+EAPI="2"
+
+inherit base multilib
+
+MY_PN="${PN%i}"
+MY_P="${MY_PN}-${PV}"
+
+#UPDATE="04_03_09"
+#PATCHDATE="090511"
+
+SRC="ftp://ftp.ccp4.ac.uk/ccp4"
+
+DESCRIPTION="Protein X-ray crystallography toolkit -- graphical interface"
+HOMEPAGE="http://www.ccp4.ac.uk/"
+SRC_URI="
+ ${SRC}/${PV}/${MY_P}-core-src.tar.gz
+ http://dev.gentooexperimental.org/~jlec/distfiles/${PV}-oasis4.0.patch.bz2"
+[[ -n ${UPDATE} ]] && SRC_URI="${SRC_URI} ${SRC}/${PV}/updates/${P}-src-patch-${UPDATE}.tar.gz"
+[[ -n ${PATCHDATE} ]] && SRC_URI="${SRC_URI} http://dev.gentooexperimental.org/~jlec/science-dist/${PV}-${PATCHDATE}-updates.patch.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="ccp4"
+IUSE=""
+
+RDEPEND="
+ app-shells/tcsh
+ media-gfx/graphviz
+ >=dev-lang/tk-8.3
+ >=dev-tcltk/blt-2.4"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-rename-truncate.patch
+ "${FILESDIR}"/${PV}-rename-rapper.patch
+ "${FILESDIR}"/${PV}-rename-superpose.patch
+ "${FILESDIR}"/${PV}-fix-baubles.patch
+ )
+
+src_prepare() {
+ base_src_prepare
+
+ [[ ! -z ${PATCHDATE} ]] && epatch "${WORKDIR}"/${PV}-${PATCHDATE}-updates.patch
+
+ epatch "${WORKDIR}"/${PV}-oasis4.0.patch
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ # rm imosflm stuff
+ rm -rf "${S}"/ccp4i/{bin/imosflm,imosflm}
+
+ rm -rf "${S}"/ccp4i/{bin,etc}/WINDOWS
+
+ # This is installed by mrbump
+ rm -rf "${S}"/ccp4i/{tasks/{dbviewer.tcl,mrbump.*},templates/mrbump.com,scripts/mrbump.script}
+
+ # CCP4Interface - GUI
+ insinto /usr/$(get_libdir)/ccp4
+ doins -r "${S}"/ccp4i || die
+ exeinto /usr/$(get_libdir)/ccp4/ccp4i/bin
+ doexe "${S}"/ccp4i/bin/* || die
+
+ # dbccp4i
+ insinto /usr/share/ccp4
+ doins -r "${S}"/share/dbccp4i || die
+}
diff --git a/sci-chemistry/ccp4i/files/6.1.3-fix-baubles.patch b/sci-chemistry/ccp4i/files/6.1.3-fix-baubles.patch
new file mode 100644
index 000000000000..2c5f659b8018
--- /dev/null
+++ b/sci-chemistry/ccp4i/files/6.1.3-fix-baubles.patch
@@ -0,0 +1,22 @@
+--- ccp4i/etc/configure.def.dist 2009-01-09 16:45:08.000000000 +0100
++++ ccp4i/etc/configure.def.dist.new 2009-07-07 23:17:26.000000000 +0200
+@@ -53,8 +53,8 @@
+ RUN_IMOSFLM _text "ccp4iwish [file join [GetEnvPath CCP4I_TOP] imosflm imosflm.tcl] project [GetCurrentProjectDir [GetCurrentProject]]"
+ RUN_CCP4MG _text "ccp4mg"
+ RUN_COOT _text "coot"
+-RUN_BAUBLES _text "python [file join [GetEnvPath CCP4] share smartie baubles.py]"
+-RUN_DBVIEWER _text "wish [file join [GetEnvPath CCP4] share dbccp4i application viewer.tcl]"
++RUN_BAUBLES _text "python [file join [GetEnvPath CCP4] share ccp4 smartie baubles.py]"
++RUN_DBVIEWER _text "wish [file join [GetEnvPath DBCCP4I_TOP] application viewer.tcl]"
+ ENABLE_BUBBLE_HELP _logical 1
+ DISABLE_TASKS _logical 1
+ CCP4_SETUP_COMMAND _text setup_ccp4
+@@ -62,7 +62,7 @@
+ BLT_LIBRARY _text ""
+ MENU_LENGTH _positiveint 25
+ HYPERTEXT_VIEWER _text firefox
+-START_NETSCAPE _text netscape
++START_NETSCAPE _text firefox
+ O_MAPMAN _text mapman
+ MAPMAN_MAXSIZE _positiveint 4194304
+ QUANTA_MBKALL _text mbkall
diff --git a/sci-chemistry/ccp4i/files/6.1.3-rename-rapper.patch b/sci-chemistry/ccp4i/files/6.1.3-rename-rapper.patch
new file mode 100644
index 000000000000..a50ae6dbd648
--- /dev/null
+++ b/sci-chemistry/ccp4i/files/6.1.3-rename-rapper.patch
@@ -0,0 +1,12 @@
+--- ccp4i/scripts/rapper.script 2009-02-03 11:49:50.000000000 +0100
++++ ccp4i/scripts/rapper.script.new 2009-03-12 23:34:47.000000000 +0100
+@@ -17,7 +17,7 @@
+
+ #set up command line
+
+-set cmd "[BinPath rapper]"
++set cmd "[BinPath rappermc]"
+
+ set rapperdatadir [FileJoin [GetEnvPath CCP4] share rapper]
+ set paramsfile [FileJoin [GetEnvPath CCP4] share rapper params.xml]
+
diff --git a/sci-chemistry/ccp4i/files/6.1.3-rename-superpose.patch b/sci-chemistry/ccp4i/files/6.1.3-rename-superpose.patch
new file mode 100644
index 000000000000..90480eb8e381
--- /dev/null
+++ b/sci-chemistry/ccp4i/files/6.1.3-rename-superpose.patch
@@ -0,0 +1,12 @@
+diff -arNu ccp4-6.1.1/ccp4i/scripts/superpose.script ccp4-6.1.1.new/ccp4i/scripts/superpose.script
+--- ccp4-6.1.1/ccp4i/scripts/superpose.script 2006-07-26 16:22:49.000000000 +0200
++++ ccp4-6.1.1.new/ccp4i/scripts/superpose.script 2009-07-05 22:11:59.000000000 +0200
+@@ -21,7 +21,7 @@
+
+ if { [regexp SSM $SUPERPOSE_MODE ] } {
+
+- set cmd "[BinPath superpose] \"$XYZIN2\" -s $SSM_MOVING \"$XYZIN1\" -s $SSM_FIXED \"$XYZOUT_LOCAL\""
++ set cmd "[BinPath superpose-ccp4] \"$XYZIN2\" -s $SSM_MOVING \"$XYZIN1\" -s $SSM_FIXED \"$XYZOUT_LOCAL\""
+ set status [Execute $cmd "" program_status report ]
+
+ } elseif { [regexp TOP $SUPERPOSE_MODE ] } {
diff --git a/sci-chemistry/ccp4i/files/6.1.3-rename-truncate.patch b/sci-chemistry/ccp4i/files/6.1.3-rename-truncate.patch
new file mode 100644
index 000000000000..26f1cda3e381
--- /dev/null
+++ b/sci-chemistry/ccp4i/files/6.1.3-rename-truncate.patch
@@ -0,0 +1,22 @@
+--- ./ccp4i/templates/truncate.com.orig 2009-03-02 23:31:04.000000000 -0800
++++ ./ccp4i/templates/truncate.com 2009-03-02 23:31:08.000000000 -0800
+@@ -11,7 +11,7 @@
+ $SYMMETRY symmetry $SPACE_GROUP
+ $CELL cell $CELL_1 $CELL_2 $CELL_3 $CELL_4 $CELL_5 $CELL_6
+
+-1 truncate
++1 ftruncate
+ - { [StringSame $APPLY_TRUNCATE "WILSON" ] } YES | NO
+ {[IfSet $ANOMALOUS]} anomalous
+ - $ANOMALOUS YES | NO
+--- ./ccp4i/scripts/truncate.script.orig 2009-03-02 23:39:04.000000000 -0800
++++ ./ccp4i/scripts/truncate.script 2009-03-02 23:39:41.000000000 -0800
+@@ -45,7 +45,7 @@
+
+ CreateComScript truncate truncate_script
+
+- set cmd "[BinPath truncate] HKLIN \"$HKLIN\""
++ set cmd "[BinPath ftruncate] HKLIN \"$HKLIN\""
+ if { ![StringSame $INPUT_DATA AMPLITUDES] } {
+ append cmd " HKLOUT \"$HKL_TRUNCATE\""
+ }
diff --git a/sci-chemistry/ccp4i/metadata.xml b/sci-chemistry/ccp4i/metadata.xml
new file mode 100644
index 000000000000..9ac9ffdb3a41
--- /dev/null
+++ b/sci-chemistry/ccp4i/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+</pkgmetadata>