summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-16 07:25:03 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-16 07:25:03 +0000
commit02464b44f94dbce5ddb1b9393aba67b1cd18903e (patch)
treecf2ec182188395302b071a5dceb8017be29826e5 /sci-chemistry/ccp4i
parentMasked sci-chemistry/ccp4i-6.1.3-r3 for bug 314053 (diff)
downloadgentoo-2-02464b44f94dbce5ddb1b9393aba67b1cd18903e.tar.gz
gentoo-2-02464b44f94dbce5ddb1b9393aba67b1cd18903e.tar.bz2
gentoo-2-02464b44f94dbce5ddb1b9393aba67b1cd18903e.zip
Attempts tp fix bug 314053
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/ccp4i')
-rw-r--r--sci-chemistry/ccp4i/ChangeLog7
-rw-r--r--sci-chemistry/ccp4i/ccp4i-6.1.3-r3.ebuild85
2 files changed, 91 insertions, 1 deletions
diff --git a/sci-chemistry/ccp4i/ChangeLog b/sci-chemistry/ccp4i/ChangeLog
index 4451beec803f..a59ffc23513b 100644
--- a/sci-chemistry/ccp4i/ChangeLog
+++ b/sci-chemistry/ccp4i/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/ccp4i
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4i/ChangeLog,v 1.4 2010/04/25 12:32:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4i/ChangeLog,v 1.5 2010/06/16 07:25:03 jlec Exp $
+
+*ccp4i-6.1.3-r3 (16 Jun 2010)
+
+ 16 Jun 2010; Justin Lecher <jlec@gentoo.org> +ccp4i-6.1.3-r3.ebuild:
+ Attempts tp fix bug 314053
*ccp4i-6.1.3-r2 (25 Apr 2010)
diff --git a/sci-chemistry/ccp4i/ccp4i-6.1.3-r3.ebuild b/sci-chemistry/ccp4i/ccp4i-6.1.3-r3.ebuild
new file mode 100644
index 000000000000..63c2309f18ee
--- /dev/null
+++ b/sci-chemistry/ccp4i/ccp4i-6.1.3-r3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4i/ccp4i-6.1.3-r3.ebuild,v 1.1 2010/06/16 07:25:03 jlec Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit base multilib python
+
+MY_PN="${PN%i}"
+MY_P="${MY_PN}-${PV}"
+
+#UPDATE="04_03_09"
+#PATCHDATE="090511"
+
+SRC="ftp://ftp.ccp4.ac.uk/ccp4"
+
+DESCRIPTION="Protein X-ray crystallography toolkit -- graphical interface"
+HOMEPAGE="http://www.ccp4.ac.uk/"
+SRC_URI="
+ ${SRC}/${PV}/${MY_P}-core-src.tar.gz
+ mirror://gentoo/${P}-arpwarp.patch.bz2
+ http://dev.gentooexperimental.org/~jlec/distfiles/${PV}-oasis4.0.patch.bz2"
+[[ -n ${UPDATE} ]] && SRC_URI="${SRC_URI} ${SRC}/${PV}/updates/${P}-src-patch-${UPDATE}.tar.gz"
+[[ -n ${PATCHDATE} ]] && SRC_URI="${SRC_URI} http://dev.gentooexperimental.org/~jlec/science-dist/${PV}-${PATCHDATE}-updates.patch.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="ccp4"
+IUSE=""
+
+RDEPEND="
+ app-shells/tcsh
+ media-gfx/graphviz
+ >=dev-lang/tk-8.3
+ >=dev-tcltk/blt-2.4"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-fix-baubles.patch
+ "${WORKDIR}"/${P}-arpwarp.patch
+ )
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ base_src_prepare
+
+ [[ ! -z ${PATCHDATE} ]] && epatch "${WORKDIR}"/${PV}-${PATCHDATE}-updates.patch
+
+ epatch "${WORKDIR}"/${PV}-oasis4.0.patch
+ python_convert_shebangs -r $(python_get_version) ccp4i/ share/dbccp4i/
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ # rm imosflm stuff
+ rm -rf "${S}"/ccp4i/{bin/imosflm,imosflm}
+
+ rm -rf "${S}"/ccp4i/{bin,etc}/WINDOWS
+
+ # This is installed by mrbump
+ rm -rf "${S}"/ccp4i/{tasks/{dbviewer.tcl,mrbump.*},templates/mrbump.com,scripts/mrbump.script}
+
+ # CCP4Interface - GUI
+ insinto /usr/$(get_libdir)/ccp4
+ doins -r "${S}"/ccp4i || die
+ exeinto /usr/$(get_libdir)/ccp4/ccp4i/bin
+ doexe "${S}"/ccp4i/bin/* || die
+
+ # dbccp4i
+ insinto /usr/share/ccp4
+ doins -r "${S}"/share/dbccp4i || die
+}