summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-09-04 03:04:43 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-09-04 03:04:43 +0000
commit9fa39c998e5d1e414036147b06180f4b8506f7c6 (patch)
tree0725d331bcfb126c500d7b1f80d9d6e72344fc97 /sci-biology
parentclean up for non-existant packages (diff)
downloadgentoo-2-9fa39c998e5d1e414036147b06180f4b8506f7c6.tar.gz
gentoo-2-9fa39c998e5d1e414036147b06180f4b8506f7c6.tar.bz2
gentoo-2-9fa39c998e5d1e414036147b06180f4b8506f7c6.zip
New package, ebuild written by me
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/raxml/ChangeLog10
-rw-r--r--sci-biology/raxml/metadata.xml9
-rw-r--r--sci-biology/raxml/raxml-7.0.4.ebuild39
3 files changed, 58 insertions, 0 deletions
diff --git a/sci-biology/raxml/ChangeLog b/sci-biology/raxml/ChangeLog
new file mode 100644
index 000000000000..8aada1fdc747
--- /dev/null
+++ b/sci-biology/raxml/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-biology/raxml
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/raxml/ChangeLog,v 1.1 2009/09/04 03:04:43 weaver Exp $
+
+*raxml-7.0.4 (03 Sep 2009)
+
+ 03 Sep 2009; Andrey Kislyuk <weaver@gentoo.org> +metadata.xml,
+ +raxml-7.0.4.ebuild:
+ New package, ebuild written by me
+
diff --git a/sci-biology/raxml/metadata.xml b/sci-biology/raxml/metadata.xml
new file mode 100644
index 000000000000..3302123e5718
--- /dev/null
+++ b/sci-biology/raxml/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>weaver@gentoo.org</email>
+ <name>Andrey Kislyuk</name>
+ </maintainer>
+ <herd>sci-biology</herd>
+</pkgmetadata>
diff --git a/sci-biology/raxml/raxml-7.0.4.ebuild b/sci-biology/raxml/raxml-7.0.4.ebuild
new file mode 100644
index 000000000000..54780b8e9a4f
--- /dev/null
+++ b/sci-biology/raxml/raxml-7.0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/raxml/raxml-7.0.4.ebuild,v 1.1 2009/09/04 03:04:43 weaver Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A Program for Sequential, Parallel & Distributed Inference of Large Phylogenetic Trees"
+HOMEPAGE="http://icwww.epfl.ch/~stamatak/index-Dateien/Page443.htm"
+SRC_URI="http://icwww.epfl.ch/~stamatak/index-Dateien/software/RAxML-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+mpi +threads"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/RAxML-${PV}"
+
+src_prepare() {
+ sed -i -e 's/CFLAGS =/CFLAGS := ${CFLAGS}/' \
+ -e 's/CC = gcc/CC = '$(tc-getCC)'/' \
+ Makefile.* || die
+}
+
+src_compile() {
+ emake -f Makefile.gcc || die
+ if use mpi; then emake -f Makefile.MPI clean && emake -f Makefile.MPI || die; fi
+ if use threads; then emake -f Makefile.PTHREADS clean && emake -f Makefile.PTHREADS || die; fi
+}
+
+src_install() {
+ dobin raxmlHPC || die
+ if use mpi; then dobin raxmlHPC-MPI || die; fi
+ if use threads; then dobin raxmlHPC-PTHREADS || die; fi
+}