summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-26 16:06:44 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-26 16:06:44 +0000
commit3ac54f584dcfe0010f83b8a63cc0a39fe725bc99 (patch)
treea9b544f19b3d59a90b0f8692b5b0a65d86330848 /sci-biology
parentsci-calculators/calcoo: Move to EAPI=4, added fix gold linker (diff)
downloadgentoo-2-3ac54f584dcfe0010f83b8a63cc0a39fe725bc99.tar.gz
gentoo-2-3ac54f584dcfe0010f83b8a63cc0a39fe725bc99.tar.bz2
gentoo-2-3ac54f584dcfe0010f83b8a63cc0a39fe725bc99.zip
sci-biology/tree-puzzle: Move to EAPI=4
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/tree-puzzle/ChangeLog7
-rw-r--r--sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild26
2 files changed, 19 insertions, 14 deletions
diff --git a/sci-biology/tree-puzzle/ChangeLog b/sci-biology/tree-puzzle/ChangeLog
index 5c6d5f08c2b5..dec1c08c776c 100644
--- a/sci-biology/tree-puzzle/ChangeLog
+++ b/sci-biology/tree-puzzle/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-biology/tree-puzzle
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/tree-puzzle/ChangeLog,v 1.15 2010/01/01 21:44:45 fauli Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tree-puzzle/ChangeLog,v 1.16 2012/04/26 16:06:44 jlec Exp $
+
+ 26 Apr 2012; Justin Lecher <jlec@gentoo.org> tree-puzzle-5.2.ebuild:
+ Move to EAPI=4
01 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
tree-puzzle-5.2.ebuild:
diff --git a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
index 5c22237acc30..1d5a2b540bb5 100644
--- a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
+++ b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
@@ -1,19 +1,22 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild,v 1.10 2010/01/01 21:44:45 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild,v 1.11 2012/04/26 16:06:44 jlec Exp $
+
+EAPI=4
inherit toolchain-funcs
-DESCRIPTION="Maximum likelihood analysis for nucleotide, amino acid, and two-state data."
+DESCRIPTION="Maximum likelihood analysis for nucleotide, amino acid, and two-state data"
HOMEPAGE="http://www.tree-puzzle.de"
SRC_URI="http://www.tree-puzzle.de/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="mpi"
DEPEND="mpi? ( sys-cluster/lam-mpi )"
+RDEPEND="${DEPEND}"
pkg_setup () {
use mpi && [ $(tc-getCC) = icc ] && die "The parallelized version of tree-puzzle cannot be compiled using icc.
@@ -21,16 +24,15 @@ pkg_setup () {
version of the program, or use gcc as your compiler (CC=\"gcc\")."
}
-src_compile() {
- econf || die
- cd ${S}/src
+src_prepare() {
if ! use mpi; then
- sed -e 's:bin_PROGRAMS = puzzle$(EXEEXT) ppuzzle:bin_PROGRAMS = puzzle :' \
- -e 's:DIST_SOURCES = $(ppuzzle_SOURCES) $(puzzle_SOURCES):DIST_SOURCES = $(puzzle_SOURCES):' \
- -i Makefile || die
+ cd ${S}/src
+ sed \
+ -e 's:bin_PROGRAMS = puzzle$(EXEEXT) ppuzzle:bin_PROGRAMS = puzzle :' \
+ -e 's:DIST_SOURCES = $(ppuzzle_SOURCES) $(puzzle_SOURCES):DIST_SOURCES = $(puzzle_SOURCES):' \
+ -i Makefile || die
+ cd ${S}
fi
- cd ${S}
- emake || die
}
src_install() {