summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-28 17:30:41 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-28 17:30:41 +0000
commit192d863b02ce6e337e24220267bc09ff4ac786eb (patch)
tree23a53cb583b536b748db9ed9630d364d1714cc1b /sci-biology
parentCall correct install function (diff)
downloadgentoo-2-192d863b02ce6e337e24220267bc09ff4ac786eb.tar.gz
gentoo-2-192d863b02ce6e337e24220267bc09ff4ac786eb.tar.bz2
gentoo-2-192d863b02ce6e337e24220267bc09ff4ac786eb.zip
Call correct install function
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/embassy-domalign/ChangeLog11
-rw-r--r--sci-biology/embassy-domalign/embassy-domalign-0.1.650.ebuild13
-rw-r--r--sci-biology/embassy-domalign/files/embassy-domalign-0.1.650_fix-build-system.patch92
-rw-r--r--sci-biology/embassy-domalign/metadata.xml2
4 files changed, 114 insertions, 4 deletions
diff --git a/sci-biology/embassy-domalign/ChangeLog b/sci-biology/embassy-domalign/ChangeLog
index fd9e26234760..cf25c5266a7c 100644
--- a/sci-biology/embassy-domalign/ChangeLog
+++ b/sci-biology/embassy-domalign/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/embassy-domalign
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/embassy-domalign/ChangeLog,v 1.23 2011/10/20 08:57:30 xarthisius Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/embassy-domalign/ChangeLog,v 1.24 2015/03/28 17:30:41 jlec Exp $
+
+*embassy-domalign-0.1.650 (28 Mar 2015)
+
+ 28 Mar 2015; Justin Lecher <jlec@gentoo.org> +embassy-domalign-0.1.650.ebuild,
+ +files/embassy-domalign-0.1.650_fix-build-system.patch, metadata.xml:
+ Call correct install function
20 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org>
embassy-domalign-0.1.0-r4.ebuild, embassy-domalign-0.1.0-r3.ebuild:
@@ -100,4 +106,3 @@
07 Aug 2005; Olivier Fisette <ribosome@gentoo.org> +metadata.xml,
+embassy-domalign-0.1.0.ebuild:
Initial import. Part of EMBASSY 3.0.0.
-
diff --git a/sci-biology/embassy-domalign/embassy-domalign-0.1.650.ebuild b/sci-biology/embassy-domalign/embassy-domalign-0.1.650.ebuild
new file mode 100644
index 000000000000..8152116b0539
--- /dev/null
+++ b/sci-biology/embassy-domalign/embassy-domalign-0.1.650.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/embassy-domalign/embassy-domalign-0.1.650.ebuild,v 1.1 2015/03/28 17:30:41 jlec Exp $
+
+EAPI=5
+
+EBO_DESCRIPTION="Protein domain alignment add-on package"
+
+PATCHES=( "${FILESDIR}"/${P}_fix-build-system.patch )
+AUTOTOOLS_AUTORECONF=1
+inherit emboss-r1
+
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-linux ~ppc-macos"
diff --git a/sci-biology/embassy-domalign/files/embassy-domalign-0.1.650_fix-build-system.patch b/sci-biology/embassy-domalign/files/embassy-domalign-0.1.650_fix-build-system.patch
new file mode 100644
index 000000000000..d87bae393f61
--- /dev/null
+++ b/sci-biology/embassy-domalign/files/embassy-domalign-0.1.650_fix-build-system.patch
@@ -0,0 +1,92 @@
+--- DOMALIGN-0.1.650/configure.ac
++++ DOMALIGN-0.1.650/configure.ac
+@@ -635,33 +635,6 @@
+
+
+
+-dnl PCRE library definitions - see the MAJOR and MINOR values
+-dnl to see which version's configure.in these lines come from
+-
+-dnl Provide the current PCRE version information. Do not use numbers
+-dnl with leading zeros for the minor version, as they end up in a C
+-dnl macro, and may be treated as octal constants. Stick to single
+-dnl digits for minor numbers less than 10. There are unlikely to be
+-dnl that many releases anyway.
+-
+-PCRE_MAJOR="7"
+-PCRE_MINOR="9"
+-PCRE_DATE="11-Apr-2009"
+-PCRE_VERSION="${PCRE_MAJOR}.${PCRE_MINOR}"
+-
+-dnl Default values for miscellaneous macros
+-
+-POSIX_MALLOC_THRESHOLD="-DPOSIX_MALLOC_THRESHOLD=10"
+-
+-dnl Provide versioning information for libtool shared libraries that
+-dnl are built by default on Unix systems.
+-
+-PCRE_LIB_VERSION="0:1:0"
+-PCRE_POSIXLIB_VERSION="0:0:0"
+-
+-
+-
+-
+ dnl FIXME: This does no longer seem required with Autoconf 2.67?
+ dnl Intel MacOSX 10.6 puts X11 in a non-standard place
+ dnl AS_IF([test "x${with_x}" != "xno"],
+@@ -737,21 +710,6 @@
+
+
+
+-dnl "Export" these variables for PCRE
+-
+-AC_SUBST([HAVE_MEMMOVE])
+-AC_SUBST([HAVE_STRERROR])
+-AC_SUBST([PCRE_MAJOR])
+-AC_SUBST([PCRE_MINOR])
+-AC_SUBST([PCRE_DATE])
+-AC_SUBST([PCRE_VERSION])
+-AC_SUBST([PCRE_LIB_VERSION])
+-AC_SUBST([PCRE_POSIXLIB_VERSION])
+-AC_SUBST([POSIX_MALLOC_THRESHOLD])
+-
+-
+-
+-
+ dnl Test if --enable-localforce given
+ locallink="no"
+ embprefix="/usr/local"
+@@ -874,6 +832,11 @@
+ AM_CONDITIONAL([ESYSTEMLIBS], [test "x${enable_systemlibs}" = "xyes"])
+
+
++AS_IF([test "x${enable_systemlibs}" = "xyes"],
++[
++dnl using system libraries
++ PKG_CHECK_MODULES([PLPLOT], [plplotd])
++])
+
+
+ # Enable the purify tool: --enable-purify, sets CC and LIBTOOL
+--- DOMALIGN-0.1.650/src/Makefile.am
++++ DOMALIGN-0.1.650/src/Makefile.am
+@@ -17,10 +17,7 @@
+ -I../../../ajax/ensembl -I../../../ajax/ajaxdb \
+ -I../../../ajax/acd -I../../../plplot
+ else
+-AM_CPPFLAGS = -I../include -I${embprefix}/include \
+- -I${embprefix}/include/eplplot \
+- $(NLINCLUDES) \
+- -I${embprefix}/include/epcre
++AM_CPPFLAGS = -I${embprefix}/include $(NLINCLUDES) $(PLPLOT_CFLAGS)
+ endif
+
+ if ISSHARED
+@@ -63,5 +60,5 @@
+ ../../../plplot/libeplplot.la $(XLIB)
+ else
+ LDADD = -L${embprefix}/lib -lnucleus -lacd -lajaxdb -lensembl -lajaxg \
+- -lajax -lepcre $(NLADD) -leplplot $(XLIB)
++ -lajax $(NLADD) $(XLIB)
+ endif
+
diff --git a/sci-biology/embassy-domalign/metadata.xml b/sci-biology/embassy-domalign/metadata.xml
index d4648212cbad..f17a827e3101 100644
--- a/sci-biology/embassy-domalign/metadata.xml
+++ b/sci-biology/embassy-domalign/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-biology</herd>
+ <herd>sci-biology</herd>
</pkgmetadata>