summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-02-28 10:51:24 +0000
committerJustin Lecher <jlec@gentoo.org>2015-02-28 10:51:24 +0000
commit6226a00f5223849830d8838fd55d5fc1997262ff (patch)
tree93747af8b0cc3a817b15701214bbc37af01928fb /sci-biology/samtools
parentUse proper upstream tarball, thanks marienz for reporting (diff)
downloadgentoo-2-6226a00f5223849830d8838fd55d5fc1997262ff.tar.gz
gentoo-2-6226a00f5223849830d8838fd55d5fc1997262ff.tar.bz2
gentoo-2-6226a00f5223849830d8838fd55d5fc1997262ff.zip
Fix depend rules in make which break due to unbundling of htslib, #541134; use LD_LIBRARY_PATH druing tests
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology/samtools')
-rw-r--r--sci-biology/samtools/ChangeLog7
-rw-r--r--sci-biology/samtools/files/samtools-1.2-buildsystem.patch47
-rw-r--r--sci-biology/samtools/samtools-1.2.ebuild4
3 files changed, 52 insertions, 6 deletions
diff --git a/sci-biology/samtools/ChangeLog b/sci-biology/samtools/ChangeLog
index 080b006cb2b8..f9a84b0644c6 100644
--- a/sci-biology/samtools/ChangeLog
+++ b/sci-biology/samtools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/samtools
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/samtools/ChangeLog,v 1.22 2015/02/18 10:21:10 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/samtools/ChangeLog,v 1.23 2015/02/28 10:51:24 jlec Exp $
+
+ 28 Feb 2015; Justin Lecher <jlec@gentoo.org>
+ files/samtools-1.2-buildsystem.patch, samtools-1.2.ebuild:
+ Fix depend rules in make which break due to unbundling of htslib, #541134; use
+ LD_LIBRARY_PATH druing tests
*samtools-1.2 (18 Feb 2015)
diff --git a/sci-biology/samtools/files/samtools-1.2-buildsystem.patch b/sci-biology/samtools/files/samtools-1.2-buildsystem.patch
index 0044aac0725a..2343b2245a29 100644
--- a/sci-biology/samtools/files/samtools-1.2-buildsystem.patch
+++ b/sci-biology/samtools/files/samtools-1.2-buildsystem.patch
@@ -1,8 +1,8 @@
- Makefile | 76 ++++++++++++++++++++++++++++++++++++----------------------------
- 1 file changed, 43 insertions(+), 33 deletions(-)
+ Makefile | 94 +++++++++++++++++++++++++++++++++++-----------------------------
+ 1 file changed, 52 insertions(+), 42 deletions(-)
diff --git a/Makefile b/Makefile
-index e368cee..bebb7af 100644
+index e368cee..9054526 100644
--- a/Makefile
+++ b/Makefile
@@ -21,11 +21,12 @@
@@ -136,6 +136,47 @@ index e368cee..bebb7af 100644
test/merge/test_bam_translate test/merge/test_bam_translate.tmp
test/merge/test_pretty_header
test/merge/test_rtrans_build
+@@ -191,31 +201,31 @@ check test: samtools $(BGZIP) $(BUILT_TEST_PROGRAMS)
+ test/split/test_parse_args
+
+
+-test/merge/test_bam_translate: test/merge/test_bam_translate.o test/test.o $(HTSLIB)
++test/merge/test_bam_translate: test/merge/test_bam_translate.o test/test.o
+ $(CC) -pthread $(LDFLAGS) -o $@ test/merge/test_bam_translate.o test/test.o $(HTSLIB) $(LDLIBS) -lz
+
+-test/merge/test_pretty_header: test/merge/test_pretty_header.o $(HTSLIB)
++test/merge/test_pretty_header: test/merge/test_pretty_header.o
+ $(CC) -pthread $(LDFLAGS) -o $@ test/merge/test_pretty_header.o $(HTSLIB) $(LDLIBS) -lz
+
+-test/merge/test_rtrans_build: test/merge/test_rtrans_build.o $(HTSLIB)
++test/merge/test_rtrans_build: test/merge/test_rtrans_build.o
+ $(CC) -pthread $(LDFLAGS) -o $@ test/merge/test_rtrans_build.o $(HTSLIB) $(LDLIBS) -lz
+
+-test/merge/test_trans_tbl_init: test/merge/test_trans_tbl_init.o $(HTSLIB)
++test/merge/test_trans_tbl_init: test/merge/test_trans_tbl_init.o
+ $(CC) -pthread $(LDFLAGS) -o $@ test/merge/test_trans_tbl_init.o $(HTSLIB) $(LDLIBS) -lz
+
+-test/split/test_count_rg: test/split/test_count_rg.o test/test.o $(HTSLIB)
++test/split/test_count_rg: test/split/test_count_rg.o test/test.o
+ $(CC) -pthread $(LDFLAGS) -o $@ test/split/test_count_rg.o test/test.o $(HTSLIB) $(LDLIBS) -lz
+
+-test/split/test_expand_format_string: test/split/test_expand_format_string.o test/test.o $(HTSLIB)
++test/split/test_expand_format_string: test/split/test_expand_format_string.o test/test.o
+ $(CC) -pthread $(LDFLAGS) -o $@ test/split/test_expand_format_string.o test/test.o $(HTSLIB) $(LDLIBS) -lz
+
+-test/split/test_filter_header_rg: test/split/test_filter_header_rg.o test/test.o $(HTSLIB)
++test/split/test_filter_header_rg: test/split/test_filter_header_rg.o test/test.o
+ $(CC) -pthread $(LDFLAGS) -o $@ test/split/test_filter_header_rg.o test/test.o $(HTSLIB) $(LDLIBS) -lz
+
+-test/split/test_parse_args: test/split/test_parse_args.o test/test.o $(HTSLIB)
++test/split/test_parse_args: test/split/test_parse_args.o test/test.o
+ $(CC) -pthread $(LDFLAGS) -o $@ test/split/test_parse_args.o test/test.o $(HTSLIB) $(LDLIBS) -lz
+
+-test/vcf-miniview: test/vcf-miniview.o $(HTSLIB)
++test/vcf-miniview: test/vcf-miniview.o
+ $(CC) -pthread $(LDFLAGS) -o $@ test/vcf-miniview.o $(HTSLIB) $(LDLIBS) -lz
+
+ test_test_h = test/test.h $(htslib_sam_h)
@@ -252,10 +262,10 @@ misc/md5sum-lite: misc/md5sum-lite.o
misc/wgsim: misc/wgsim.o
$(CC) $(LDFLAGS) -o $@ misc/wgsim.o $(LDLIBS) -lm -lz
diff --git a/sci-biology/samtools/samtools-1.2.ebuild b/sci-biology/samtools/samtools-1.2.ebuild
index bfa8a1809cfe..a4f6f5cfe6bf 100644
--- a/sci-biology/samtools/samtools-1.2.ebuild
+++ b/sci-biology/samtools/samtools-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/samtools/samtools-1.2.ebuild,v 1.1 2015/02/18 10:21:10 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/samtools/samtools-1.2.ebuild,v 1.2 2015/02/28 10:51:24 jlec Exp $
EAPI=5
@@ -61,7 +61,7 @@ src_test() {
HTSLIB=$($(tc-getPKG_CONFIG) --libs htslib)
BAMLIB="libbam.so"
)
- emake "${mymakeargs[@]}" test
+ LD_LIBRARY_PATH="${S}" emake "${mymakeargs[@]}" test
}
src_install() {