summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-14 17:27:03 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-14 17:27:03 +0000
commitde7994c503f29b80c5e4e516cf26463dbabcf6af (patch)
tree9c1b63e8c2a1a5c41a9e8033666a99138a652556 /sci-biology/primer3
parentdev-tcltk/itk: Version Bump (diff)
downloadgentoo-2-de7994c503f29b80c5e4e516cf26463dbabcf6af.tar.gz
gentoo-2-de7994c503f29b80c5e4e516cf26463dbabcf6af.tar.bz2
gentoo-2-de7994c503f29b80c5e4e516cf26463dbabcf6af.zip
sci-biology/primer3: Version Bump
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-biology/primer3')
-rw-r--r--sci-biology/primer3/ChangeLog9
-rw-r--r--sci-biology/primer3/primer3-2.3.5.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/sci-biology/primer3/ChangeLog b/sci-biology/primer3/ChangeLog
index 2f139b7818c4..63181203ef3f 100644
--- a/sci-biology/primer3/ChangeLog
+++ b/sci-biology/primer3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/primer3
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/primer3/ChangeLog,v 1.39 2012/12/17 08:12:46 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/primer3/ChangeLog,v 1.40 2013/02/14 17:27:03 jlec Exp $
+
+*primer3-2.3.5 (14 Feb 2013)
+
+ 14 Feb 2013; Justin Lecher <jlec@gentoo.org> +primer3-2.3.5.ebuild:
+ Version Bump
17 Dec 2012; Justin Lecher <jlec@gentoo.org> -primer3-2.2.3.ebuild,
-primer3-2.3.0.ebuild:
diff --git a/sci-biology/primer3/primer3-2.3.5.ebuild b/sci-biology/primer3/primer3-2.3.5.ebuild
new file mode 100644
index 000000000000..d505e3d2ea47
--- /dev/null
+++ b/sci-biology/primer3/primer3-2.3.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/primer3/primer3-2.3.5.ebuild,v 1.1 2013/02/14 17:27:03 jlec Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Primer Design for PCR reactions"
+HOMEPAGE="http://primer3.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+
+DEPEND="dev-lang/perl"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.3.4-buildsystem.patch
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ sed -e "s:LIBOPTS ='-static':LIBOPTS =:" -i Makefile || die
+ fi
+
+ tc-export CC CXX AR RANLIB
+}
+
+src_compile() {
+ emake -C src
+}
+
+src_test () {
+ emake -C test | tee "${T}"/test.log
+ grep -q "\[FAILED\]" && die "test failed. See "${T}"/test.log"
+}
+
+src_install () {
+ dobin src/{long_seq_tm_test,ntdpal,oligotm,primer3_core}
+ dodoc src/release_notes.txt example
+ insinto /opt/primer3_config
+ doins -r src/primer3_config/* primer3*settings.txt
+ dohtml primer3_manual.htm
+}