summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-07-25 21:41:49 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-07-25 21:41:49 +0000
commit2fe0bbe5f94c5826721df9c2103bd442e81c9e25 (patch)
tree8611163e0f7636bdfd3023b651a8ed13a09e2ec5 /sci-biology/pilercr
parentFix compilation with gcc-4.4. Patch by Victor Ostorga <vostorga AT gentoo DO... (diff)
downloadgentoo-2-2fe0bbe5f94c5826721df9c2103bd442e81c9e25.tar.gz
gentoo-2-2fe0bbe5f94c5826721df9c2103bd442e81c9e25.tar.bz2
gentoo-2-2fe0bbe5f94c5826721df9c2103bd442e81c9e25.zip
Import from Science overlay
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/pilercr')
-rw-r--r--sci-biology/pilercr/ChangeLog11
-rw-r--r--sci-biology/pilercr/files/pilercr-1.0-gcc43.patch33
-rw-r--r--sci-biology/pilercr/metadata.xml9
-rw-r--r--sci-biology/pilercr/pilercr-1.0.ebuild34
4 files changed, 87 insertions, 0 deletions
diff --git a/sci-biology/pilercr/ChangeLog b/sci-biology/pilercr/ChangeLog
new file mode 100644
index 000000000000..762520722d77
--- /dev/null
+++ b/sci-biology/pilercr/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-biology/piler-cr
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/pilercr/ChangeLog,v 1.1 2009/07/25 21:41:49 weaver Exp $
+
+ 25 Jul 2009; Andrey Kislyuk <weaver@gentoo.org>
+ +files/pilercr-1.0-gcc43.patch, +metadata.xml:
+ Import from Science overlay
+
+ 18 Feb 2009; weaver <weaver@gentoo.org> ChangeLog:
+ New package sci-biology/pilercr, ebuild written by me
+
diff --git a/sci-biology/pilercr/files/pilercr-1.0-gcc43.patch b/sci-biology/pilercr/files/pilercr-1.0-gcc43.patch
new file mode 100644
index 000000000000..7b49df872e27
--- /dev/null
+++ b/sci-biology/pilercr/files/pilercr-1.0-gcc43.patch
@@ -0,0 +1,33 @@
+diff -dur work/multaln.h work-orig/multaln.h
+--- work/multaln.h 2007-04-17 19:02:18.000000000 +0000
++++ work-orig/multaln.h 2009-02-18 21:25:26.166333299 +0000
+@@ -6,6 +6,7 @@
+ #define _CRT_SECURE_NO_DEPRECATE 1
+ #endif
+
++#include <cstring>
+ #include <vector>
+ #include <limits.h>
+ #include <ctype.h>
+diff -dur work/seqvect.h work-orig/seqvect.h
+--- work/seqvect.h 2006-04-06 23:36:18.000000000 +0000
++++ work-orig/seqvect.h 2009-02-18 21:25:26.171090246 +0000
+@@ -1,6 +1,7 @@
+ #ifndef SeqVect_h
+ #define SeqVect_h
+
++#include <stdio.h>
+ #include <vector>
+ #include "seq.h"
+
+diff -dur work/tree.h work-orig/tree.h
+--- work/tree.h 2006-04-05 23:52:42.000000000 +0000
++++ work-orig/tree.h 2009-02-18 21:25:26.171090246 +0000
+@@ -1,6 +1,7 @@
+ #ifndef tree_h
+ #define tree_h
+
++#include <stdlib.h>
+ #include <limits.h>
+
+ class Clust;
diff --git a/sci-biology/pilercr/metadata.xml b/sci-biology/pilercr/metadata.xml
new file mode 100644
index 000000000000..3302123e5718
--- /dev/null
+++ b/sci-biology/pilercr/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>weaver@gentoo.org</email>
+ <name>Andrey Kislyuk</name>
+ </maintainer>
+ <herd>sci-biology</herd>
+</pkgmetadata>
diff --git a/sci-biology/pilercr/pilercr-1.0.ebuild b/sci-biology/pilercr/pilercr-1.0.ebuild
new file mode 100644
index 000000000000..043b9400cb6c
--- /dev/null
+++ b/sci-biology/pilercr/pilercr-1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/pilercr/pilercr-1.0.ebuild,v 1.1 2009/07/25 21:41:49 weaver Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Analysis of repetitive DNA found in genome sequences"
+HOMEPAGE="http://www.drive5.com/pilercr/"
+#SRC_URI="http://www.drive5.com/pilercr/pilercr.tar.gz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch || die
+}
+
+src_compile() {
+ emake GPP="$(tc-getCXX)" CFLAGS="${CXXFLAGS}" || die
+}
+
+src_install() {
+ dobin pilercr || die
+}