summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2007-09-19 18:32:04 +0000
committerOlivier Fisette <ribosome@gentoo.org>2007-09-19 18:32:04 +0000
commit0cb1e845cd5ab25ce3a8e36beead0ac57c35ca32 (patch)
tree787513fa2a3993673fac351f2dc3825b76ea1fdb /sci-biology/phylip
parentStable on ppc; bug #192445. (diff)
downloadgentoo-2-0cb1e845cd5ab25ce3a8e36beead0ac57c35ca32.tar.gz
gentoo-2-0cb1e845cd5ab25ce3a8e36beead0ac57c35ca32.tar.bz2
gentoo-2-0cb1e845cd5ab25ce3a8e36beead0ac57c35ca32.zip
New upstream version.
(Portage version: 2.1.3.9)
Diffstat (limited to 'sci-biology/phylip')
-rw-r--r--sci-biology/phylip/ChangeLog9
-rw-r--r--sci-biology/phylip/files/README.Gentoo2
-rw-r--r--sci-biology/phylip/files/digest-phylip-3.673
-rw-r--r--sci-biology/phylip/phylip-3.67.ebuild47
4 files changed, 59 insertions, 2 deletions
diff --git a/sci-biology/phylip/ChangeLog b/sci-biology/phylip/ChangeLog
index 4afa2b271190..3ab79e9b588e 100644
--- a/sci-biology/phylip/ChangeLog
+++ b/sci-biology/phylip/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/phylip
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/phylip/ChangeLog,v 1.26 2007/08/30 21:00:59 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/phylip/ChangeLog,v 1.27 2007/09/19 18:32:04 ribosome Exp $
+
+*phylip-3.67 (19 Sep 2007)
+
+ 19 Sep 2007; Olivier Fisette <ribosome@gentoo.org> files/README.Gentoo,
+ +phylip-3.67.ebuild:
+ New upstream version. (Thanks to Arfrever Frehtes Taifersar Arahesis
+ <arfrever.fta@gmail.com> for reporting. See bug #191869)
30 Aug 2007; Olivier Fisette <ribosome@gentoo.org> phylip-3.66.ebuild:
Added to ~amd64.
diff --git a/sci-biology/phylip/files/README.Gentoo b/sci-biology/phylip/files/README.Gentoo
index 0598c1541631..3b2062003996 100644
--- a/sci-biology/phylip/files/README.Gentoo
+++ b/sci-biology/phylip/files/README.Gentoo
@@ -11,5 +11,5 @@ Location of the font files
PHYLIP programs will find font files only if they are in a directory
referenced by the "PATH" variable or if they are in the current working
directory. When working with PHYLIP programs that need these files, either
-copy the fonts you need in your working directory, or add
+copy or symlink the fonts you need to your working directory, or add
"/usr/share/phylip/fonts/" to your "PATH" variable.
diff --git a/sci-biology/phylip/files/digest-phylip-3.67 b/sci-biology/phylip/files/digest-phylip-3.67
new file mode 100644
index 000000000000..76116bc020d8
--- /dev/null
+++ b/sci-biology/phylip/files/digest-phylip-3.67
@@ -0,0 +1,3 @@
+MD5 625e45f3959fd1d2988f0f5f1704d3e5 phylip-3.67.tar.gz 1467526
+RMD160 5636707b2585077a793c71fa81f255dfd8708100 phylip-3.67.tar.gz 1467526
+SHA256 089f31c0519b1af162628c02d4ff78570b42cd261f39b87c6406733f2f759b5d phylip-3.67.tar.gz 1467526
diff --git a/sci-biology/phylip/phylip-3.67.ebuild b/sci-biology/phylip/phylip-3.67.ebuild
new file mode 100644
index 000000000000..aa146eb00325
--- /dev/null
+++ b/sci-biology/phylip/phylip-3.67.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/phylip/phylip-3.67.ebuild,v 1.1 2007/09/19 18:32:04 ribosome Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="PHYLIP - The PHYLogeny Inference Package"
+LICENSE="freedist"
+HOMEPAGE="http://evolution.genetics.washington.edu/phylip.html"
+SRC_URI="http://evolution.gs.washington.edu/${PN}/download/${P}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~ppc ~ppc-macos ~x86 ~amd64"
+
+RDEPEND="x11-libs/libXaw"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/${P}/src"
+
+src_compile() {
+ sed -e "s/CFLAGS = -O3 -fomit-frame-pointer/CFLAGS = ${CFLAGS}/" \
+ -e "s/CC = cc/CC = $(tc-getCC)/" \
+ -e "s/DC = cc/DC = $(tc-getCC)/" \
+ -i Makefile || die "Patching Makefile failed."
+ mkdir ../fonts
+ emake -j1 all put || die "Compilation failed."
+ mv ../exe/font* ../fonts || die "Font move failed."
+ mv ../exe/factor ../exe/factor-${PN} || die "Renaming factor failed."
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}"
+
+ dobin exe/* || "Failed to install programs."
+
+ dodoc "${FILESDIR}"/README.Gentoo || die "Failed to install Gentoo notes."
+
+ dohtml phylip.html || "Failed to install HTML documentation index."
+ insinto /usr/share/doc/${PF}/html/doc
+ doins doc/* || "Failed to install HTML documentation."
+
+ insinto /usr/share/${PN}/fonts
+ doins fonts/* || die "Fonts installation failed."
+}