summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-01-25 23:51:42 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-01-25 23:51:42 +0000
commitc281774047b37a1f8cb82f3f745943b6bc261a5b (patch)
tree2ca0b6d854974dc4abcb4b6e3413ad221d1c858c /sci-biology/emboss
parentfix quoting (diff)
downloadgentoo-2-c281774047b37a1f8cb82f3f745943b6bc261a5b.tar.gz
gentoo-2-c281774047b37a1f8cb82f3f745943b6bc261a5b.tar.bz2
gentoo-2-c281774047b37a1f8cb82f3f745943b6bc261a5b.zip
Fixed unresolved symbols with as-needed (see bug #207304).
(Portage version: 2.1.4)
Diffstat (limited to 'sci-biology/emboss')
-rw-r--r--sci-biology/emboss/ChangeLog9
-rw-r--r--sci-biology/emboss/emboss-4.0.0.ebuild6
-rw-r--r--sci-biology/emboss/emboss-5.0.0.ebuild19
-rw-r--r--sci-biology/emboss/files/emboss-5.0.0-as-needed.patch24
4 files changed, 51 insertions, 7 deletions
diff --git a/sci-biology/emboss/ChangeLog b/sci-biology/emboss/ChangeLog
index d1e75ae470f0..1de7d18f5144 100644
--- a/sci-biology/emboss/ChangeLog
+++ b/sci-biology/emboss/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/emboss
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.45 2007/07/22 07:32:37 dberkholz Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.46 2008/01/25 23:51:41 markusle Exp $
+
+ 25 Jan 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/emboss-5.0.0-as-needed.patch, emboss-4.0.0.ebuild,
+ emboss-5.0.0.ebuild:
+ Fixed unresolved symbols with as-needed (see bug #207304).
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>; emboss-4.0.0.ebuild:
Drop virtual/x11 references.
diff --git a/sci-biology/emboss/emboss-4.0.0.ebuild b/sci-biology/emboss/emboss-4.0.0.ebuild
index 8d03a59bf2b2..0ced2e60f033 100644
--- a/sci-biology/emboss/emboss-4.0.0.ebuild
+++ b/sci-biology/emboss/emboss-4.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/emboss-4.0.0.ebuild,v 1.9 2007/07/22 07:32:37 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/emboss-4.0.0.ebuild,v 1.10 2008/01/25 23:51:41 markusle Exp $
DESCRIPTION="The European Molecular Biology Open Software Suite - A sequence analysis package"
HOMEPAGE="http://emboss.sourceforge.net/"
@@ -54,7 +54,7 @@ src_install() {
|| die "Failed to install documentation."
# Install env file for setting libplplot and acd files path.
- doenvd ${FILESDIR}/22emboss || die "Failed to install environment file."
+ doenvd "${FILESDIR}"/22emboss || die "Failed to install environment file."
# Symlink preinstalled docs to /usr/share/doc.
dosym /usr/share/EMBOSS/doc/manuals /usr/share/doc/${PF}/manuals || die
diff --git a/sci-biology/emboss/emboss-5.0.0.ebuild b/sci-biology/emboss/emboss-5.0.0.ebuild
index 5d7a83176305..7dc99b1a7050 100644
--- a/sci-biology/emboss/emboss-5.0.0.ebuild
+++ b/sci-biology/emboss/emboss-5.0.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/emboss-5.0.0.ebuild,v 1.1 2007/07/18 00:55:33 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/emboss-5.0.0.ebuild,v 1.2 2008/01/25 23:51:41 markusle Exp $
+
+inherit eutils
DESCRIPTION="The European Molecular Biology Open Software Suite - A sequence analysis package"
HOMEPAGE="http://emboss.sourceforge.net/"
@@ -33,6 +35,19 @@ PDEPEND="!minimal? (
S="${WORKDIR}/EMBOSS-${PV}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+
+ local link_string="-lX11";
+ if use png; then
+ link_string="${link_string} -lgd -lpng"
+ fi
+ sed -e "s:PATCH_PLPLOT:${link_string}:" -i plplot/Makefile.in \
+ || die "Failed to patch ajax Makefile"
+}
+
src_compile() {
EXTRA_CONF="--includedir=${D}/usr/include/emboss"
! use X && EXTRA_CONF="${EXTRA_CONF} --without-x"
diff --git a/sci-biology/emboss/files/emboss-5.0.0-as-needed.patch b/sci-biology/emboss/files/emboss-5.0.0-as-needed.patch
new file mode 100644
index 000000000000..9915f95376d0
--- /dev/null
+++ b/sci-biology/emboss/files/emboss-5.0.0-as-needed.patch
@@ -0,0 +1,24 @@
+diff -Naur EMBOSS-5.0.0.old/ajax/Makefile.in EMBOSS-5.0.0/ajax/Makefile.in
+--- EMBOSS-5.0.0.old/ajax/Makefile.in 2007-07-12 05:53:32.000000000 -0500
++++ EMBOSS-5.0.0/ajax/Makefile.in 2008-01-25 16:43:51.000000000 -0500
+@@ -244,7 +244,7 @@
+ top_srcdir = @top_srcdir@
+ @ISCYGWIN_FALSE@lib_LTLIBRARIES = libajax.la libajaxg.la
+ @ISCYGWIN_TRUE@lib_LTLIBRARIES = libajax.la
+-@ISAIXIA64_FALSE@@ISSHARED_TRUE@AM_CFLAGS =
++@ISAIXIA64_FALSE@@ISSHARED_TRUE@AM_CFLAGS = -lm -L../plplot/.libs -leplplot
+ @ISAIXIA64_TRUE@@ISSHARED_TRUE@@NEEDAJAX_FALSE@AM_CFLAGS = -Wl,-G -L../plplot/.libs -L.libs -leplplot -lm
+ @ISAIXIA64_TRUE@@ISSHARED_TRUE@@NEEDAJAX_TRUE@AM_CFLAGS = -Wl,-G -L../plplot/.libs -L.libs -lajax -leplplot -lm
+ @ISCYGWIN_TRUE@AM_LDFLAGS = -no-undefined -Wl,--add-stdcall-alias -Wl,--export-all-symbols -Wl,--enable-auto-import -L../plplot -leplplot
+diff -Naur EMBOSS-5.0.0.old/plplot/Makefile.in EMBOSS-5.0.0/plplot/Makefile.in
+--- EMBOSS-5.0.0.old/plplot/Makefile.in 2007-07-12 05:53:36.000000000 -0500
++++ EMBOSS-5.0.0/plplot/Makefile.in 2008-01-25 16:42:51.000000000 -0500
+@@ -229,7 +229,7 @@
+ lib_LTLIBRARIES = libeplplot.la
+ @AMPNG_FALSE@@ISAIXIA64_TRUE@@ISSHARED_TRUE@AM_CFLAGS = -Wl,-G -lX11
+ @AMPNG_TRUE@@ISAIXIA64_TRUE@@ISSHARED_TRUE@AM_CFLAGS = -Wl,-G -lgd -lpng -lz -lX11 -lm
+-@ISAIXIA64_FALSE@@ISSHARED_TRUE@AM_CFLAGS =
++@ISAIXIA64_FALSE@@ISSHARED_TRUE@AM_CFLAGS = PATCH_PLPLOT
+ @ISCYGWIN_TRUE@AM_LDFLAGS = -no-undefined -Wl,--add-stdcall-alias -Wl,--export-all-symbols -Wl,--enable-auto-import -lX11 -lgd -lpng -lz
+ INCLUDES = $(X_CFLAGS) -I$(srcdir)/ -I/usr/include/gd -DPREFIX=\"$(prefix)\" -DBUILD_DIR=\"$(srcdir)\" -DDRV_DIR=\"$(srcdir)\" -DEMBOSS_TOP=\"$(EMBOSS_TOP)\"
+ PLPLOTSRC = pdfutils.c plargs.c plbox.c plcont.c plcore.c \