summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-04-26 10:15:58 +0000
committerJustin Lecher <jlec@gentoo.org>2013-04-26 10:15:58 +0000
commitd8609a561e1f85b16336ab327bb948390c9ee827 (patch)
tree144aeab7e23fb9dc86a823501f2a332df86884a0 /sci-biology/biopython
parentUse AC_CONFIG_HEADERS instead of AM_CONFIG_HEADER for automake-1.13 compabili... (diff)
downloadgentoo-2-d8609a561e1f85b16336ab327bb948390c9ee827.tar.gz
gentoo-2-d8609a561e1f85b16336ab327bb948390c9ee827.tar.bz2
gentoo-2-d8609a561e1f85b16336ab327bb948390c9ee827.zip
sci-biology/biopython: Version Bump
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-biology/biopython')
-rw-r--r--sci-biology/biopython/ChangeLog10
-rw-r--r--sci-biology/biopython/biopython-1.61.ebuild52
-rw-r--r--sci-biology/biopython/metadata.xml2
3 files changed, 61 insertions, 3 deletions
diff --git a/sci-biology/biopython/ChangeLog b/sci-biology/biopython/ChangeLog
index 055bcb5ee1ad..7f2823ec82e7 100644
--- a/sci-biology/biopython/ChangeLog
+++ b/sci-biology/biopython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/biopython
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.68 2012/12/14 10:00:10 ulm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.69 2013/04/26 10:15:58 jlec Exp $
+
+*biopython-1.61 (26 Apr 2013)
+
+ 26 Apr 2013; Justin Lecher <jlec@gentoo.org> +biopython-1.61.ebuild,
+ metadata.xml:
+ Version Bump
14 Dec 2012; Ulrich Müller <ulm@gentoo.org> biopython-1.57.ebuild,
biopython-1.58.ebuild, biopython-1.59.ebuild:
diff --git a/sci-biology/biopython/biopython-1.61.ebuild b/sci-biology/biopython/biopython-1.61.ebuild
new file mode 100644
index 000000000000..c5fcff08dbe7
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.61.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.61.ebuild,v 1.1 2013/04/26 10:15:58 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python modules for computational molecular biology"
+HOMEPAGE="http://www.biopython.org/ http://pypi.python.org/pypi/biopython/"
+SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mysql postgres"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ media-gfx/pydot[${PYTHON_USEDEP}]
+ mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+#PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+#DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DOCS=( CONTRIB DEPRECATED NEWS README )
+#PYTHON_MODNAME="Bio BioSQL"
+
+#PATCHES=( "${FILESDIR}"/${PN}-1.51-flex.patch )
+
+python_test() {
+ cd Tests
+ ${PYTHON} run_tests.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr/share/doc/${PF}
+ doins -r Doc/*
+ insinto /usr/share/${PN}
+ cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
+}
diff --git a/sci-biology/biopython/metadata.xml b/sci-biology/biopython/metadata.xml
index 34294c65ca04..f17a827e3101 100644
--- a/sci-biology/biopython/metadata.xml
+++ b/sci-biology/biopython/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-biology</herd>
+ <herd>sci-biology</herd>
</pkgmetadata>