summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-26 12:17:18 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-26 12:17:18 +0000
commitbe43bc3e7da36abc7851fd422b9b04ede762dadb (patch)
tree3755deb278794cb34ce49301a0c92de9e7c92685 /sci-biology/biopython
parentStable for x86, wrt bug #544056 (diff)
downloadgentoo-2-be43bc3e7da36abc7851fd422b9b04ede762dadb.tar.gz
gentoo-2-be43bc3e7da36abc7851fd422b9b04ede762dadb.tar.bz2
gentoo-2-be43bc3e7da36abc7851fd422b9b04ede762dadb.zip
Backport test fix
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology/biopython')
-rw-r--r--sci-biology/biopython/ChangeLog6
-rw-r--r--sci-biology/biopython/biopython-1.65.ebuild4
-rw-r--r--sci-biology/biopython/files/biopython-1.65-test-fix-backport.patch40
3 files changed, 48 insertions, 2 deletions
diff --git a/sci-biology/biopython/ChangeLog b/sci-biology/biopython/ChangeLog
index eaafcd26553f..e127a14f7066 100644
--- a/sci-biology/biopython/ChangeLog
+++ b/sci-biology/biopython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/biopython
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.79 2015/03/26 07:11:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.80 2015/03/26 12:17:18 jlec Exp $
+
+ 26 Mar 2015; Justin Lecher <jlec@gentoo.org>
+ +files/biopython-1.65-test-fix-backport.patch, biopython-1.65.ebuild:
+ Backport test fix
26 Mar 2015; Justin Lecher <jlec@gentoo.org> biopython-1.65.ebuild:
Add note for embos support, bug #543510
diff --git a/sci-biology/biopython/biopython-1.65.ebuild b/sci-biology/biopython/biopython-1.65.ebuild
index b79d71c82e76..e6a0eb48a2b0 100644
--- a/sci-biology/biopython/biopython-1.65.ebuild
+++ b/sci-biology/biopython/biopython-1.65.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.65.ebuild,v 1.2 2015/03/26 07:11:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.65.ebuild,v 1.3 2015/03/26 12:17:18 jlec Exp $
EAPI=5
@@ -31,6 +31,8 @@ DEPEND="${RDEPEND}
DOCS=( CONTRIB DEPRECATED NEWS README Doc/. )
+PATCHES=( "${FILESDIR}"/${P}-test-fix-backport.patch )
+
python_test() {
[[ ${EPYTHON} == pypy ]] && return
cd Tests || die
diff --git a/sci-biology/biopython/files/biopython-1.65-test-fix-backport.patch b/sci-biology/biopython/files/biopython-1.65-test-fix-backport.patch
new file mode 100644
index 000000000000..2efdef97d799
--- /dev/null
+++ b/sci-biology/biopython/files/biopython-1.65-test-fix-backport.patch
@@ -0,0 +1,40 @@
+From 08c72f8778a87701586a03dffcce33c7589bc6d7 Mon Sep 17 00:00:00 2001
+From: Peter Cock <p.j.a.cock@googlemail.com>
+Date: Sun, 18 Jan 2015 02:07:54 +0000
+Subject: [PATCH] Clearer error message; update failing test.
+
+One of the orchid examples now returns different enough
+results that the test was failing. The new error message
+makes it much easier to pick another positive example to
+add to the the white-list.
+---
+ Tests/test_NCBI_qblast.py | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/Tests/test_NCBI_qblast.py b/Tests/test_NCBI_qblast.py
+index 88bfe61..19f7b35 100644
+--- a/Tests/test_NCBI_qblast.py
++++ b/Tests/test_NCBI_qblast.py
+@@ -66,7 +66,7 @@ def test_orchid_est(self):
+ AGCCATGGATTTCTCAGAAGAAAATGATTATACTTCTTAATCAGGCAACTGATATTATCAATTTATGGCA
+ GCAGAGTGGTGGCTCCTTGTCCCAGCAGCAGTAATTACTTTTTTTTCTCTTTTTGTTTCCAAATTAAGAA
+ ACATTAGTATCATATGGCTATTTGCTCAATTGCAGATTTCTTTCTTTTGTGAATG""",
+- 0.0000001, None, ["21554275", "18409071", "296087288"])
++ 0.0000001, None, ["21554275", "18409071", "296087288", "566183510"])
+
+ def run_qblast(self, program, database, query, e_value, entrez_filter, expected_hits):
+ try:
+@@ -120,9 +120,10 @@ def run_qblast(self, program, database, query, e_value, entrez_filter, expected_
+ print("Update this test to have some redundancy...")
+ for alignment in record.alignments:
+ print(alignment.hit_id)
+- assert found_result, "Missing all of %s in alignments" \
+- % ", ".join(expected_hits)
+- self.assertTrue(found_result)
++ self.assertTrue(found_result,
++ "Missing all expected hits (%s), instead have: %s"
++ % (", ".join(expected_hits),
++ ", ".join(a.hit_id for a in record.alignments)))
+
+ # Check the expected result(s) are found in the descriptions
+ if expected_hits is None: