summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-30 15:15:24 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-30 15:15:24 +0000
commit1fe2894b7eaf76491ae7b571e2b0747a6b402238 (patch)
tree7ed934b8d1303c6fc128ab35ea2a66208c3af0f9 /sci-biology/biopython
parentDrop Python 3 support (diff)
downloadgentoo-2-1fe2894b7eaf76491ae7b571e2b0747a6b402238.tar.gz
gentoo-2-1fe2894b7eaf76491ae7b571e2b0747a6b402238.tar.bz2
gentoo-2-1fe2894b7eaf76491ae7b571e2b0747a6b402238.zip
Version BUmp
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology/biopython')
-rw-r--r--sci-biology/biopython/ChangeLog9
-rw-r--r--sci-biology/biopython/biopython-1.63.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/sci-biology/biopython/ChangeLog b/sci-biology/biopython/ChangeLog
index bb30a4404636..119ccab60910 100644
--- a/sci-biology/biopython/ChangeLog
+++ b/sci-biology/biopython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/biopython
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.73 2013/12/29 00:56:58 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.74 2014/01/30 15:15:24 jlec Exp $
+
+*biopython-1.63 (30 Jan 2014)
+
+ 30 Jan 2014; Justin Lecher <jlec@gentoo.org> +biopython-1.63.ebuild:
+ Version BUmp
*biopython-1.62-r1 (29 Dec 2013)
diff --git a/sci-biology/biopython/biopython-1.63.ebuild b/sci-biology/biopython/biopython-1.63.ebuild
new file mode 100644
index 000000000000..f8079711ce31
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.63.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.63.ebuild,v 1.1 2014/01/30 15:15:24 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python modules for computational molecular biology"
+HOMEPAGE="http://www.biopython.org/ http://pypi.python.org/pypi/biopython/"
+SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="mysql postgres"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/rdflib[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ media-gfx/pydot[${PYTHON_USEDEP}]
+ mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+DOCS=( CONTRIB DEPRECATED NEWS README Doc/. )
+
+python_test() {
+ cd Tests || die
+ ${PYTHON} run_tests.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodir /usr/share/${PN}
+ cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
+}