summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2008-06-17 19:34:50 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2008-06-17 19:34:50 +0000
commit77bce882cd5ee3614f7bb4e0dece5e5e51339575 (patch)
tree9daa61b76ff4e45b41d7429b1b6b11d12d3c6273 /sci-biology/amos
parentAdd alternative mirror (diff)
downloadgentoo-2-77bce882cd5ee3614f7bb4e0dece5e5e51339575.tar.gz
gentoo-2-77bce882cd5ee3614f7bb4e0dece5e5e51339575.tar.bz2
gentoo-2-77bce882cd5ee3614f7bb4e0dece5e5e51339575.zip
Version bump and add gcc-4.3 patch, bug 227597, thanks to Marek Miller
(Portage version: 2.1.5.5)
Diffstat (limited to 'sci-biology/amos')
-rw-r--r--sci-biology/amos/amos-2.0.7.ebuild (renamed from sci-biology/amos/amos-2.0.5.ebuild)10
-rw-r--r--sci-biology/amos/files/amos-2.0.7-gcc43.patch84
2 files changed, 92 insertions, 2 deletions
diff --git a/sci-biology/amos/amos-2.0.5.ebuild b/sci-biology/amos/amos-2.0.7.ebuild
index 3fa12ba006e4..ce1038f8c9a5 100644
--- a/sci-biology/amos/amos-2.0.5.ebuild
+++ b/sci-biology/amos/amos-2.0.7.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/amos/amos-2.0.5.ebuild,v 1.1 2008/05/26 14:47:52 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/amos/amos-2.0.7.ebuild,v 1.1 2008/06/17 19:34:49 weaver Exp $
EAPI="1"
-inherit qt3
+inherit qt3 eutils
DESCRIPTION="A Modular, Open-Source whole genome assembler"
HOMEPAGE="http://amos.sourceforge.net/"
@@ -19,6 +19,12 @@ RDEPEND="${DEPEND}
dev-perl/DBI
sci-biology/mummer"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
src_compile() {
econf || die "econf failed"
# TODO: fix parallel make. Notified upstream
diff --git a/sci-biology/amos/files/amos-2.0.7-gcc43.patch b/sci-biology/amos/files/amos-2.0.7-gcc43.patch
new file mode 100644
index 000000000000..e9cfcf92c1d2
--- /dev/null
+++ b/sci-biology/amos/files/amos-2.0.7-gcc43.patch
@@ -0,0 +1,84 @@
+--- src/Foundation/ConfigFile.cc.orig 2008-06-16 18:12:13.000000000 +0000
++++ src/Foundation/ConfigFile.cc 2008-06-16 18:12:28.000000000 +0000
+@@ -35,6 +35,8 @@
+
+ #include "ConfigFile.hh"
+
++#include <cstring>
++
+ //! Constructor
+ /*! Creates a ConfigFile class. Also loads, parses, and resolves
+ * variable substitution.
+
+--- src/Foundation/Logger.cc.orig 2008-06-16 18:13:45.000000000 +0000
++++ src/Foundation/Logger.cc 2008-06-16 18:14:03.000000000 +0000
+@@ -58,6 +58,8 @@
+ */
+
+ #include "Logger.hh"
++#include <cstdlib>
++
+
+ //! Sets default values for class
+ /*! Note: Log is disabled until a filter level is set\n
+
+--- src/Foundation/OptionResult.cc.orig 2008-06-16 18:15:41.000000000 +0000
++++ src/Foundation/OptionResult.cc 2008-06-16 18:15:51.000000000 +0000
+@@ -9,6 +9,8 @@
+ //! @brief OptionResult class implementation
+
+ #include "OptionResult.hh"
++#include <cstdlib>
++
+
+ //! Sets defaults for all results
+ OptionResult::OptionResult(const std::string & optionHelp)
+
+--- src/Foundation/Options.cc.orig 2008-06-16 18:17:01.000000000 +0000
++++ src/Foundation/Options.cc 2008-06-16 18:17:11.000000000 +0000
+@@ -26,6 +26,8 @@
+ */
+
+ #include "Options.hh"
++#include <cstring>
++
+
+ //! Constructor takes command line options in standard argc, argv format
+ /*! Initializes application name, filespec, and invocation
+
+--- src/Align/missing-reads.cc.orig 2008-06-16 18:22:21.000000000 +0000
++++ src/Align/missing-reads.cc 2008-06-16 18:22:34.000000000 +0000
+@@ -9,6 +9,8 @@
+ #include <vector>
+ #include <algorithm>
+ #include <cassert>
++#include <cstring>
++
+ using namespace std;
+
+ const int MAX_LINE = 1000;
+
+--- src/Utils/runAmos.cc.orig 2008-06-16 18:30:30.000000000 +0000
++++ src/Utils/runAmos.cc 2008-06-16 18:30:42.000000000 +0000
+@@ -18,6 +18,8 @@
+ #include <dirent.h>
+ #include <fcntl.h>
+ #include <iostream>
++#include <cstdlib>
++
+
+ #define MAX_STRING 256 // length of various char*s in file
+
+
+--- src/bankViewer/HistogramWindow.cc.orig 2008-06-16 18:36:40.000000000 +0000
++++ src/bankViewer/HistogramWindow.cc 2008-06-16 18:37:04.000000000 +0000
+@@ -1,6 +1,8 @@
+ #include "HistogramWindow.hh"
+ #include "HistogramWidget.hh"
+ #include "InsertStats.hh"
++#include <cstdlib>
++
+
+ #include <qspinbox.h>
+ #include <qcheckbox.h>
+