summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-11-25 07:32:54 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-11-25 07:32:54 +0000
commitf67da832ede477b0eec8133f965101a2df41ae24 (patch)
tree200dec1c25909091c50800a9e08a8da388ca50e9 /sci-astronomy
parentRemove old versions. (diff)
downloadgentoo-2-f67da832ede477b0eec8133f965101a2df41ae24.tar.gz
gentoo-2-f67da832ede477b0eec8133f965101a2df41ae24.tar.bz2
gentoo-2-f67da832ede477b0eec8133f965101a2df41ae24.zip
Fixed ds9 script for paths. Might be broken for xml, only time will tell
(Portage version: 2.2_rc51/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/ds9/ChangeLog8
-rw-r--r--sci-astronomy/ds9/ds9-5.7-r2.ebuild (renamed from sci-astronomy/ds9/ds9-5.7-r1.ebuild)4
-rw-r--r--sci-astronomy/ds9/files/ds9-5.7-main.patch24
-rw-r--r--sci-astronomy/ds9/files/ds9-5.7-src.patch4
4 files changed, 24 insertions, 16 deletions
diff --git a/sci-astronomy/ds9/ChangeLog b/sci-astronomy/ds9/ChangeLog
index c05052c763fa..d15090adf90a 100644
--- a/sci-astronomy/ds9/ChangeLog
+++ b/sci-astronomy/ds9/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/ds9
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ChangeLog,v 1.21 2009/11/24 07:40:17 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ChangeLog,v 1.22 2009/11/25 07:32:54 bicatali Exp $
+
+*ds9-5.7-r2 (25 Nov 2009)
+
+ 25 Nov 2009; Sébastien Fabbro <bicatali@gentoo.org> -ds9-5.7-r1.ebuild,
+ +ds9-5.7-r2.ebuild, files/ds9-5.7-main.patch, files/ds9-5.7-src.patch:
+ Fixed ds9 script for paths. Might be broken for xml, only time will tell
*ds9-5.7-r1 (24 Nov 2009)
diff --git a/sci-astronomy/ds9/ds9-5.7-r1.ebuild b/sci-astronomy/ds9/ds9-5.7-r2.ebuild
index 6d2762445686..a0a8e8fbcbc3 100644
--- a/sci-astronomy/ds9/ds9-5.7-r1.ebuild
+++ b/sci-astronomy/ds9/ds9-5.7-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ds9-5.7-r1.ebuild,v 1.1 2009/11/24 07:40:17 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ds9-5.7-r2.ebuild,v 1.1 2009/11/25 07:32:54 bicatali Exp $
EAPI=2
inherit eutils
@@ -52,7 +52,7 @@ src_prepare() {
src_install () {
newbin bin/ds9 ds9.exe || die "failed installing ds9 binary"
echo "#!/bin/sh" > ds9
- echo "LD_LIBRARY_PATH=$(dir -d ${ROOT}usr/$(get_libdir)/Tclxml*) ds9.exe" >> ds9.sh
+ echo "LD_LIBRARY_PATH=$(dir -d ${ROOT}usr/$(get_libdir)/Tclxml?.?):\${LD_LIBRARY_PATH} ds9.exe" >> ds9.sh
exeinto /usr/bin
newexe ds9.sh ds9
insinto /usr/share/${PN}
diff --git a/sci-astronomy/ds9/files/ds9-5.7-main.patch b/sci-astronomy/ds9/files/ds9-5.7-main.patch
index 802068abdbc6..08039779c825 100644
--- a/sci-astronomy/ds9/files/ds9-5.7-main.patch
+++ b/sci-astronomy/ds9/files/ds9-5.7-main.patch
@@ -1,6 +1,6 @@
diff -Nur saods9.orig/ds9/ds9.C saods9/ds9/ds9.C
---- saods9.orig/ds9/ds9.C 2009-11-04 02:32:16.000000000 +0000
-+++ saods9/ds9/ds9.C 2009-11-04 02:58:59.000000000 +0000
+--- saods9.orig/ds9/ds9.C 2009-10-01 17:53:59.000000000 +0100
++++ saods9/ds9/ds9.C 2009-11-25 07:43:52.000000000 +0000
@@ -13,8 +13,6 @@
void TclSetStartupScriptFileName(const char*);
@@ -101,10 +101,14 @@ diff -Nur saods9.orig/ds9/ds9.C saods9/ds9/ds9.C
// IIS
if (Iis_Init(interp) == TCL_ERROR)
return TCL_ERROR;
-@@ -194,84 +147,6 @@
- if (Tclxml_Init(interp) == TCL_ERROR)
- return TCL_ERROR;
+@@ -190,88 +143,6 @@
+ Tcl_StaticPackage (interp, "tkmpeg", Tkmpeg_Init,
+ (Tcl_PackageInitProc*)NULL);
+- // Tclxml
+- if (Tclxml_Init(interp) == TCL_ERROR)
+- return TCL_ERROR;
+-
- // Tkimg
- if (Tkimg_Init(interp) == TCL_ERROR)
- return TCL_ERROR;
@@ -186,7 +190,7 @@ diff -Nur saods9.orig/ds9/ds9.C saods9/ds9/ds9.C
// Signal_Ext
#ifndef _WIN32
if (Signal_ext_Init(interp) == TCL_ERROR)
-@@ -294,15 +169,6 @@
+@@ -294,15 +165,6 @@
(Tcl_PackageInitProc*)NULL);
#endif
@@ -203,8 +207,8 @@ diff -Nur saods9.orig/ds9/ds9.C saods9/ds9/ds9.C
}
diff -Nur saods9.orig/ds9/Makefile saods9/ds9/Makefile
---- saods9.orig/ds9/Makefile 2009-11-04 02:32:16.000000000 +0000
-+++ saods9/ds9/Makefile 2009-11-04 03:10:28.000000000 +0000
+--- saods9.orig/ds9/Makefile 2009-09-30 21:35:26.000000000 +0100
++++ saods9/ds9/Makefile 2009-11-25 07:42:35.000000000 +0000
@@ -4,12 +4,7 @@
#--------------------------defines
@@ -302,11 +306,11 @@ diff -Nur saods9.orig/ds9/Makefile saods9/ds9/Makefile
+ $(RM) $@
+ rm -f libstdc++.a
+ ln -s `$(CXX) -print-file-name=libstdc++.a` .
-+ $(CXX) ${LDFLAGS} \
++ $(CXX) $(LDFLAGS) \
+ $(OBJS) $(LIBS) -o $@ \
+ -Wl,-Bstatic -L. -lstdc++ \
+ -Wl,-Bdynamic -L$(X11LIB) -lX11 \
-+ -ldl -lpthread -lxml2 -L/usr/lib/$(TCLXMLVER) -lTclxml3.2 \
++ -ldl -lpthread -lxml2 \
+ -ltk -ltcl -lBLT24 \
+ -lfuntools `pkg-config --libs wcstools` -lz \
+ `ast_link`
diff --git a/sci-astronomy/ds9/files/ds9-5.7-src.patch b/sci-astronomy/ds9/files/ds9-5.7-src.patch
index d60870b2f942..e64d2e73ca41 100644
--- a/sci-astronomy/ds9/files/ds9-5.7-src.patch
+++ b/sci-astronomy/ds9/files/ds9-5.7-src.patch
@@ -1,6 +1,6 @@
--- saods9.orig/src/ds9.tcl 2009-11-04 02:32:17.000000000 +0000
+++ saods9/src/ds9.tcl 2009-11-04 02:50:39.000000000 +0000
-@@ -34,24 +34,34 @@
+@@ -34,24 +34,32 @@
option add {*Label*BorderWidth} 2
# initialize
@@ -13,7 +13,6 @@
+package require http
-source $ds9(root)/tk8.4/tearoff.tcl
-+package require tearoff
-source $ds9(root)/tcllib1.10/base64/base64.tcl
-source $ds9(root)/tcllib1.10/log/log.tcl
@@ -33,7 +32,6 @@
+package require textutil::tabify
+
+package require tkcon
-+package require xmlrpc
+
+package require BLT
+package require Tktable