summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-03 15:37:32 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-03 15:37:32 +0000
commit64d94daf10fbc1b200ea3881b62582763c9ddba6 (patch)
treefe7c63ca2b26943f55d06e7fa4e00dafe6040b2f /sci-astronomy
parentVersion bump (diff)
downloadgentoo-2-64d94daf10fbc1b200ea3881b62582763c9ddba6.tar.gz
gentoo-2-64d94daf10fbc1b200ea3881b62582763c9ddba6.tar.bz2
gentoo-2-64d94daf10fbc1b200ea3881b62582763c9ddba6.zip
sci-astronomy/celestia: Add patch for gcc47, #414015
(Portage version: 2.2.0_alpha109/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/celestia/ChangeLog6
-rw-r--r--sci-astronomy/celestia/celestia-1.6.1.ebuild5
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-gcc47.patch22
3 files changed, 31 insertions, 2 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index 39df97996479..859d76fe60be 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.84 2012/05/04 06:46:12 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.85 2012/06/03 15:37:32 jlec Exp $
+
+ 03 Jun 2012; Justin Lecher <jlec@gentoo.org> celestia-1.6.1.ebuild,
+ +files/celestia-1.6.1-gcc47.patch:
+ Add patch for gcc47, #414015
04 May 2012; Jeff Horelick <jdhore@gentoo.org> celestia-1.6.1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/sci-astronomy/celestia/celestia-1.6.1.ebuild b/sci-astronomy/celestia/celestia-1.6.1.ebuild
index cf4b179a859a..b04dbc9c7d8a 100644
--- a/sci-astronomy/celestia/celestia-1.6.1.ebuild
+++ b/sci-astronomy/celestia/celestia-1.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.1.ebuild,v 1.12 2012/05/04 06:46:12 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.1.ebuild,v 1.13 2012/06/03 15:37:31 jlec Exp $
EAPI=2
@@ -60,6 +60,9 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-libpng15.patch \
"${FILESDIR}"/${P}-linking.patch
+ # gcc-47, #414015
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+
# remove flags to let the user decide
for cf in -O2 -ffast-math \
-fexpensive-optimizations \
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-gcc47.patch b/sci-astronomy/celestia/files/celestia-1.6.1-gcc47.patch
new file mode 100644
index 000000000000..385f39a20511
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.6.1-gcc47.patch
@@ -0,0 +1,22 @@
+diff -up celestia-1.6.1/src/celengine/frametree.h.gcc47 celestia-1.6.1/src/celengine/frametree.h
+--- celestia-1.6.1/src/celengine/frametree.h.gcc47 2012-03-22 12:56:56.096087430 -0400
++++ celestia-1.6.1/src/celengine/frametree.h 2012-03-22 12:57:04.333022427 -0400
+@@ -13,6 +13,7 @@
+ #ifndef _CELENGINE_FRAMETREE_H_
+ #define _CELENGINE_FRAMETREE_H_
+
++#include <unistd.h>
+ #include <vector>
+
+ class Star;
+diff -up celestia-1.6.1/src/celengine/planetgrid.cpp.gcc47 celestia-1.6.1/src/celengine/planetgrid.cpp
+--- celestia-1.6.1/src/celengine/planetgrid.cpp.gcc47 2012-03-22 12:53:01.496950513 -0400
++++ celestia-1.6.1/src/celengine/planetgrid.cpp 2012-03-22 12:53:08.812891865 -0400
+@@ -12,6 +12,7 @@
+
+ #include <cstdio>
+ #include <cmath>
++#include <celmath/mathlib.h>
+ #include <celmath/intersect.h>
+ #include "planetgrid.h"
+ #include "body.h"