summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-01-08 14:24:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-01-08 14:24:37 +0000
commit2c759a59b734938e3bb1224a9cb5bcba7bd266ff (patch)
treebefeff12c78ad3e1470bbab8e57735fdec2a7f68 /sci-astronomy
parentBlock with ircd-hybrid, both provide ircd executable (diff)
downloadgentoo-2-2c759a59b734938e3bb1224a9cb5bcba7bd266ff.tar.gz
gentoo-2-2c759a59b734938e3bb1224a9cb5bcba7bd266ff.tar.bz2
gentoo-2-2c759a59b734938e3bb1224a9cb5bcba7bd266ff.zip
Added explicit pkgconfig dependency (bug #204802)
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/celestia/ChangeLog8
-rw-r--r--sci-astronomy/celestia/celestia-1.4.1-r2.ebuild35
2 files changed, 25 insertions, 18 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index cc66bdb97459..8ee2d22bb5e1 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-astronomy/celestia
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.36 2007/09/11 11:47:04 bicatali Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.37 2008/01/08 14:24:37 bicatali Exp $
+
+ 08 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ celestia-1.4.1-r2.ebuild:
+ Added explicit pkgconfig dependency (bug #204802)
11 Sep 2007; Sébastien Fabbro <bicatali@gentoo.org>
+files/celestia-1.4.1-gnome-desktop.patch, celestia-1.4.1-r2.ebuild:
diff --git a/sci-astronomy/celestia/celestia-1.4.1-r2.ebuild b/sci-astronomy/celestia/celestia-1.4.1-r2.ebuild
index 62e8928c0258..f4905b52acc3 100644
--- a/sci-astronomy/celestia/celestia-1.4.1-r2.ebuild
+++ b/sci-astronomy/celestia/celestia-1.4.1-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.1-r2.ebuild,v 1.8 2007/09/11 11:47:04 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.1-r2.ebuild,v 1.9 2008/01/08 14:24:37 bicatali Exp $
WANT_AUTOMAKE="1.9"
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86"
IUSE="cairo gnome gtk kde arts threads nls lua"
-DEPEND="virtual/glu
+RDEPEND="virtual/glu
media-libs/jpeg
media-libs/libpng
gtk? ( !gnome? ( !kde? (
@@ -33,6 +33,9 @@ DEPEND="virtual/glu
lua? ( >=dev-lang/lua-5.0 )
cairo? ( x11-libs/cairo )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
pkg_setup() {
# Check for one for the following use flags to be set.
if ! use gnome && use kde; then
@@ -68,32 +71,32 @@ src_unpack() {
# some lua patches to make it work for lua-5.1
has_version ">=dev-lang/lua-5.1.1" && \
- epatch "${FILESDIR}/${P}-lua51.patch"
+ epatch "${FILESDIR}"/${P}-lua51.patch
# standard set of gcc-4.1 patches
- epatch "${FILESDIR}/${P}-gcc-4.1.patch"
+ epatch "${FILESDIR}"/${P}-gcc-4.1.patch
# fix kde datadir in makefile.am and .desktop location
- epatch "${FILESDIR}/${P}-kde-datadir.patch"
+ epatch "${FILESDIR}"/${P}-kde-datadir.patch
# add a desktop file that doesn't end up in lost+found
- epatch "${FILESDIR}/${P}-kde-desktop.patch"
- epatch "${FILESDIR}/${P}-gnome-desktop.patch"
+ epatch "${FILESDIR}"/${P}-kde-desktop.patch
+ epatch "${FILESDIR}"/${P}-gnome-desktop.patch
# add a ~/.celestia for extra directories
- epatch "${FILESDIR}/${P}-cfg.patch"
+ epatch "${FILESDIR}"/${P}-cfg.patch
# strict aliasing from fedora
- epatch "${FILESDIR}/${P}-strictalias.patch"
+ epatch "${FILESDIR}"/${P}-strictalias.patch
# install 3ds models by requests
- epatch "${FILESDIR}/${P}-3dsmodels.patch"
+ epatch "${FILESDIR}"/${P}-3dsmodels.patch
# fix po/Makefile.in.in to regenerate
- epatch "${FILESDIR}/${P}-locale.patch"
+ epatch "${FILESDIR}"/${P}-locale.patch
# fix for as-needed (bug #130091)
- epatch "${FILESDIR}/${P}-as-needed.patch"
+ epatch "${FILESDIR}"/${P}-as-needed.patch
# remove flags to let the user decide
for cf in -O2 -ffast-math \
@@ -145,10 +148,10 @@ src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
for size in 16 22 32 48 ; do
insinto /usr/share/icons/hicolor/${size}x${size}/apps
- newins ${S}/src/celestia/kde/data/hi${size}-app-${PN}.png ${PN}.png
+ newins "${S}"/src/celestia/kde/data/hi${size}-app-${PN}.png ${PN}.png
done
fi
- dodoc AUTHORS README TODO NEWS TRANSLATORS *.txt
- dohtml coding-standards.html
+ dodoc AUTHORS README TODO NEWS TRANSLATORS *.txt || die
+ dohtml coding-standards.html || die
dosym "${PORTDIR}"/licenses/GPL-2 /usr/share/${PN}/COPYING
}