summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-09-11 11:36:29 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-09-11 11:36:29 +0000
commit5280bc8d06bb95fa8c6f7ba3e38d7940340129e1 (patch)
tree80941046eda768cb3abe756b7ce19711997e2352 /sci-astronomy/xfitsview
parentRemove unneeded dep, bug 182483, cosmetics, and remove old (diff)
downloadgentoo-2-5280bc8d06bb95fa8c6f7ba3e38d7940340129e1.tar.gz
gentoo-2-5280bc8d06bb95fa8c6f7ba3e38d7940340129e1.tar.bz2
gentoo-2-5280bc8d06bb95fa8c6f7ba3e38d7940340129e1.zip
Version bump. Closing bug #191885.
(Portage version: 2.1.2.12)
Diffstat (limited to 'sci-astronomy/xfitsview')
-rw-r--r--sci-astronomy/xfitsview/ChangeLog8
-rw-r--r--sci-astronomy/xfitsview/files/digest-xfitsview-2.23
-rw-r--r--sci-astronomy/xfitsview/xfitsview-2.2.ebuild37
3 files changed, 47 insertions, 1 deletions
diff --git a/sci-astronomy/xfitsview/ChangeLog b/sci-astronomy/xfitsview/ChangeLog
index 25c1d7352535..e4389dc0d2ac 100644
--- a/sci-astronomy/xfitsview/ChangeLog
+++ b/sci-astronomy/xfitsview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/xfitsview
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xfitsview/ChangeLog,v 1.1 2007/04/19 16:27:39 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xfitsview/ChangeLog,v 1.2 2007/09/11 11:36:29 bicatali Exp $
+
+*xfitsview-2.2 (11 Sep 2007)
+
+ 11 Sep 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ +xfitsview-2.2.ebuild:
+ Version bump. Closing bug #191885.
*xfitsview-2.1 (19 Apr 2007)
diff --git a/sci-astronomy/xfitsview/files/digest-xfitsview-2.2 b/sci-astronomy/xfitsview/files/digest-xfitsview-2.2
new file mode 100644
index 000000000000..e7374f97ccee
--- /dev/null
+++ b/sci-astronomy/xfitsview/files/digest-xfitsview-2.2
@@ -0,0 +1,3 @@
+MD5 2469ea512fa6ea57cf28a325ee74139e xfitsview2.2.tgz 290959
+RMD160 d6c3748d69e0538ccf388e9a7e037043ff990383 xfitsview2.2.tgz 290959
+SHA256 f47649ad0091fa555aae13a0c539cd378591df28613b8572195baf77eea74fbb xfitsview2.2.tgz 290959
diff --git a/sci-astronomy/xfitsview/xfitsview-2.2.ebuild b/sci-astronomy/xfitsview/xfitsview-2.2.ebuild
new file mode 100644
index 000000000000..7ad9625a514e
--- /dev/null
+++ b/sci-astronomy/xfitsview/xfitsview-2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xfitsview/xfitsview-2.2.ebuild,v 1.1 2007/09/11 11:36:29 bicatali Exp $
+
+inherit eutils
+
+MY_PN=XFITSview
+MY_P=${MY_PN}${PV}
+
+DESCRIPTION="Viewer for astronomical images in FITS format"
+HOMEPAGE="http://www.nrao.edu/software/fitsview/"
+SRC_URI="ftp://ftp.cv.nrao.edu/fits/os-support/unix/xfitsview/${PN}${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+DEPEND="virtual/motif"
+
+S=${WORKDIR}/${MY_PN}
+
+src_compile() {
+ econf || die "econf failed"
+ # trick to make parallel building work
+ for d in fitssubs src; do
+ pushd ${d}
+ emake || die "emake ${d} failed"
+ popd
+ done
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dobin XFITSview || die "dobin failed"
+ dodoc README changes notes.text || die "dodoc failed"
+}