summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-08-05 19:18:28 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-08-05 19:18:28 +0000
commitc1823a3e425b5868ce75abc2e66ce29fb5a40c09 (patch)
tree5a5c4b1b878dd22e8e265e386ca991fa00b87c83 /sci-astronomy/pyephem
parentStable arm, bug #427546 (diff)
downloadgentoo-2-c1823a3e425b5868ce75abc2e66ce29fb5a40c09.tar.gz
gentoo-2-c1823a3e425b5868ce75abc2e66ce29fb5a40c09.tar.bz2
gentoo-2-c1823a3e425b5868ce75abc2e66ce29fb5a40c09.zip
keyword amd64-linux, x86-linux, switch to EAPI4
(Portage version: 2.2.01.20796-prefix/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/pyephem')
-rw-r--r--sci-astronomy/pyephem/ChangeLog6
-rw-r--r--sci-astronomy/pyephem/pyephem-3.7.5.1.ebuild14
2 files changed, 10 insertions, 10 deletions
diff --git a/sci-astronomy/pyephem/ChangeLog b/sci-astronomy/pyephem/ChangeLog
index 6c5db27bfe40..da439c54b70b 100644
--- a/sci-astronomy/pyephem/ChangeLog
+++ b/sci-astronomy/pyephem/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-astronomy/pyephem
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/ChangeLog,v 1.16 2012/02/25 02:47:03 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/ChangeLog,v 1.17 2012/08/05 19:18:28 bicatali Exp $
+
+ 05 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> pyephem-3.7.5.1.ebuild:
+ keyword amd64-linux, x86-linux, switch to EAPI4
25 Feb 2012; Patrick Lauer <patrick@gentoo.org> pyephem-3.7.4.1.ebuild,
pyephem-3.7.5.1.ebuild:
@@ -82,4 +85,3 @@
+pyephem-3.7b.ebuild:
Initial import (fixes bug #67489). Many thanks to Tim Cera
<timcera@earthlink.net> for his ebuild.
-
diff --git a/sci-astronomy/pyephem/pyephem-3.7.5.1.ebuild b/sci-astronomy/pyephem/pyephem-3.7.5.1.ebuild
index 7ff6bcbc5f38..ab874da60ef9 100644
--- a/sci-astronomy/pyephem/pyephem-3.7.5.1.ebuild
+++ b/sci-astronomy/pyephem/pyephem-3.7.5.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/pyephem-3.7.5.1.ebuild,v 1.2 2012/02/25 02:47:03 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/pyephem-3.7.5.1.ebuild,v 1.3 2012/08/05 19:18:28 bicatali Exp $
-EAPI="3"
+EAPI=4
PYTHON_DEPEND="2:2.5"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.4 3.* *-jython 2.7-pypy-*"
@@ -15,14 +15,14 @@ HOMEPAGE="http://rhodesmill.org/pyephem/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="doc"
RDEPEND=""
DEPEND="doc? ( dev-python/sphinx )"
src_prepare() {
# don't install rst files
- sed -i -e "s:'doc/\*\.rst',::" "${S}"/setup.py || die
+ sed -i -e "s:'doc/\*\.rst',::" setup.py || die
distutils_src_prepare
}
@@ -30,13 +30,11 @@ src_compile() {
distutils_src_compile
if use doc; then
cd src/ephem/doc
- PYTHONPATH=../../.. emake html || die "Building of documentation failed"
+ PYTHONPATH=../../.. emake html
fi
}
src_install() {
distutils_src_install
- if use doc; then
- dohtml -r src/ephem/doc/.build/html/* || die "Installation of documentation failed"
- fi
+ use doc && dohtml -r src/ephem/doc/.build/html/*
}