summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-09-06 18:24:05 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-09-06 18:24:05 +0000
commit7271d7a46466230c9e568bc53af7994c417d4e91 (patch)
tree84e6d530cf87caf94156278b9949f8b37ccdd3b4 /sci-astronomy/celestia
parentRemove unused patches. Fix repoman complains. (diff)
downloadgentoo-2-7271d7a46466230c9e568bc53af7994c417d4e91.tar.gz
gentoo-2-7271d7a46466230c9e568bc53af7994c417d4e91.tar.bz2
gentoo-2-7271d7a46466230c9e568bc53af7994c417d4e91.zip
Fixed when kde 3 when kde4 is installed, thanks to johannis, closing bug #282829
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/celestia')
-rw-r--r--sci-astronomy/celestia/ChangeLog7
-rw-r--r--sci-astronomy/celestia/celestia-1.6.0.ebuild5
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.0-kde-3.5.patch24
3 files changed, 34 insertions, 2 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index a11695482f23..221f6a2f0f26 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.52 2009/08/13 00:38:47 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.53 2009/09/06 18:24:05 bicatali Exp $
+
+ 06 Sep 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ celestia-1.6.0.ebuild, +files/celestia-1.6.0-kde-3.5.patch:
+ Fixed when kde 3 when kde4 is installed, thanks to johannis, closing bug
+ #282829
13 Aug 2009; Sébastien Fabbro <bicatali@gentoo.org>
celestia-1.6.0.ebuild, -files/celestia-1.6.0-as-needed.patch:
diff --git a/sci-astronomy/celestia/celestia-1.6.0.ebuild b/sci-astronomy/celestia/celestia-1.6.0.ebuild
index 8e084df8e616..eecf750e9e87 100644
--- a/sci-astronomy/celestia/celestia-1.6.0.ebuild
+++ b/sci-astronomy/celestia/celestia-1.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.0.ebuild,v 1.2 2009/08/13 00:38:47 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.0.ebuild,v 1.3 2009/09/06 18:24:05 bicatali Exp $
EAPI=2
inherit eutils flag-o-matic gnome2 kde-functions autotools
@@ -67,6 +67,9 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.4.1-as-needed.patch
# missing includes with gcc 4.4
epatch "${FILESDIR}"/${PN}-1.5.1-gcc44.patch
+ # needed for proper detection of kde-3.5 in the presence
+ # of kde4
+ epatch "${FILESDIR}"/${P}-kde-3.5.patch
# remove flags to let the user decide
for cf in -O2 -ffast-math \
-fexpensive-optimizations \
diff --git a/sci-astronomy/celestia/files/celestia-1.6.0-kde-3.5.patch b/sci-astronomy/celestia/files/celestia-1.6.0-kde-3.5.patch
new file mode 100644
index 000000000000..3069abe591ab
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.6.0-kde-3.5.patch
@@ -0,0 +1,24 @@
+--- acinclude.m4 2009-09-05 10:30:34.000000000 +0200
++++ newacinclude.m4 2009-09-05 20:47:53.000000000 +0200
+@@ -1792,9 +1792,9 @@
+ AC_MSG_CHECKING([for KDE])
+
+ if test "${prefix}" != NONE; then
+- kde_includes=${includedir}
+- KDE_EXPAND_MAKEVAR(ac_kde_includes, includedir)
+-
++ kde_includes=${prefix}/kde/3.5/include
++ ac_kde_includes=$prefix/kde/3.5/include
++
+ kde_libraries=${libdir}
+ KDE_EXPAND_MAKEVAR(ac_kde_libraries, libdir)
+
+@@ -1818,7 +1818,7 @@
+
+ if test -z "$1"; then
+
+-kde_incdirs="$kde_libs_prefix/include /usr/lib/kde/include /usr/local/kde/include /usr/local/include /usr/kde/include /usr/include/kde /usr/include /opt/kde3/include /opt/kde/include $x_includes $qt_includes"
++kde_incdirs="/usr/kde/3.5/include $x_includes $qt_includes"
+ test -n "$KDEDIR" && kde_incdirs="$KDEDIR/include $KDEDIR/include/kde $KDEDIR $kde_incdirs"
+ kde_incdirs="$ac_kde_includes $kde_incdirs"
+ AC_FIND_FILE($kde_check_header, $kde_incdirs, kde_incdir)